cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1805
Views
0
Helpful
3
Replies

Nexus 9K EVPN VXLAN using EBGP as the Underlay

desert7791
Level 1
Level 1

Hi- I am having as issue with the spine receiving type-2 routes. The type-2 route for a connected host is present on the Leaf, but not advertised up to spine. Any help is appreciated.

!-Leaf nve output

VTEP01# show nve interface
Interface: nve1, State: Up, encapsulation: VXLAN
VPC Capability: VPC-VIP-Only [notified]
Local Router MAC: 5000.0007.0007
Host Learning Mode: Control-Plane
Source-Interface: loopback1 (primary: 10.1.2.3, secondary: 10.1.3.3)

!-end

 

!-Leaf type-2 entry for attached host

VTEP01# show bgp l2vpn evpn route-type 2
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 10.1.1.3:33768 (L2VNI 2001001)
BGP routing table entry for [2]:[0]:[0]:[48]:[0050.7966.6809]:[0]:[0.0.0.0]/216, version 17
Paths: (1 available, best #0)
Flags: (0x000102) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW

Path type: local, path is invalid(rnh not resolved), no labeled nexthop
AS-Path: NONE, path locally originated
10.1.3.3 (inaccessible, metric 4294967295) from 0.0.0.0 (10.1.1.3)
Origin IGP, MED not set, localpref 100, weight 32768
Received label 2001001
Extcommunity: RT:65001:2001001 SOO:10.1.3.3:0 ENCAP:8

BGP routing table entry for [2]:[0]:[0]:[48]:[0050.7966.6809]:[32]:[4.1.1.10]/248, version 10
Paths: (1 available, best #0)
Flags: (0x000102) (high32 00000000) on xmit-list, is not in l2rib/evpn, is not in HW

Path type: local, path is invalid(rnh not resolved), no labeled nexthop
AS-Path: NONE, path locally originated
10.1.3.3 (inaccessible, metric 4294967295) from 0.0.0.0 (10.1.1.3)
Origin IGP, MED not set, localpref 100, weight 32768
Received label 2001001 900001
Extcommunity: RT:65001:101 RT:65001:2001001 SOO:10.1.3.3:0 ENCAP:8
Router MAC:5000.0007.0007

!-end

 

!-begin spine config

hostname SPINE-1

nv overlay evpn
feature bgp
feature pim

ip pim rp-address 100.1.1.1 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8
ip pim anycast-rp 100.1.1.1 10.1.1.1
ip pim anycast-rp 100.1.1.1 10.1.1.2
vlan 1

ip prefix-list LOOP seq 10 permit 10.1.1.1/32
ip prefix-list LOOP seq 20 permit 100.1.1.1/32
route-map DIRECT-ROUTES-MAP permit 10
match ip address prefix-list LOOP
route-map UNCHANGED permit 10
set ip next-hop unchanged

interface Ethernet1/1
no switchport
ip address 10.0.0.0/31
ip pim sparse-mode
no shutdown

interface Ethernet1/2
no switchport
ip address 10.0.0.2/31
ip pim sparse-mode
no shutdown

interface Ethernet1/3
no switchport
ip address 10.0.0.4/31
ip pim sparse-mode
no shutdown

interface Ethernet1/4
no switchport
ip address 10.0.0.6/31
ip pim sparse-mode
no shutdown

interface loopback0
ip address 10.1.1.1/32

interface loopback1
description ANYCAST-RP
ip address 100.1.1.1/32

router bgp 65000
router-id 10.1.1.1
address-family ipv4 unicast
redistribute direct route-map DIRECT-ROUTES-MAP
maximum-paths 2
address-family l2vpn evpn
nexthop route-map UNCHANGED
retain route-target all
neighbor 10.0.0.1
remote-as 65001
address-family ipv4 unicast
allowas-in 3
disable-peer-as-check
send-community
send-community extended
neighbor 10.1.1.3
remote-as 65001
update-source loopback0
ebgp-multihop 3
address-family l2vpn evpn
disable-peer-as-check
send-community
send-community extended
route-map UNCHANGED out

!-end spine

 

!-begin leaf

nv overlay evpn
feature bgp
feature pim
feature fabric forwarding
feature interface-vlan
feature vn-segment-vlan-based
feature lacp
feature vpc
feature nv overlay

fabric forwarding anycast-gateway-mac 0000.2222.3333
ip pim rp-address 100.1.1.1 group-list 224.0.0.0/4
ip pim ssm range 232.0.0.0/8

vlan 101
vn-segment 900001
vlan 1001
vn-segment 2001001
vlan 1002
vn-segment 2001002
vlan 3965
name vpcPeerIbgp
vlan 3966
name vpcKeepAlive
vlan 3967
name vpcPeerLink

ip prefix-list LOOP seq 10 permit 10.1.1.3/32
ip prefix-list LOOP seq 20 permit 10.1.2.3/32
route-map DIRECT-ROUTES-MAP permit 10
match ip address prefix-list LOOP-ZERO
route-map SET-PEER-AS-NEXTHOP permit 10
set ip next-hop peer-address
vrf context keepalive

vrf context vxlan-900001
vni 900001
rd auto
address-family ipv4 unicast
route-target import 65001:101
route-target import 65001:101 evpn
route-target export 65001:101
route-target export 65001:101 evpn
address-family ipv6 unicast
route-target import 65001:101
route-target import 65001:101 evpn
route-target export 65001:101
route-target export 65001:101 evpn
vpc domain 1
role priority 1
system-priority 4000
peer-keepalive destination 192.168.0.2 source 192.168.0.1 vrf keepalive
peer-gateway
layer3 peer-router

interface Vlan101
no shutdown
vrf member vxlan-900001
ip forward

interface Vlan1001
no shutdown
vrf member vxlan-900001
ip address 4.1.1.1/24
ipv6 address 4:1:0:1::1/64
fabric forwarding mode anycast-gateway

interface Vlan1002
no shutdown
vrf member vxlan-900001
ip address 4.2.2.1/24
ipv6 address 4:2:0:1::1/64
fabric forwarding mode anycast-gateway

interface Vlan3965
no shutdown
no ip redirects
ip address 192.168.1.1/30
no ipv6 redirects

interface Vlan3966
no shutdown
vrf member keepalive
no ip redirects
ip address 192.168.0.1/30
no ipv6 redirects

interface port-channel1
description vpc peer link
switchport mode trunk
switchport trunk allowed vlan 3965,3967
spanning-tree port type network
vpc peer-link

interface nve1
no shutdown
host-reachability protocol bgp
source-interface loopback1
member vni 900001 associate-vrf
member vni 2001001
mcast-group 239.0.0.1
member vni 2001002
mcast-group 239.0.0.1

interface Ethernet1/1
no switchport
ip address 10.0.0.1/31
ip pim sparse-mode
no shutdown

interface Ethernet1/3
switchport access vlan 1001

interface Ethernet1/6
switchport access vlan 3966

interface Ethernet1/7
description vpc peer link
switchport mode trunk
switchport trunk allowed vlan 3965,3967
channel-group 1 mode active

interface Ethernet1/8
description vpc peer link
switchport mode trunk
switchport trunk allowed vlan 3965,3967
channel-group 1 mode active

interface loopback0
ip address 10.1.1.3/32
ip pim sparse-mode

interface loopback1
ip address 10.1.2.3/32
ip address 10.1.3.3/32 secondary
ip pim sparse-mode

router bgp 65001
router-id 10.1.1.3
address-family ipv4 unicast
redistribute direct route-map DIRECT-ROUTES-MAP
maximum-paths 2
address-family l2vpn evpn
neighbor 10.0.0.0
remote-as 65000
address-family ipv4 unicast
allowas-in 3
send-community
send-community extended
neighbor 10.1.1.1
remote-as 65000
update-source loopback0
ebgp-multihop 3
address-family l2vpn evpn
allowas-in 3
send-community
send-community extended
vrf vxlan-900001
evpn
vni 30000 l2
rd auto
route-target import auto
route-target export auto
vni 2001001 l2
rd auto
route-target import auto
route-target export auto
vni 2001002 l2
rd auto
route-target import auto
route-target export auto

!-end Leaf

 

3 Replies 3

Hello,

 

at first glance, you are missing 'ip pim sparse-mode' on the loopbacks of your spine:

 

interface loopback0
ip address 10.1.1.1/32

--> ip pim sparse-mode

!

interface loopback1
description ANYCAST-RP
ip address 100.1.1.1/32

--> ip pim sparse-mode

Alexey
Cisco Employee
Cisco Employee

Your prefix list on the LEAF is wrong (or match statement in the route-map)

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello desert7791,

I agree with Alexej

see the following section of first show output

>>Path type: local, path is invalid(rnh not resolved), no labeled nexthop
AS-Path: NONE, path locally originated
>>>10.1.3.3 (inaccessible, metric 4294967295) from 0.0.0.0 (10.1.1.3)

 

on the other leaf node you are not advertising the loop1 secondary address 10.1.3.3 in AF IPv4 unicast that should be your underlay.

The prefix-list LOOP needs to allow also 10.1.3.3/32 and must be called in the route-map named DIRECT-ROUTES-MAP

 

or you can simply use

network 10.1.3.3 255.255.255.255

in router bgp address family ipv4 unicast config mode

 

Hope to help

Giuseppe

 

Review Cisco Networking for a $25 gift card