03-15-2005 12:28 PM - edited 03-03-2019 09:03 AM
Ladies/Gentlemen,
I've recently acquired my CCNA and realize how much I still need to learn.
Here's what I'd like some help with.
I'd like to setup my 1700 series with my home DSL. I've already setup all the basics (DHCP IP on the 'WAN' WIC and static private on the internal WIC) but I need help with configuring NAT.
Can someone give me the ABC's of setting up NAT? Primarily, what is the sequence of commands required to connect one subnet to another.
Please do not point me to some very large document. I'll learn much faster if I can get it working THEN read the large documents.
Thanks,
Tom DaBeginner
03-15-2005 02:43 PM
03-15-2005 02:45 PM
Hello,
basically, you need to define an inside and an outside interface, and an entry that defines what is being translated to what. I guess the easiest way to configure this is to look at a sample configuration:
In this configuration, all your inside addresses will get translated to whatever IP address is given by your provider to your ADSL connection. Obviously, your addressing might be different, but you get the idea...
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
-->ip nat inside
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Dialer0
ip address dhcp
ip accounting output-packets
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
-->ip nat outside
!
-->ip nat inside source list 1 interface Dialer0 overload
-->access-list 1 permit 192.168.1.0 0.0.0.255
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
dialer-list 1 protocol ip permit
!
end
HTH,
GP
03-16-2005 06:12 AM
Thank you very much!!!
It'll be working in a couple hours!
t
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide