08-15-2021 09:38 PM
Hello All,
I want to migrate my Cisco router from 2811 to 4321. The problem is, former router (2811) has following commands configured:
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.1533
description ***Wateen Primary_12Mbps L3VPN Data***
encapsulation dot1Q 1533
ip address 192.168.x.x 255.255.255.252
!
interface GigabitEthernet0/0.1534
description ***Wateen Primary_20Mbps L2BGP***
encapsulation dot1Q 1534
ip address 192.168.x.x 255.255.255.252
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1529
description ***Wateen Secondary_12Mbps L3VPN Data***
encapsulation dot1Q 1529
ip address 192.168.x.x 255.255.255.252
!
interface GigabitEthernet0/1.1535
description ***Wateen Secondary_20Mbps L2BGP***
encapsulation dot1Q 1535
ip address 192.168.x.x 255.255.255.252
!
interface FastEthernet0/1/0
ip address 103.x.x.x 255.255.x.x
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
----------------
Now the same command for Auto speed and auto duplex can't be configured at 4321 side. So I configured auto negotiation.
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/0/0.1533
description ***Wateen Primary_12Mbps L3VPN Data***
encapsulation dot1Q 1533
ip address 192.168.x.x 255.255.255.252
!
interface GigabitEthernet0/0/0.1534
description ***Wateen Primary_20Mbps L2BGP***
encapsulation dot1Q 1534
ip address 192.168.x.x 255.255.255.252
!
interface GigabitEthernet0/0/1
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1.185
description ***HO-RTR--->HO-FW***
encapsulation dot1Q 185
ip address 103.x.x.x 255.255.x.x
!
interface GigabitEthernet0/0/1.11
encapsulation dot1Q 11
ip address 192.168.x.x 255.255.255.0
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
interface GigabitEthernet0.1529
description ***Wateen Secondary_12Mbps L3VPN Data***
encapsulation dot1Q 1529
ip address 192.168.x.x 255.255.255.252
!
interface GigabitEthernet0.1535
description ***Wateen Secondary_20Mbps L2BGP***
encapsulation dot1Q 1535
ip address 192.168.x.x 255.255.255.252
!
When I deploy my new 4321 router, it's ports Gig 0 and Gig 0/0/1 go Up while the port Gig 0/0/0 goes down.
How can I tackle the issue?
The router one other end is also configured for auto speed and auto duplex.
08-15-2021 11:06 PM
08-15-2021 11:42 PM
Hello,
I assume these are copper ports (as obviously you cannot set the duplex on fiber linke)...
I remember a similar case from a few years ago. Try the following command sequence:
4321#conf t
4321(config)#interface GigabitEthernet0/0/1
4321(config-if)#shut
4321(config-if)no negotiation auto
4321(config-if)ethernet oam mode active
4321(config-if)no shut
Then check if the port comes up and lets you set speed and duplex.
speed x
duplex x
08-16-2021 12:52 AM
hi,
what's the adjacent device connected to your 4321 G0/0/0?
i assume this is facing the service provider. check with your provider what's their device speed/duplex setting and configure the same.
int Gig 0/0/0
no negotiation auto
speed 100
duplex full
08-16-2021 02:38 AM
Thanks for your help.
The configuration on adjacent router is as below:
interface FastEthernet0/0
description ***Wateen_12Mbps L3VPN Data***
ip address 192.168.x.x 255.255.x.x
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.x.x.x 255.255.x.x
duplex auto
speed auto
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide