01-12-2011 02:27 AM - edited 03-04-2019 11:03 AM
Hi all,
I have 3 routers running OSPF (R1,R2 and R4. Picture R4 as a hub in a hub and spoke diagram). R4 is an ASBR which is connected to another router (R3), and is running EIGRP between itself and R3. On R4, i have configured route redistribution both ways;
router eigrp 1
redistribute ospf 1
network 4.4.4.4 0.0.0.0
network 192.168.43.4 0.0.0.0
default-metric 100000 5100 255 1 1500
no auto-summary
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
redistribute eigrp 1 subnets route-map EIGRP_TOO_OSPF
network 172.14.0.2 0.0.0.0 area 0
network 172.42.0.4 0.0.0.0 area 0
network 192.168.1.4 0.0.0.0 area 0
On R3, I cannot see any EIGRP routers being redistributed from OSPF. The only EIGRP route I can see if the 4.4.4.4 advertisement.
R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
100.0.0.0/32 is subnetted, 1 subnets
C 100.1.1.1 is directly connected, Loopback0
4.0.0.0/24 is subnetted, 1 subnets
D 4.4.4.0 [90/156160] via 192.168.43.4, 01:59:40, FastEthernet0/0
192.168.43.0/29 is subnetted, 1 subnets
C 192.168.43.0 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 4 subnets
C 10.101.4.0 is directly connected, Loopback4
C 10.101.3.0 is directly connected, Loopback3
C 10.101.2.0 is directly connected, Loopback2
C 10.101.1.0 is directly connected, Loopback1
If I log onto R1 or R2, I can see the EIGRP routes being advertised into the OSPF routing domain;
R1#show ip route ospf
4.0.0.0/24 is subnetted, 1 subnets
O E2 4.4.4.0 [110/20] via 172.14.0.2, 01:33:09, Serial0/1
192.168.43.0/29 is subnetted, 1 subnets
O E2 192.168.43.0 [110/20] via 172.14.0.2, 01:33:09, Serial0/1
172.42.0.0/29 is subnetted, 1 subnets
O 172.42.0.0 [110/65] via 172.14.0.2, 02:38:19, Serial0/1
[110/65] via 172.12.0.2, 02:38:19, Serial0/0
10.0.0.0/24 is subnetted, 4 subnets
O E2 10.101.4.0 [110/666] via 172.14.0.2, 01:35:09, Serial0/1
O E2 10.101.3.0 [110/20] via 172.14.0.2, 01:33:09, Serial0/1
O E1 10.101.2.0 [110/84] via 172.14.0.2, 00:29:47, Serial0/1
O E2 10.101.1.0 [110/20] via 172.14.0.2, 01:33:09, Serial0/1
I made sure I wasnt missing setting the metrics under EIGRP. Am i missing something here.....?
Thanks,
DK
Solved! Go to Solution.
01-12-2011 02:13 PM
On both R3 and R4 you have a loopback interface with IP address 100.1.1.1
Because this is the highest IP address on a loopback interface for both routers they both use this IP address as the router-id for EIGRP.
This won't cause any problems for internal EIGRP routes but it will for external redistributed EIGRP routes.
See also: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800949ab.shtml
01-12-2011 02:48 AM
There are no routes matching the network statements, they are all /32.
You must configure the masks for the network statements to match the actual subnets.
If this does not resolve the problem, please post a picture of your topology.
regards,
Leo
01-12-2011 03:09 AM
Hi Leo,
Im advertising the below loopbacks into OSPF from R1. These are in area 1. I can see these at inter-area routes on R4. If they are seen by R4 as OSPF routes, then shouldnt they be redistrubting into EIGRP as per the redistribution command under the EIGRP process?
interface Loopback0
ip address 100.1.1.1 255.255.255.255
!
interface Loopback10
ip address 1.1.1.1 255.255.255.0
!
interface Loopback110
ip address 172.172.10.1 255.255.255.0
!
interface Loopback120
ip address 172.172.20.1 255.255.255.0
!
interface Loopback130
ip address 172.172.30.1 255.255.255.0
R4#show ip route ospf
172.172.0.0/32 is subnetted, 3 subnets
O IA 172.172.10.1 [110/65] via 172.14.0.1, 03:22:52, Serial0/0
O IA 172.172.20.1 [110/65] via 172.14.0.1, 03:22:52, Serial0/0
O IA 172.172.30.1 [110/65] via 172.14.0.1, 03:22:52, Serial0/0
172.12.0.0/30 is subnetted, 1 subnets
O 172.12.0.0 [110/65] via 172.42.0.2, 03:22:52, FastEthernet0/1
So i'm not sure what you mean by matching the network statements,......
01-12-2011 03:39 AM
The second network which is elegible to redistribution (192.168.43.0) is connected on R4 and is redistributed as expected.
That's why you are seeing it as an E2 on R1.
As for the confusion, I was mislead by the 10.0.0.0/24 under sh ip routes.
Also, I saw only later these were outputs from different routers.
A bit more info, like the drawing you now provided might have improved my response.
regards,
Leo
01-12-2011 03:51 AM
Leo,
I have removed the route-map but this didnt help. The route-map has nothing to do with EIGRP. The route-map is used under the OSPF process for the sole purpose of redistribution into OSPF from another routing protocol, which I know is working because I have set match and set statements.
I have attached the configs if that helps.
Thanks
01-12-2011 04:03 AM
Thanks for the configs.
I will get back on this one after some labbing.
regards,
Leo
01-12-2011 09:57 AM
Hi Daniel,
On R3 and R4 , do you see these ospf routes on the eigrp topology table? #sh ip eigrp topology x.x.x.x
01-12-2011 01:36 PM
Hi Rob,
I only see the OSPF routes on R4's EIGRP topology table. R3 is only showing connected and the single 4.4.4.0/24 network which I purposely advertised to make sure EIGRP was working between R3 and R4.
01-12-2011 02:13 PM
On both R3 and R4 you have a loopback interface with IP address 100.1.1.1
Because this is the highest IP address on a loopback interface for both routers they both use this IP address as the router-id for EIGRP.
This won't cause any problems for internal EIGRP routes but it will for external redistributed EIGRP routes.
See also: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800949ab.shtml
01-12-2011 11:44 PM
This is indeed true. What happens is the routes are entered in the eigrp topology on R4 but due to the above mentioned reason, they are not advertized to R3. Actually it is not the redistribution which is not working but the routing between R3 and R4 is broken.
regards,
Leo
01-13-2011 12:29 AM
Thank you for the info,. I changed the router-id on R3 and can now see all the external routes. I haven't had time to read the link you posted in your reply, but I most definately will.
Thanks to the others for their input. Much appreciated.
Thanks
DK
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide