cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5888
Views
65
Helpful
15
Replies

OSPF 4 router configuration problems in Packet Tracer

pmtp94
Level 1
Level 1

Hello,

I'm currently working on an exercise in Packet Tracer with the following layout:

Network layout

I've connected the 4 routers via serial and created 4 different networks between them.

I've also configured OSPF the following way:

Router00Router01Router02Router03

The network works fine this way, the problems begin when I start removing connections for testing.

For example:

.If network 192.168.3.0 goes down, Router01 can't reach network 192.168.4.0

.If network 192.168.6.0 goes down, Router01 can't reach network 192.168.5.0

.If network 192.168.4.0 goes down, Router02 can't reach network 192.168.3.0

.If network 192.168.5.0 goes down, Router02 can't reach network 192.168.6.0

Is this normal behavior? and is there any solution to this problem? can I make this network work even if any of the inter Router networks go down?

Sorry if there is any lack of information, I'll post more if necessary. I've also included the project file if you want to check it out.

Thank you,

Pedro

15 Replies 15

Hello
Looking at this it should work!
Did you leave enough time for the dead timers to initiate to tear down the adjacency (default is 40 secs)

If so i am wondering a mis-configuration somewhere which would produce a discontinuous area but I cannot open the attach file to check, By default all serial interfaces are P2P - I am assuming they are this?

Just to confirm:
R1 - all interfaces = area 0
R2 /4- ABR
R3 - All interfaces = area1

All interconnects are ospf P2P

If, so please configure area 1 as a totally stub area and test again.

rtr 2/4
router ospf1
area 1 sub no-summary
no default-information originate

rtr 3
router ospf 1
area 1 stub 

Lastly -remove the default-information originate from rtr 2/4 which are the abrs as its not doing anything.

res
Paul 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul, thank you for your input,

I always fast forward a good amount before I do any testing, so the dead timers shouldn't be the issue.

Yes, all the connections are P2P:

Net 3 Type

Net 4 Type

Net 5 Type

Net 6 Type

I've done everything you've said but I still can't get all the routers to communicate when one of the connections goes down.

The routers now look like this:

Router 1.1.1.1Router 2.2.2.2Router 3.3.3.34.4.4.4

Checking the border routers on router 3.3.3.3:

Border Routers

But, for example, if network 192.168.3.0 goes down, router 4.4.4.4 can't communicate with router 1.1.1.1 (I always fast forward a good amount between tests):

Net 3 DownConnection Failed

If you need any more information feel free to ask.

Once again thank you for your help,

Peter

Hello,

for now, I am concentrating on networks 192.168.3.0 and 192.168.4.0, the links between R1 and R4, and R1 and R2, respectively.

If either of these networks go down, you are basically dealing with a partitioned backbone (area 0). To remedy this, create a virtual link between R4 and R2. 

I have added loopback interfaces to all routers to simplify the virtual link creation. The configs would look like this:

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.3.1 255.255.255.0
clock rate 64000
!
interface Serial0/0/1
ip address 192.168.4.2 255.255.255.0
clock rate 2000000
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0/0
ip address 192.168.4.1 255.255.255.0
clock rate 64000
!
interface Serial0/0/1
ip address 192.168.5.2 255.255.255.0
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 1 virtual-link 4.4.4.4
network 192.168.5.0 0.0.0.255 area 1
network 2.2.2.2 0.0.0.0 area 1
network 192.168.4.0 0.0.0.255 area 0

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.7.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.5.1 255.255.255.0
clock rate 64000
!
interface Serial0/0/1
ip address 192.168.6.2 255.255.255.0
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 192.168.6.0 0.0.0.255 area 1
network 192.168.7.0 0.0.0.255 area 1
network 192.168.5.0 0.0.0.255 area 1
network 3.3.3.3 0.0.0.0 area 1

R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0/0
ip address 192.168.6.1 255.255.255.0
clock rate 64000
!
interface Serial0/0/1
ip address 192.168.3.2 255.255.255.0
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
area 1 virtual-link 2.2.2.2
network 192.168.3.0 0.0.0.255 area 0
network 192.168.6.0 0.0.0.255 area 1
network 4.4.4.4 0.0.0.0 area 1

@Gpauwen


If either of these networks go down, you are basically dealing with a partitioned backbone (area 0

Tend to disgree- Unless I am mistaken =Both rtr 2/4 are ABR' between area0 and area 1  - if with one those links go down the area0 isnt partitioned as the other link still has reachabitily to area0 - if both go down then it would occur.

However I have not seen the actual config from the OP to check the current config so it might be I have missed something like the rids being ospf enabled and in the wrong area?

res
Paul

.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Paul,

I labbed this in GNS3 as well. The link being down apparently doesn't change the role of R4 or R2 as ABRs. The only way to NOT make it an ABR is to completely remove the area 0 configuration from R2 or R4, which is not what happens when one of the links is down. I am not sure if this is RFC to-be-expected behavior, but the VL is, at least according to my findings, the only way to remedy this.

A bit weird I admit...

Hello
I haven't labbed it - But it must be due with the way rids are being advertised  (ie: loopbacks in wrong area)

Can you remove the rids from ospf and clear the process and test again - it should work given the topology provided

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I removed the IDs...same thing. As soon as the area 0 link goes down, connectivty to anything inter-area is lost. The only explanation I have is that the ABR remains an ABR and hence expects a link to the backbone.

To be honest, I spent the better part of the last two days labbing this, with serial links, Ethernet links, even frame relay links, OSPF point-to-point, broadcast, etc.; but the outcome was always the same. Without the VL, it doesn't work.

Hello
Humm....Did you wait for the adjacency dead interval before testing connectivity?  P2P = 40 secs


res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Yes. Worse yet, R1 even loses all intra-area routes when one of the links go down. The OP has included the .pkt file, you can download Packet Tracer and see the entire thing. 

Hello
I cannot read that pck file - however just labbed this , basic config from what i can see in OP - results show connectivity is resilient, with or without rids in ospf process.


@pmtp34 -  can you re-post your config maybe in a txt file so we can verify your configuration

Also please review attached file.from my testing

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi, thank you both very much for the help,

@pdriver what version packet tracer are you running? I'm using Student version 6.2. Will it help if I save as .PKZ?

I will attach the .PKZ and all the router configs in .txt files.

Note - When a link goes down, the connection between PC00 & PC01 still works, but not from router to router (inter-area).

Once again, thank you for the help,

Pedro

Hello

Can you do the following:
rtr 0
router ospf 1
 no network 192.168.1.0 0.0.0.255 area 0
 no network 192.168.3.0 0.0.0.255 area 0
 no network 192.168.4.0 0.0.0.255 area 0
 network 192.168.1.1 0.0.0.0 area 0
 network 192.168.3.1 0.0.0.0 area 0
 network 192.168.4.2 0.0.0.0 area 0



rtr1
router ospf 1
 no area 1 stub no-summary
 no network 192.168.6.0 0.0.0.255 area 1
 no network 192.168.3.0 0.0.0.255 area 0
 network 192.168.6.1 0.0.0.0 area 1
 network 192.168.3.2 0.0.0.0 area 0


rt2
 router ospf 1
 no area 1 stub no-summary
 no network 192.168.5.0 0.0.0.255 area 1
 no network 192.168.4.0 0.0.0.255 area 0
 network 192.168.5.2 0.0.0.0 area 1
 network 192.168.4.1 0.0.0.0 area 0


 No ip route 0.0.0.0 0.0.0.0 Null0


rtr3
router ospf 1
 no area 1 stub
 no network 192.168.6.0 0.0.0.255 area 1
 no network 192.168.7.0 0.0.0.255 area 1
 no network 192.168.5.0 0.0.0.255 area 1
 network 192.168.6.2 0.0.0.0 area 1
 network 192.168.7.1 0.0.0.0 area 1
 network 192.168.5.1 0.0.0.0 area 1

clear the ospf process and test.

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul,

I've tried that configuration and it still doesn't work. The same result as before.

Meanwhile, I've installed GNS3 (an emulator) and created a similar layout, with just the 4 routers. I've used the initial configuration you suggested with area 1 as a stub and it works. If any of the links go down, I can still ping from any router to the other.

Could this be a weird bug with packet tracer?

Thank you,

Pedro

Hello
Yes I would say so, I tested on real hardware and it worked as expected

FYI - It would also work just fine without the stub area

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul