cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
256
Views
0
Helpful
7
Replies
Highlighted
Beginner

OSPF adjaceny and route learning

Hi,

I have a scenario where the routes on my core2 at site B are learned from all the 4 VLAN interfaces on Core1 at SiteA. Attached the NW diagram for your reference.

O E1 10.0.0.0/16 [110/23] via 172.16.3.130, 5d03h, Vlan104
                            [110/23] via 10.158.216.2, 5d03h, Vlan216
                             [110/23] via 10.158.214.2, 5d03h, Vlan214
                             [110/23] via 10.158.11.161, 5d03h, Vlan1


O E1 10.0.0.0/17 [110/23] via 172.16.3.130, 5d03h, Vlan104
                            [110/23] via 10.158.216.2, 5d03h, Vlan216
                            [110/23] via 10.158.214.2, 5d03h, Vlan214
                            [110/23] via 10.158.11.161, 5d03h, Vlan1
 

Routes are being learned from core1 to core2 are via172.16.2.130 at SiteB. This is not routable via MPLS, hence remote sites are not able to communicate with the devices attached to Core2. Rest are being advertised. fyi, we are running OSPF between SiteA and SiteB and BGP between SiteA and the rest.

what should be done on core1 so that the routes are learned via other vlan's except 172.16.3.130? should i define cost on the vlan 104 on core1 or use passive interface command under the svi ? pls advise.

Thanks,

Sridhar

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Mentor

Hello

Hello

Looks like you have ospf enabled on all theses vlans which seems unnecessary, If you dont require this then you can make them passive to ospf as such they wont create adjacency's

router ospf xx
passive interface vlan 104

or
router ospf xx
passive interface default (this makes all interfaces passive and not form adjacency)
no passive interfaces vlan 216
no passive interfaces vlan 214
no passive interfaces vlan 1

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

7 REPLIES 7
Highlighted
VIP Advisor

Hi

Hi

It will be a pleasure to assist you, could you please provide more details on the diagram? I would like to be sure where 172.16.2.130 is. or analyse the packet flow. 

:-)

Highlighted
Beginner

172.16.2.130 is at siteB

172.16.2.130 is at siteB

Highlighted
Beginner

Thq all the issue has been

Thq all the issue has been resolved after making the non routebale SVI's passive in OSPF configuration.

Highlighted
VIP Mentor

Hello

Hello

Looks like you have ospf enabled on all theses vlans which seems unnecessary, If you dont require this then you can make them passive to ospf as such they wont create adjacency's

router ospf xx
passive interface vlan 104

or
router ospf xx
passive interface default (this makes all interfaces passive and not form adjacency)
no passive interfaces vlan 216
no passive interfaces vlan 214
no passive interfaces vlan 1

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Highlighted
Beginner

should i apply passive

should i apply passive interface vlan 104 on both core swicthes at SiteB. so that if the primary link is down, then core-1 should learn from Core2 via the svi's other than vlan 104.

Highlighted
VIP Mentor

Hello

Hello

if you don't need ospf to form adjecency on vlan 104 then yes make that svi passive

res

paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

This looks like exactly the

This looks like exactly the same issue that I have experienced before. If that's the case what is happening is OSPF is forming an adjacency between your two core switches over each VLAN, hence you have multiple paths to the same destination. If you make the VLAN's that you don't want traffic to route over passive it should stop the issue.

CreatePlease to create content