cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
211
Views
5
Helpful
4
Replies
Highlighted
Beginner

OSPF did not creat a neighbors relationship

hi 

i am trying to work on my project on gns3 I do everything right but i can't see the OSPF neighbors relationship  between my router and Layer 3 switch 

Topology and configuration as follows 

Router 1 connects to L3S on interface Eth1/0

L3S connects to Router 1 on interface Eth 0/0

Router 1 configuration file

interface Ethernet1/0
ip address 172.58.10.3 255.255.255.240
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 12345
full-duplex

router ospf 100
router-id 2.2.2.2
log-adjacency-changes
area 0 authentication message-digest
passive-interface default
no passive-interface Ethernet1/0
no passive-interface Ethernet1/1
network 172.58.10.0 0.0.0.0 area 0
network 172.58.20.0 0.0.0.0 area 0

 

L3S conf file

interface Ethernet0/0
no switchport
ip address 172.58.10.1 255.255.255.240
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 12345


router ospf 100
router-id 1.1.1.1
area 0 authentication message-digest
passive-interface default
no passive-interface Ethernet1/1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
network 192.168.40.0 0.0.0.255 area 0
network 192.168.50.0 0.0.0.255 area 0
network 192.168.60.0 0.0.0.255 area 0

 

Looking forward to it thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Expert

Hello,

 

make the changes marked in bold:

 

interface Ethernet1/0
ip address 172.58.10.3 255.255.255.240
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 12345
full-duplex

router ospf 100
router-id 2.2.2.2
log-adjacency-changes
area 0 authentication message-digest
passive-interface default
no passive-interface Ethernet1/0
no passive-interface Ethernet1/1
--> network 172.58.10.0 0.0.0.255 area 0
--> network 172.58.20.0 0.0.0.255 area 0

 

L3S conf file

interface Ethernet0/0
no switchport
ip address 172.58.10.1 255.255.255.240
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 12345


router ospf 100
router-id 1.1.1.1
area 0 authentication message-digest
passive-interface default
no passive-interface Ethernet1/1

--> no passive-interface Ethernet0/0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
network 192.168.40.0 0.0.0.255 area 0
network 192.168.50.0 0.0.0.255 area 0
network 192.168.60.0 0.0.0.255 area 0

--> network 172.58.10.0 0.0.0.255 area 0

View solution in original post

4 REPLIES 4
Highlighted
VIP Expert

Hello,

 

make the changes marked in bold:

 

interface Ethernet1/0
ip address 172.58.10.3 255.255.255.240
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 12345
full-duplex

router ospf 100
router-id 2.2.2.2
log-adjacency-changes
area 0 authentication message-digest
passive-interface default
no passive-interface Ethernet1/0
no passive-interface Ethernet1/1
--> network 172.58.10.0 0.0.0.255 area 0
--> network 172.58.20.0 0.0.0.255 area 0

 

L3S conf file

interface Ethernet0/0
no switchport
ip address 172.58.10.1 255.255.255.240
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 12345


router ospf 100
router-id 1.1.1.1
area 0 authentication message-digest
passive-interface default
no passive-interface Ethernet1/1

--> no passive-interface Ethernet0/0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 0
network 192.168.40.0 0.0.0.255 area 0
network 192.168.50.0 0.0.0.255 area 0
network 192.168.60.0 0.0.0.255 area 0

--> network 172.58.10.0 0.0.0.255 area 0

View solution in original post

Highlighted

thank you very much for you kind replay  it works perfectly 

Highlighted
VIP Mentor

Hello
Suggest to remove area/interface authentication then try to establish ospf adjacency’s  when you do have the adjacency’s append authentication.

If you cannot turn authentication off then do so at the interface level and test again
int x/x
ip ospf authentication null



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
VIP Expert

BTW, both Georg and Paul suggest using an OSPF mask of 0.0.0.255 but as your interface address masks are 255.255.255.240, you might match other interfaces on the same router.  (I.e. any that fall under the /24.)  If that is what you intend, that's fine, but otherwise I would suggest you either match the interface's IP or its specific subnet size.  The former would use an OSPF mask of 0.0.0.0 (and the interface's IP) and the latter an OSPF mask of 0.0.0.15. (and the interface's network prefix)

Another option, with later Cisco IOS OSPF implementations, is to use the interface command "ip ospf process-id area area-id".  Instead of the network statements.