cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3032
Views
0
Helpful
1
Replies

OSPF Process ID change

rmorenobb
Level 1
Level 1

I have a pretty straight forward change I need to make to several devices at one site; I need to change the OSPF process ID. 

 

The site has 2 edge routers, 1 L3 switch stack that connects all 3 floor IDFs all via OSPF. 

 

All devices are using the following OSPF config

 

router ospf 20
router-id 10.0.0.1 (this changes based off of device)
auto-cost reference-bandwidth 10000
area 0 authentication message-digest
passive-interface default
no passive-interface GigabitEthernet1/0/47 (this changes based off of device uplink)
no passive-interface GigabitEthernet1/0/47 (this changes based off of device uplink)
default-information originate
 
I want to change all device(s) OSPF from process 20 to process 100
 
router ospf 100
router-id 10.0.0.1 (this changes based off of device)
auto-cost reference-bandwidth 10000
area 0 authentication message-digest
passive-interface default
no passive-interface GigabitEthernet1/0/47 (this changes based off of device uplink)
no passive-interface GigabitEthernet1/0/47 (this changes based off of device uplink)
default-information originate
 
 
interface uplink configuration looks like this on all devices
 
ip address 10.1.1.1 255.255.255.252
ip ospf message-digest-key 1 md5 7 072416185D0D3F175F10
ip ospf network point-to-point
ip ospf 65400 area 0
 
also all Vlans have OSPF 
 
So, what I'm planning to do is script out the changes and manually apply the script. 
 
I figured I'd start with the 3 Floor IDFs
 
1st floor IDF switch stack change
conf t
no router ospf 20
router ospf 100
router-id 10.2.1.1.1
auto-cost reference-bandwidth 10000
area 0 authentication message-digest
passive-interface default
no passive-interface TenGigabitEthernet1/1/1
no passive-interface TenGigabitEthernet2/1/1
!
int te1/1/1
no ip ospf 20 area 0
ip ospf 100 area 0
!
int te2/1/1
no ip ospf 20 area 0
ip ospf 100 area 0
int vlan 10
no ip ospf 20 area 0
ip ospf 100 area 0
!
end
 
once i have all the floors updated, then i plan to update the layer 3 core switch stack
 
conf t
no router ospf 20
router ospf 100
router-id 10.0.1.1
auto-cost reference-bandwidth 10000
area 0 authentication message-digest
passive-interface default
no passive-interface TenGigabitEthernet1/1/1
no passive-interface TenGigabitEthernet1/1/2
no passive-interface TenGigabitEthernet1/1/3
no passive-interface TenGigabitEthernet1/1/4
default-information originate
!
int range te1/1/1-4
no ip ospf 20 area 0
ip ospf 100 area 0
!
 
And lastly edge routers
 
conf t
no router ospf 20
router ospf 100
router-id 10.4.4.4
auto-cost reference-bandwidth 10000
area 0 authentication message-digest
passive-interface default
no passive-interface GigabitEthernet0/0/0
no passive-interface GigabitEthernet0/0/1
default-information originate metric 100
!
int range gi0/0/0-1
no ip ospf 20 area 0
ip ospf 100 area 0
!
end
 
So, one thing I think I need to add to the end of each is to clear the process ID for re convergence?
I'd like to do this remotely but not sure if I'll lose connectivity to the devices, which is why I figured I'd make the changes to the floor IDF switch stacks and then update the L3 core switch stack than the edge routers. 
 
I'm still doing some research into this, to make this change smooth, and to not lose connectivity to any of the devices.
 
I'm still learning OSPF so I'm a bit hesitant with this change, for those that are knowledgeable in OSPF does this sound like the proper change?
 
 
 
1 Reply 1

luis_cordova
VIP Alumni
VIP Alumni

Hi @rmorenobb ,

 

Things to keep in mind:

In OSPF there may be convergence between devices with different process ID.

Therefore, the convergence will be lost when you delete the process (no router ospf 20).

The convergence will return when you  assign the new process to the interfaces:

int te1/1/1
no ip ospf 20 area 0 <-- this command should not be necessary, because assigning one process replaces the other
ip ospf 100 area 0
 
When you assign the process to the interface, the process will be created automatically, returning convergence.
Then, you can enter the specific process settings.
 
Regards

 

 

Review Cisco Networking for a $25 gift card