06-06-2024 08:20 AM
Hi I have the following topology in GNS3:
Currently only concerned with R1/2/3 which are all in area 0, I have created static routes on R1 as below:
ip route 77.1.0.0 255.255.255.0 66.1.1.2
ip route 77.1.1.0 255.255.255.0 66.1.1.2
ip route 77.1.2.0 255.255.255.0 66.1.1.2
ip route 77.1.3.0 255.255.255.0 66.1.1.2
I have redistributed these into OSPF and have the below config:
router ospf 1
router-id 1.1.1.1
auto-cost reference-bandwidth 100000
area 123 nssa no-summary
summary-address 77.1.0.0 255.255.252.0
redistribute static metric-type 1 subnets
passive-interface default
no passive-interface GigabitEthernet1/0
no passive-interface Loopback0
I want to summarise the 77.1.0.0, 71.1.2.0 and 71.1.3.0 into the summary address summary-address 77.1.0.0 255.255.252.0 but still want to have a specific route to the 71.1.1.0 network, how can i do this?
06-07-2024 12:42 AM
Hello
TBH thinking about it it should make no difference, I was thinking in the reverse, the no-summary on R3 will just advertise a summary default INTO area 123 without it the more specific routes from other areas will be included, so you should be fine.
06-07-2024 01:22 AM
Thanks for your help Paul and MHM I have found a solution to this configured the following prefix list/route map on R1 then used the RM in redistribution of the static routes:
R1#show route-map
route-map OSPF, permit, sequence 10
Match clauses:
ip address prefix-lists: STATIC>OSPF
Set clauses:
metric-type type-1
Policy routing matches: 0 packets, 0 bytes
route-map OSPF, deny, sequence 20
Match clauses:
ip address prefix-lists: DENY>RDIST
Set clauses:
Policy routing matches: 0 packets, 0 bytes
R1#show ip prefix-list
ip prefix-list DENY>RDIST: 3 entries
seq 5 permit 77.1.0.0/24
seq 10 permit 77.1.2.0/24
seq 15 permit 77.1.3.0/24
ip prefix-list STATIC>OSPF: 2 entries
seq 5 permit 77.1.1.0/24
seq 10 permit 77.1.0.0/22
R1#show run | section ospf
ip ospf 1 area 123
ip ospf authentication message-digest
ip ospf authentication-key CISCO
ip ospf priority 100
ip ospf 1 area 123
router ospf 1
router-id 1.1.1.1
auto-cost reference-bandwidth 100000
area 123 nssa no-summary
redistribute static metric-type 1 subnets route-map OSPF
passive-interface default
no passive-interface GigabitEthernet1/0
no passive-interface Loopback0
After this I added a static route to the summary route for null0
R1#show run | section ip route
ip route 77.1.0.0 255.255.252.0 Null0
now showing on R3:
O N1 77.1.0.0/22 [110/121] via 192.168.13.1, 00:00:07, GigabitEthernet1/0
O N1 77.1.1.0/24 [110/121] via 192.168.13.1, 00:00:52, GigabitEthernet1/0
Kind Regards,
Ryan
06-07-2024 06:55 AM
Hello
That's a bit long winded but if it works accordingly good news, I would say though a specific additional summary on the ASBR would have also worked.
Anyway i'm glad you have a solution and thanks for sharing it.
06-07-2024 07:04 AM
You add new static route not summary the static prefix into one
Anyway
You don't need filter by route-map
You can use in ABR
Summary <> not-adv
This will make ABR not translate lsa7 into lsa5
FYI there is summary and leak in bgp but as you ask in ospf sorry there is no such as this
MHM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide