cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2334
Views
3
Helpful
6
Replies

OSPFv3 with frame-relay P-to-Multipoint

ahmedmahmoud22
Level 1
Level 1

While using frame-relay point-to-multipoint network with OSPFv3  on 4 routers , frame-relay mapping with broadcast keyword configured on the all routers, i found that 3 of 4 routers are all adjacent with the fourth only, while it shall be adjacent with all other routers . the config. of the routers as below .

R1 :

interface Serial0/0

ip address 1.1.1.1 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::1/64

ipv6 ospf network point-to-multipoint

ipv6 ospf priority 100

ipv6 ospf 1 area 1

clock rate 2000000

frame-relay map ipv6 FE80::C001:BFF:FEB4:0 202 broadcast

frame-relay map ipv6 FE80::C000:BFF:FEB4:0 203 broadcast

frame-relay map ipv6 FE80::C003:BFF:FEB4:0 201 broadcast

R2 :

interface Serial0/0

ip address 10.1.1.23 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::2/64

ipv6 ospf network point-to-multipoint

ipv6 ospf 1 area 1

clock rate 2000000

frame-relay map ipv6 FE80::C000:BFF:FEB4:0 210 broadcast

frame-relay map ipv6 FE80::C001:BFF:FEB4:0 210 broadcast

frame-relay map ipv6 FE80::C002:BFF:FEB4:0 210 broadcast

R3:

interface Serial0/0

ip address 10.1.3.1 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::3/64

ipv6 ospf network point-to-multipoint

ipv6 ospf priority 0

ipv6 ospf 1 area 1

clock rate 2000000

frame-relay map ipv6 FE80::C002:BFF:FEB4:0 220 broadcast

frame-relay map ipv6 FE80::C000:BFF:FEB4:0 220 broadcast

frame-relay map ipv6 FE80::C003:BFF:FEB4:0 220 broadcast

R4 :

interface Serial0/0

ip address 192.2.2.9 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::4/64

ipv6 ospf network point-to-multipoint

ipv6 ospf priority 0

ipv6 ospf 1 area 1

clock rate 2000000

frame-relay map ipv6 FE80::C001:BFF:FEB4:0 230 broadcast

frame-relay map ipv6 FE80::C003:BFF:FEB4:0 230 broadcast

frame-relay map ipv6 FE80::C002:BFF:FEB4:0 230 broadcast

R2,R3,R4 is adjacent with R1 only , even these routers are having only R1 as a neighbor by Sho ipv ospf neighbor

1 Accepted Solution

Accepted Solutions

It's more of a limitation with the way link-local addressing works in IPv6. FE80::/10 addresses do not route beyond the local link. OSPFv3 only sends updates using this address (in place of the 224.0.0.5 & .6 addresses which were also link local and not routable). The problem comes in that you're expecting to get an adjacency between 2 hosts that are hanging off of a switch with no PVC between the 2 hosts. The problem then comes in that you would need to have a PVC created between each and every site that you would want an adjacency with. Since you're doing this in GNS, create a PVC between 2 routers that aren't getting an adjacency now and then create your mapping for them. Once you do, you'll see that your adjacency will come up.

If you want to post your gns .net file, I can try to play with it today...

HTH,

John

HTH, John *** Please rate all useful posts ***

View solution in original post

6 Replies 6

John Blakley
VIP Alumni
VIP Alumni

Link local addresses don't route beyond the local link. The way to get your issue resolved would be to create new PVCs between the other locations. I'll use R1, R2, and R3 as an example. The easiest way to fix this issue is within the FR switch:

R1 :

interface Serial0/0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::1/64

ipv6 ospf network point-to-multipoint

frame-relay map ipv6 FE80::C001:BFF:FEB4:0 202 broadcast

frame-relay map ipv6 FE80::C000:BFF:FEB4:0 203 broadcast

frame-relay interface-dlci 202

frame-relay interface-dlci 203

R2 :

interface Serial0/0

ip address 10.1.1.23 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::2/64

ipv6 ospf network point-to-multipoint

ipv6 ospf 1 area 1

clock rate 2000000

frame-relay map ipv6 FE80::C000:BFF:FEB4:0 201 broadcast

frame-relay map ipv6 FE80::C001:BFF:FEB4:0 203 broadcast

frame-relay interface-dlci 201

frame-relay interface-dlci 203

R3:

interface Serial0/0

ip address 10.1.3.1 255.255.255.0

encapsulation frame-relay

ipv6 address 2001:DB8:0:1::3/64

ipv6 ospf network point-to-multipoint

clock rate 2000000

frame-relay map ipv6 FE80::C002:BFF:FEB4:0 301 broadcast

frame-relay map ipv6 FE80::C000:BFF:FEB4:0 302 broadcast

frame-relay interface-dlci 301

frame-relay interface-dlci 302

You would need a PVC from

R1 - R2

R1 - R3

R2 - R3

Your maps would change to the bolded above. Basically, if you need an adjacency between all routers with IPv6, you'll need to have a PVC between all routers.

HTH,

John

HTH, John *** Please rate all useful posts ***

Thanks John ,I'd like to clarify that i'm applying this example as a lab practicing for CCIE, this config. is done through GNS3, even if the network is broadcast, the routers are only showing neighborship and adjacency with DR which is router R1, as per the case study, the all routers shall have neighborship with each other .

I am not sure, it may be a limitation of the virtual frame-relay switch in GNS3.

Please advise .

It's more of a limitation with the way link-local addressing works in IPv6. FE80::/10 addresses do not route beyond the local link. OSPFv3 only sends updates using this address (in place of the 224.0.0.5 & .6 addresses which were also link local and not routable). The problem comes in that you're expecting to get an adjacency between 2 hosts that are hanging off of a switch with no PVC between the 2 hosts. The problem then comes in that you would need to have a PVC created between each and every site that you would want an adjacency with. Since you're doing this in GNS, create a PVC between 2 routers that aren't getting an adjacency now and then create your mapping for them. Once you do, you'll see that your adjacency will come up.

If you want to post your gns .net file, I can try to play with it today...

HTH,

John

HTH, John *** Please rate all useful posts ***

Once again,Thanks John, attached is the GNS config. files with .net GNS topology file .Waiting for your reply .

John, Now the problem solved, there was a problem in the virtula frame relay switch config. after modification, now it's fine .. Thank you .

Awesome I'm glad to hear you got it resolved!

Sent from Cisco Technical Support iPhone App

HTH, John *** Please rate all useful posts ***
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card