my configuration:
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface FastEthernet0/0
ip address 10.x.x.x.255.255.0
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
no cdp enable
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
interface ATM0/0/0.1 point-to-point
pvc 0/35
pppoe-client dial-pool-number 1
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ####
ppp chap password %%%%
ppp pap sent-username #### password %%%%
ip classless
ip route 0.x.x.x.0.0.0 Dialer1
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit 10.x.x.x.0.0.255
dialer-list 1 protocol ip permit
i have done troubleshooting using the following:
1. atm packet
*Apr 16 14:20:38.363: ATM0/0/0.1(O):
VCD:0x1 VPI:0x0 VCI:0x23 DM:0x100 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x4D
2. atm events
3. sh dsl int atm 0/0/0
Alcatel 20150 chipset information
ATU-R (DS) ATU-C (US)
Modem Status: Showtime (DMTDSL_SHOWTIME)
DSL Mode: ITU G.992.1 (G.DMT) Annex A
4. debug dialer packet
*Apr 16 14:22:26.183: Di1 DDR: ip (s=10.120.120.200, d=194.x.x.2), 68 bytes, outgoing interesting (ip PERMIT)
*Apr 16 14:22:27.183: Di1 DDR: ip (s=10.120.120.200, d=194.x.x.2), 68 bytes, outgoing interesting (ip PERMIT)
when try to debug ppp (negotiation & authentication) nothing happens. WHY?
it seems like the 2811 does train with the dslam.
thanks