cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
348
Views
0
Helpful
3
Replies

policy-based routing question

ibbsaccess
Level 1
Level 1

I have an edge router that has multiple upstreams and im implementing policy routing to make the appropiate next hops...thats not a problem.

Issue is, i now have to add another step to the route-map to specify that specific source addresses need to be forwarded to a next hop which is over the ethernet interface the route-map is applied to.

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip address 192.168.2.1 255.255.255.0 secondary

ip policy route-map test

!

interface Serial0

ip address 200.200.200.2 255.255.255.252

!

interface Serial1

ip address 201.201.201.2 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 201.201.201.1

ip route 10.1.1.0 255.255.255.0 192.168.2.2

ip route 10.1.2.0 255.255.255.0 192.168.2.2

!

access-list 100 permit ip 10.1.1.0 0.0.0.255

access-list 101 permit ip 10.1.2.0 0.0.0.255

!

route-map test permit 10

match ip address 100

set ip next-hop 200.200.200.1

!

route-map test permit 20 <--- in question

match ip address 101

set ip next-hop 192.168.1.100

I need to force traffic from say the 10.1.1.0/24 network out the serial interface to an egress provider.

However, at the same time i need to force traffic rcvd sourcing from 10.1.2.0/24 to be forwarded to another device on the LAN which happens to be connected over the same and only FastEthernet on this router.

Question - can this be implemented or is there a limitation with PBR that you cannot specify a next-hop in the route-map if it is over the interface to which the ip policy was applied to.

3 Replies 3

Richard Burts
Hall of Fame
Hall of Fame

I have not done this particular issue in PBR so I can not answer from direct personal experience. But I have done a fair amount of PBR and I have never heard that there is any restriction like that. So I believe that it will work. Give it a try and let us know.

HTH

Rick

HTH

Rick

ok, I will do that. I thought i had run into a problem doing this before and wanted to see if anyone had hit a roadblock like i thought i had. Ill give it a shot in production and let you guys know if it worked.

cheers,

Derek

srath
Level 1
Level 1

It should work.

You will get a lot of icmp redirects but it is possible. If you are still having a problem, try adding a loopback interface. Route the 10.1.2.0/24 network to the looback interface, then allow your normal routing to route it back to the faste :)

Review Cisco Networking products for a $25 gift card