cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2669
Views
0
Helpful
1
Replies

PPPoE configuration on Cisco 1941

netopia
Beginner
Beginner

I have recently gotten a cisco 1941 router running version 15.1(3)T, and am trying to configure the router as a PPPoE server for access via a vlan on one of the gigabit ethernet ports.

I currently have a cisco 2620 router (version 11.3(2)XA4) with the following relevant configurations:

vpdn enable

vpdn multihop

vpdn domain-delimiter @ suffix

!

vpdn-group pppoe

accept-dialin

  protocol pppoe

  virtual-template 1

!

interface Loopback1

description loopback for PPPoE

ip address 163.176.94.193 255.255.255.192

!

interface FastEthernet0/0.301

description PPPoE interface

encapsulation dot1Q 301

no ip route-cache

no ip mroute-cache

pppoe enable

!

interface Virtual-Template1

description PPPoE interface

mtu 1492

ip unnumbered Loopback1

ip mroute-cache

peer default ip address pool PPPnet

ppp authentication chap pap

ppp ipcp dns 163.176.4.23

!

I am trying to duplicate this (all but IP addresses) on the new router, but there are some options that do not seem to exist in this particular software/hardware combination.  Specifically,

vpdn-group pppoe

accept-dialin

  protocol pppoe

does not accept "pppoe" as a protocol, only allowing l2tp.  I am hoping that someone can tell me what has changed, and what the proper configuration is.

Thanks,

Ben Brown

1 Reply 1

Nandan Mathure
Beginner
Beginner

@ Ben

bba (broadband association) group config is used instead of vpdn

================================

R1(config)#bba-group pppoe global

================================

so your config will be as follows:

!

bba-group pppoe global

virtual-template 1

!

!

interface Loopback1

description loopback for PPPoE

ip address 163.176.94.193 255.255.255.192

!

!

interface FastEthernet0/0.301

description PPPoE interface

encapsulation dot1Q 301

no ip route-cache

no ip mroute-cache

pppoe enable group global

!

interface Virtual-Template1

description PPPoE interface

mtu 1492

ip unnumbered Loopback1

peer default ip address pool PPPnet

ppp authentication chap pap

ppp ipcp dns 163.176.4.23

!

===================================

R1(config)#interface FastEthernet0/0.301

R1(config-subif)#pppoe enable group global

===================================

I have highligted the changes in  between ===. everything else remains same. Plz let me know if this helped. Thanks.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers