cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1080
Views
0
Helpful
4
Replies

PPPoE configuration

kolomja3
Level 1
Level 1

Hey guys,

I'm trying to setup my home internet on Cisco router. ISP is via PPPoE connection - NBN HFC (cable modem).

Here is my configuration and debug:

 

interface GigabitEthernet1
no ip address
pppoe enable group 42
pppoe-client dial-pool-number 42


interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 42
dialer-group 42
ppp authentication chap callin
ppp chap hostname MY_ISP_NAME
ppp chap password MY_ISP_PASSWORD
!

IR800# sh pppoe session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 0 0000.0000.0000 Gi1 Di1 N/A PADISNT
0000.0000.0000

IR800# sh ip int brief


GigabitEthernet1 unassigned YES unset up up
Dialer1 unassigned YES manual up up
Virtual-Access1 unassigned YES unset up up
Vlan1 unassigned YES unset up up

IR800#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Feb 27 06:41:32.179: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing uninteresting (dialer-list 42 not defined).
*Feb 27 06:41:34.180: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing uninteresting (dialer-list 42 not defined)..
*Feb 27 06:41:36.193: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing uninteresting (dialer-list 42 not defined).
*Feb 27 06:41:38.191: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing uninteresting (dialer-list 42 not defined).

 

Any advice why I can't receive PADO packet from ISP or why Dialer 1 int. can't find correct dialer-list?

 

Thank you

4 Replies 4

Hello,

do you have 'dialer-list 42 protocol ip permit' configured ? Post the full running configuration (sh run) of your router...

Hello George,

Here is full config:

! Last configuration change at 09:14:26 UTC Mon Feb 27 2023
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IR800
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ppp syslog enable
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 11
!
no ignition enable
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
license udi pid IR829GW-LTE-GA-ZK9 sn FGL2436L87A
!
!
!
redundancy

!
!
!
!
!
controller Cellular 0
lte failovertimer 5
lte modem link-recovery disable
no cdp run
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
no ip address
shutdown
!
interface GigabitEthernet1
no ip address
pppoe enable group 42
pppoe-client dial-pool-number 42
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
ipv6 address autoconfig
!
interface Cellular1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
no ip address
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 42
dialer-group 42
ppp authentication chap callin
ppp chap hostname XXXX
ppp chap password YYYY
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
dialer-list 42 protocol ip permit
ipv6 ioam timestamp
!
!
!
control-plane
!
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
login
transport input none
!
no scheduler max-task-time
no iox hdm-enable
iox client enable interface GigabitEthernet5
no iox recovery-enable
!
!
!
!
!
!
!
end

Hello,

the config looks good, at first glance. Run the debug commands below and post the output (after shut/no shut the dialer interface):

debug ppp authentication

debug ppp negotiation

debug pppoe event

Hello,

All these debug options doesn't create any messages...(debug ppp authentication. negotiation, event)

I've enabled

debug pppoe packets

debug pppoe errors

debug pppoe events

*Feb 28 04:44:04.299: Sending PADI: Interface = GigabitEthernet1
*Feb 28 04:44:04.299: pppoe_send_padi:
contiguous pak, size 60
FF FF FF FF FF FF 64 3A EA 02 18 21 88 63 11 09
00 00 00 10 01 01 00 00 01 03 00 08 6A 00 00 01
00 00 1F 17 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00R800#sh pppoe session
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 0 0000.0000.0000 Gi1 Di1 N/A PADISNT
0000.0000.0000

 

IR800#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Feb 28 05:09:31.699: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:31.699: Di1 DDR: Cannot place call, no dialer string set.
*Feb 28 05:09:33.700: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:33.700: Di1 DDR: Cannot place call, no dialer string set.
*Feb 28 05:09:35.700: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:35.700: Di1 DDR: Cannot place call, no dialer string set.

It's sending PADI frame out of correct interface as broadcast message but it never gets reply from svr.

I've tried cloning int G1 MAC address on my TP-Link router and it works. It doesn't look like issue on ISP side. I've verified with ISP that I can use CHAP authentication as well.

 

Review Cisco Networking for a $25 gift card