cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
248
Views
0
Helpful
12
Replies
Highlighted

Problem with my cisco 897wav-e-k9

hi everyone, i have a problem with my router, i need to connect it via wan and use it like a normal router, i can configure the wan, i can ping some sites, but if i connect my pc via ethernet to the g0 i don't have any connection, and if i try to configure the ip address it gives me some errors

 here is my running configuration:

 

 

router#sh run
Building configuration...

Current configuration : 1569 bytes
!
! Last configuration change at 22:24:23 UTC Sat Mar 21 2020
version 15.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 5
service-module wlan-ap 0 bootimage autonomous
!
!
ip cef
!
!
!
!


!
!
!
!
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid C897VAW-E-K9 sn FCZ1727C0SL
!
!
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
duplex auto
speed auto
!
interface Wlan-GigabitEthernet8
no ip address
!
interface wlan-ap0
description Embedded Service module interface to manage the embedded AP
no ip address
shutdown
!
interface Vlan1
no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Hall of Fame Master

Re: Problem with my cisco 897wav-e-k9

The original poster tells us that " but if i connect my pc via ethernet to the g0 i don't have any connection, and if i try to configure the ip address it gives me some errors". It is pretty clear that this router is treating those interfaces as layer 2 switch ports and as such would refuse any attempt to configure IP addressing on them. @Georg Pauwen has suggested changes to the config and it looks to me like they do provide a workable solution. But the original poster also tells us "I don't really know what commands I must use..."  

 

The original poster told us that he could configure the wan so I assume that he is familiar with how to get into configuration mode. Once in configuration mode the original poster just needs to copy and paste the changes that are suggested such as 

--> ip dhcp excluded-address 192.168.1.1
!
--> ip dhcp pool LAN
--> network 192.168.1.0 255.255.255.0
--> default-router 192.168.1.1
--> dns-server 8.8.8.8

Of course do not include the --> in what you paste. Also some of the commands are to be made in interface config mode and to do that the original poster must include the interface command before inserting the changes suggested by Georg such as 

interface GigabitEthernet0
switchport

and 

interface GigabitEthernet8
ip nat outside

and

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside

Otherwise it should be a straightforward cut and paste the suggested changes into the config. After pasting those changes the original poster should use exit or quit to get out of config mode and should then use the copy running-config startup-config to save the config changes.

HTH

Rick

View solution in original post

Highlighted
Hall of Fame Master

Re: Problem with my cisco 897wav-e-k9

Thank you for the additional information, which is quite helpful. In looking at your pictures I realize that there is a question that Georg or I should have asked much sooner and that question was what gateway (home router) is your router connected to, and what address is your router getting? Now we see that the home router is using network 192.168.1.0. This means that the suggestion that we use 192.168.1.0 for vlan 1 was not correct, and that means that the address translation that we attempted to configure is also not correct. Based on that I suggest that you make these changes in your configuration:

config t

no ip dhcp excluded-address 192.168.1.1
no ip dhcp pool LAN

!

ip dhcp excluded-address 192.168.20.1
ip dhcp pool LAN20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.153
dns-server 8.8.8.8

!

no access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.20.0 0.0.0.255

 

[edit] While I was preparing my response I see that @Georg Pauwen has posted similar suggestions, except there are 2 issues in his DHCP pool, it gives the network as 192.168.1.0 where it should be 192.168.20.0 and it gives default router as 192.168.20.1 where it should be 192.168.20.153

HTH

Rick

View solution in original post

12 REPLIES 12
Highlighted
VIP Mentor

Re: Problem with my cisco 897wav-e-k9

Hello,

 

set your PC to DHCP and make the changes marked in bold to your router configuration:

 

Building configuration...

Current configuration : 1569 bytes
!
! Last configuration change at 22:24:23 UTC Sat Mar 21 2020
version 15.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
service-module wlan-ap 0 bootimage autonomous
!
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
license udi pid C897VAW-E-K9 sn FCZ1727C0SL
!
--> ip dhcp excluded-address 192.168.1.1
!
--> ip dhcp pool LAN
--> network 192.168.1.0 255.255.255.0
--> default-router 192.168.1.1
--> dns-server 8.8.8.8
!
controller VDSL 0
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
!
interface GigabitEthernet0
--> switchport
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
--> ip nat outside
duplex auto
speed auto
!
interface Wlan-GigabitEthernet8
no ip address
!
interface wlan-ap0
description Embedded Service module interface to manage the embedded AP
no ip address
shutdown
!
interface Vlan1
--> ip address 192.168.1.1 255.255.255.0
--> ip nat inside
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
--> ip nat inside source list 1 interface GigabitEthernet8 overload
!
--> ip route 0.0.0.0 0.0.0.0 GigabitEthernet8 dhcp
!
--> access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

Highlighted

Re: Problem with my cisco 897wav-e-k9

Thank you very much Georg, but I don't know the commands, this is my first Cisco router and I don't really know what commands I must use...

Highlighted
Hall of Fame Master

Re: Problem with my cisco 897wav-e-k9

The original poster tells us that " but if i connect my pc via ethernet to the g0 i don't have any connection, and if i try to configure the ip address it gives me some errors". It is pretty clear that this router is treating those interfaces as layer 2 switch ports and as such would refuse any attempt to configure IP addressing on them. @Georg Pauwen has suggested changes to the config and it looks to me like they do provide a workable solution. But the original poster also tells us "I don't really know what commands I must use..."  

 

The original poster told us that he could configure the wan so I assume that he is familiar with how to get into configuration mode. Once in configuration mode the original poster just needs to copy and paste the changes that are suggested such as 

--> ip dhcp excluded-address 192.168.1.1
!
--> ip dhcp pool LAN
--> network 192.168.1.0 255.255.255.0
--> default-router 192.168.1.1
--> dns-server 8.8.8.8

Of course do not include the --> in what you paste. Also some of the commands are to be made in interface config mode and to do that the original poster must include the interface command before inserting the changes suggested by Georg such as 

interface GigabitEthernet0
switchport

and 

interface GigabitEthernet8
ip nat outside

and

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside

Otherwise it should be a straightforward cut and paste the suggested changes into the config. After pasting those changes the original poster should use exit or quit to get out of config mode and should then use the copy running-config startup-config to save the config changes.

HTH

Rick

View solution in original post

Highlighted

Re: Problem with my cisco 897wav-e-k9

Thank you so much for the help @Richard Burts and @Georg Pauwen ,

but I still can't have an internet connection via ethertnet to my pc, the command switchport when I paste it gave me error that was uncomplete command, so I wrote switchport access vlan 1 and it worked.

here is my new running configuration:

 

router#sh run
Building configuration...

Current configuration : 1828 bytes
!
! Last configuration change at 12:16:26 UTC Sun Mar 22 2020
version 15.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
no logging console
!
no aaa new-model
memory-size iomem 5
service-module wlan-ap 0 bootimage autonomous
!
!
ip cef
!
!
!
!


!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
!
!
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid C897VAW-E-K9 sn FCZ1727C0SL
!
!
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Wlan-GigabitEthernet8
no ip address
!
interface wlan-ap0
description Embedded Service module interface to manage the embedded AP
no ip address
!
interface Vlan1
ip address 192.168.20.153 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

Highlighted
Hall of Fame Master

Re: Problem with my cisco 897wav-e-k9

Thank you for the additional information, which is quite helpful. In looking at your pictures I realize that there is a question that Georg or I should have asked much sooner and that question was what gateway (home router) is your router connected to, and what address is your router getting? Now we see that the home router is using network 192.168.1.0. This means that the suggestion that we use 192.168.1.0 for vlan 1 was not correct, and that means that the address translation that we attempted to configure is also not correct. Based on that I suggest that you make these changes in your configuration:

config t

no ip dhcp excluded-address 192.168.1.1
no ip dhcp pool LAN

!

ip dhcp excluded-address 192.168.20.1
ip dhcp pool LAN20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.153
dns-server 8.8.8.8

!

no access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.20.0 0.0.0.255

 

[edit] While I was preparing my response I see that @Georg Pauwen has posted similar suggestions, except there are 2 issues in his DHCP pool, it gives the network as 192.168.1.0 where it should be 192.168.20.0 and it gives default router as 192.168.20.1 where it should be 192.168.20.153

HTH

Rick

View solution in original post

Highlighted

Re: Problem with my cisco 897wav-e-k9

Thank you soooooo much @Richard Burts you helped me a lot. I'm only 15 years old and my father gave me his credentials to use this platform and I feel good this is a wonderful community and very helpful.

Richard do you have an e-mail so when I have a problem like this you could help me directly?

 

Highlighted
Hall of Fame Master

Re: Problem with my cisco 897wav-e-k9

I am glad that we were able to get this worked out. This community is an excellent place to ask questions and to learn about networking. As you get more experience I hope that you will be answering some questions as well as asking questions. In general I prefer to assist with people's issues in the context of the community. There are a couple of reason for that. One is that when issues are raised in the community and solutions are found then many people can benefit from it. Also when questions are asked in the community there is opportunity for multiple people to suggest answers, and frequently having more than one pair of eyes looking at an issue is a big advantage (as in fact for your issue both Georg and I were working on it).

 

There is a private message function in the community if you want to send me something. And if you really want it you can communicate with me at rcbnetworking@earthlink.net

HTH

Rick
Highlighted
Hall of Fame Master

Re: Problem with my cisco 897wav-e-k9

Thanks for the update. I believe that we are pretty close to getting it to work. First can we verify that the address of the ISP device is 192.168.1.1 and find what address your router is getting? To get those would you post the output of these commands:

show ip interface brief

show arp

Second can you tell us if your PC is getting an IP address using DHCP? If so can you tell us what IP, what mask, and what default gateway?

Third, There are a few commands that @Georg Pauwen suggested that I do not see in your config. So would you do this:

config t

ip nat inside source list 1 interface GigabitEthernet8 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet8 dhcp
access-list 1 permit 192.168.1.0 0.0.0.255

quit

and let us know whether it is working with these changes.

 

[edit] And if it is still not working would you post the output of show ip route

HTH

Rick
Highlighted

Re: Problem with my cisco 897wav-e-k9

This is my hardware configuration, to access the internet with my Cisco I use my home router, and its ip address is 192.168.1.1This is my hardware configuration, to access the internet with my Cisco I use my home router, and its ip address is 192.168.1.1

 

Excuse if you don't understand because I'm italian and my cmd is in italian, this is the ip that I see if I'm connected to the ciscoExcuse if you don't understand because I'm italian and my cmd is in italian, this is the ip that I see if I'm connected to the cisco

 

This is my ip configuration directly connected to my home router not the ciscoThis is my ip configuration directly connected to my home router not the cisco

Another time thank you for your help, my PC is using dhcp and how you can see from the second image my ip is the preferential, and not given from the cisco and is 169.254.75.220 and the mask 255.255.0.0

 

My cisco is getting 192.168.1.104

So yes my ISP is 192.168.1.1 (if you mean my home router)

 

Now I send another reply with some more specs

Highlighted

Re: Problem with my cisco 897wav-e-k9

router#sh ip int br
Interface IP-Address OK? Method Status Protoc ol
ATM0 unassigned YES NVRAM administratively down down
Ethernet0 unassigned YES NVRAM administratively down down
GigabitEthernet0 unassigned YES unset down down
GigabitEthernet1 unassigned YES unset down down
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
GigabitEthernet5 unassigned YES unset down down
GigabitEthernet6 unassigned YES unset down down
GigabitEthernet7 unassigned YES unset down down
GigabitEthernet8 192.168.1.104 YES DHCP up up
NVI0 unassigned YES unset administratively down down
Vlan1 192.168.20.153 YES NVRAM up up
Wlan-GigabitEthernet8 unassigned YES unset up up
wlan-ap0 unassigned YES NVRAM up up
router#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.1.1 0 8026.89e1.7160 ARPA GigabitEthernet8
Internet 192.168.1.104 - 70ca.9be9.46f1 ARPA GigabitEthernet8
Internet 192.168.20.153 - 70ca.9be9.46de ARPA Vlan1

 

 

these are the commands you asked me to log 

Highlighted

Re: Problem with my cisco 897wav-e-k9

Still not working

 

 

router# show ip route
*Mar 22 17:21:21.939: %SYS-5-CONFIG_I: Configured from console by console
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 192.168.1.1, GigabitEthernet8
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet8
L 192.168.1.104/32 is directly connected, GigabitEthernet8
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, Vlan1
L 192.168.20.153/32 is directly connected, Vlan1

VIP Mentor

Re: Problem with my cisco 897wav-e-k9

Hello,

 

make sure the configuration looks like below. What device is between the Internet and the Cisco router ? It is probably the ISP modem, that device needs a route back to the 192.168.20.0/24 network.

 

router#sh run
Building configuration...

Current configuration : 1828 bytes
!
! Last configuration change at 12:16:26 UTC Sun Mar 22 2020
version 15.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
memory-size iomem 5
service-module wlan-ap 0 bootimage autonomous
!
ip cef
!
ip dhcp excluded-address 192.168.20.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.20.1
dns-server 8.8.8.8
!
no ipv6 cef
!
multilink bundle-name authenticated
license udi pid C897VAW-E-K9 sn FCZ1727C0SL
!
controller VDSL 0
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Wlan-GigabitEthernet8
no ip address
!
interface wlan-ap0
description Embedded Service module interface to manage the embedded AP
no ip address
!
interface Vlan1
ip address 192.168.20.153 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet8 overload
!

ip route 0.0.0.0 0.0.0.0 GigabitEthernet8 dhcp

!
access-list 1 permit 192.168.20.0 0.0.0.255
!
control-plane
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end