08-06-2013 11:21 AM - edited 03-04-2019 08:40 PM
We are a small ISP that provides dsl service. The phone company is changing the data delivery to our router from ATM to Ethernet and I’m having trouble configuring a 7200 vxr to work with static IP’s on the end users.
ip dhcp excluded-address 10.10.10.230 10.10.10.254
!
ip dhcp pool test
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 209.211.0.3
!
interface Loopback1
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0.88
encapsulation dot1Q 3999 second-dot1q 88
ip unnumbered Loopback1
ip flow ingress
no snmp trap link-status
no cdp enable
We configure the dsl modem for bridge mode and configure the customer’s equipment. We are unable to statically assign IP's to our customers. If the customer's equipment is configured for a dynamic IP, this config works just fine. If the customer's equipment is configured for a static IP-either out of the excluded-address range or the dhcp pool- it doesn't work.
The following config will work but it requires a separate subnet for each subinterface.
Remove the loopback1 interface:
!
interface FastEthernet0/0.88
encapsulation dot1Q 3999 second-dot1q 88
ip address 10.10.10.1 255.255.255.0
ip flow ingress
no snmp trap link-status
no cdp enable
and configure the customer equipment with a static ip/netmask/gateway (10.10.10.2/255.255.255.0/10.10.10.1)
the only difference in this config is an ip address on the subinterface instead of using ip unnumbered Loopback1
Any suggestions would be appreciated.
08-06-2013 08:10 PM
Have you tried using IRB (bvi interfaces with bridge groups)?
http://www.cisco.com/en/US/tech/tk389/tk815/technologies_tech_note09186a0080094663.shtml
Sent from Cisco Technical Support Android App
08-07-2013 06:47 AM
Yes I have tried IRB. In fact, that's how we do it currently over the ATM circuit.
08-07-2013 09:59 AM
Does the static work if you use a static arp entry on the router for the client mac/ip? Do you see an arp request go out the correct interface if you run a debug arp?
I like you had a hard time finding anything on this using your particular config but there was something on the 4500 that covers using unnumbered interfaces and the need for connected host polling for statically assigned addresses.
08-07-2013 12:49 PM
I tried to assign IP based on mac on a test system but was unable to get it to work. Does anyone have a working config for that?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide