05-13-2019 06:30 PM
Please Help!
I would like to configure QOS or reserve bandwith for any traffic
between ServerA_30.30.30.10 and ServerB_40.40.40.10 on my 2(two) 30mbps
leased line load balancing.
Please see attached topology for your reference.
Thank you in advance.
05-14-2019 12:01 AM
Hello,
below is a simple QoS configuration. Apply the service policy outbound on both interfaces of both Layer 3 switches, respectively.
What layer 3 switch do you have ?
OFFICE B
access-list 101 permit ip host 40.40.40.10 host 30.30.30.10
!
class-map match-all 30_MB_CLASS
match access-group 101
!
policy-map 30_MB_POLICY
class 30_MB_CLASS
shape average 30000000
class class-default
fair-queue
!
interface FastEthernet0/0
description Link to ISP1
service-policy output 30_MB_POLICY
!
interface FastEthernet0/1
description Link to ISP2
service-policy output 30_MB_POLICY
OFFICE A
access-list 101 permit ip host 30.30.30.10 host 40.40.40.10
!
class-map match-all 30_MB_CLASS
match access-group 101
!
policy-map 30_MB_POLICY
class 30_MB_CLASS
shape average 30000000
class class-default
fair-queue
!
interface FastEthernet0/0
description Link to ISP1
service-policy output 30_MB_POLICY
!
interface FastEthernet0/1
description Link to ISP2
service-policy output 30_MB_POLICY
05-14-2019 01:34 AM
Thank you @Georg Pauwen
Did the configuration still okay with the details I gave to @paul driver ?
Thanks.
05-14-2019 02:55 AM
Hello,
if you want to reserve 10MB, change the config as below. As far as I recall, the EIGRP bandwidth reservation is an upper limit rather than a fixed reservation, meaning that EIGRP can utilize up to 50 percent of the bandwidth. This used to be applicable in very slow links as they existed back in the days (56K links e.g. were being used). I don't think it is an issue nowadays...
OFFICE B
access-list 101 permit ip host 40.40.40.10 host 30.30.30.10
!
class-map match-all q0_MB_CLASS
match access-group 101
!
policy-map q0_MB_POLICY
class 10_MB_CLASS
shape average 10000000
class class-default
fair-queue
!
interface FastEthernet0/0
description Link to ISP1
service-policy output 10_MB_POLICY
!
interface FastEthernet0/1
description Link to ISP2
service-policy output 10_MB_POLICY
OFFICE A
access-list 101 permit ip host 30.30.30.10 host 40.40.40.10
!
class-map match-all 10_MB_CLASS
match access-group 101
!
policy-map 10_MB_POLICY
class 10_MB_CLASS
shape average 10000000
class class-default
fair-queue
!
interface FastEthernet0/0
description Link to ISP1
service-policy output 10_MB_POLICY
!
interface FastEthernet0/1
description Link to ISP2
service-policy output 10_MB_POLICY
05-14-2019 12:22 AM - edited 05-14-2019 03:20 AM
Hello
Is the leased line at present running 30mb or do you wish for the server to server communication be shaped/policed at 30mb.
The reason I am asking is you are using eigrp and by default there is an implicit restriction that this routing process uses only 50% of its defined bandwidth for eigrp by default so introducing quality of service this restriction may need to be taken into consideration.
Can you confirm please?
05-14-2019 01:31 AM
Hello
Is the leased line at present running 30mb or do you wish for the server to server communication be shaped/policed at 30mb.
The reason I am asking is you are using eigrp and by default there is an implicit restriction that this routing process uses only 50% of its defined bandwidth by default so introducing quality of service this restriction needs to be taken into consideration.
Can you confirm please?
Hi Paul! Thanks for the extra effort.
Yes, every leased line is running 30mb. I want to limit the bandwidth for the server to server with 10mbps only.
Yes, I'm using EIGRP.
what do you suggest?
Thanks.
05-14-2019 02:19 AM - edited 05-14-2019 02:23 AM
Hello
You could apply some LLQ for the server-server communication and allocate at least some BW for the routing process and leave the rest of the traffic as best effort but as you using eigrp you may need to tell the process to use 100% of its interface bandwidth
Possible example:
Office A ( replicate for office B)
ip access-list extended eigrp
permit eigrp any any
class-map match-all routing
match access-group name eigrp
ip access-list extended srv-srv
permit ip host 30.30.30.10 host 40.40.40.10
class-map match-all srv
match access-group name serv-srv
policy-map WAN_Child
class routing
bandwidth percent 5
class srv
priority percent 33
class class-default
fair-queue
policy-map WAN_Parent
class class-default
shape average 30720000
service-policy WAN_Child
int x/x
description PLDTDLL egress interface
ip bandwidth-percent eigrp 10 100
service-policy output WAN_Parent
int x/x
description ETTPDLL egress interface
ip bandwidth-percent eigrp 10 100
service-policy output WAN_Parent
05-14-2019 02:54 AM - edited 05-14-2019 02:54 AM
Hello Paul,
I agree on adding a class-map for EIGRP traffic protection.
However, the ip eigrp bandwidth percent command refers to the bandwidth parameter of the physical interface and it does not follow the settings of bandwidth in a class-map that matches EIGRP traffic.
So I would suggest instead:
setting the bandwidth on the physical interface accordingly to the leased line rate.
Eventually setting the ip eigrp bandwidth to 5 % in accordance with allocation the class-map may be considered.
The use of a LLQ for traffic between servers can be too much, using a normal queue may be more fair for other traffic and also avoids the built in policer that a LLQ queue has to avoid starvation of other queues.
Hope to help
Giuseppe
05-14-2019 04:02 AM - edited 05-14-2019 04:04 AM
Hello Giuseppe
I totally agree on the setting the interface BW to the true bandwidth of the interface but as this could cause recalculation of the eigrp path internally for the lan rtrs I was cautious to apply it
As for the server-server traffic , LLQ is restrictive to 10MB however as the OP requested this limitation in times of congestion my thinking is QOS will prioritize at 10mb and any spare BW after that will be dealt with a best effort and not dropped unlike policing would do, Now If i specified a normal queue then at time of congestion with any spare BW a much higher BW allocation than requested would be seen would it not?
05-14-2019 04:08 AM
Hello Paul,
>> Now If i specified a normal queue then at time of congestion with any spare BW a much higher BW allocation than requested would be seen would it not?
Yes this is true, because when using the bandwith command it provides a minimal amount of traffic for the queue. And there is no built in policer.
I had this doubt while I was writing the previous post.
Best Regards
Giuseppe
05-14-2019 07:44 PM
What if I just use the static route on my two Layer3 Switches what should configuration I need for my QOS?
Thanks.
05-14-2019 11:39 PM - edited 05-15-2019 12:27 AM
Hello Alvin,
you have two parallel links with each one with a speed of 30 Mbps if I have correctly understood your network scenario.
So using a single static route would allow you to choice the link used by the communication between the two servers in both directions, but:
if that link fails all traffic will be routed on the remaining link (and you may need to track with an IP SLA the next-hop of the static route to avoid a black hole for traffic ). At that point all traffic would be on the still alive link and you need QoS to deal with it.
So even if by using a static route you can choice the preferred path, I think you should configure QoS on both links.
both directions.
I would not configure the static route, just QoS on both links both directions as suggested by Paul.
Because the static route does not give you a big advantage as you still need to configure QoS for correct treatment of traffic.
Edit:
I have checked again your network diagram in the first post of this thread.
I have a question: do you control = you can configure the four devices that are directly connected to the leased lines or you have control only on the L3switch of each site?
From the network diagram it looks like that L3switch of OfficeB connects over a single subnet 20.0.0.0 to the two devices on the left. Are you using an SVI on OfficeB L3 switch to reach the devices that connect to the leased lines?
Note: the configuration proposed by Paul is already a Hierarchical QoS that can be applied to routers direcly connected to the leased lines if they are under your control.
Hope to help
Giuseppe
05-15-2019 12:12 AM
Hello,
what model (e.g. 3850) are your layer 3 switches ? And which IOS are you running ? QoS is very model specific. Can you post the output of 'show ver' ?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide