cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
700
Views
3
Helpful
3
Replies

QoS: Configuring the Modular Quality of Service CLI

haji_akhundov
Level 1
Level 1

Hello everyone!

I need some help regarding the configuration of QoS.

I have a switch(SLM224G) that is connected to a router (2811) (fast Ethernet sub interface, encap dot1Q3). Everything works just fine. MY end goal right now is to make certain physical ports on the switch to have a higher priority.

My proposed solution was to mark the packets on the switch with a CoS value and then use that information to classify the traffic.

For example,

I changed the switch's configuration to change mark interface e1 with CoS 3,

then the router with the following:

!

class-map match-all HI

match cos  3

!

!

policy-map MyPolicy

class HI

  priority percent 90

class class-default

  fair-queue

!

When I apply this to an interface:

interface fastethernet 0/0.2

service-policy output MyPolicy

I get: 'match cos' is not supported in an output policy

What's wrong here? How can I do this?

Thank you.

3 Replies 3

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Haji,

change configurations so that  the switch marking is done assigning an OSI layer3 parameter like a DSCP value (this is mapped to the TOS-Diffserv byte in IPv4 header)

Then you change router configuration accordingly with the class defined matching on ip dscp instead of CoS

Hope to help

Giuseppe

Giuseppe,

Thank you for your reply.

It seems that I cannot make DSCP marking on my switch unfortunatly.

I tried an alternative way just now:

1. Mark CoS on a switch

2. match CoS on a router and SET dscp af11 (then apply as service-policy INPUT on a subinterface)

3. match DSCP af11 on a router set priority bandwidth et cetra (apply as OUTPUT)

class-map match-all dscpAF11

match  dscp af11

class-map match-all HI-PRI

match cos  5

!

!

policy-map marker

class HI-PRI

  set dscp af11

policy-map myQoS

class dscpAF11

  priority percent 90

class class-default

  fair-queue

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.1.1 255.255.255.0

service-policy input marker

!

But now when I try to:

Router1(config)#int fastEthernet 0/0.3

Router1(config-subif)#service-policy output myQoS

I get:

CBWFQ : Not supported on subinterfaces

What I am doing at the moment seems logical to me..  But is there a special way of configuring logical interfaces?

haji_akhundov,

What is up man?

 

I see your message, i can help you.

 

"CBWFQ : Not supported on subinterfaces

What I am doing at the moment seems logical to me..  But is there a special way of configuring logical interfaces?"

 

you just have to configure a parente level at your policy, seems like this:

 

!

policy-map myQoS-child

class dscpAF11

  priority percent 90

class class-default

  fair-queue

!

policy-map myQoS-parent

class class-default

  shape average percent 100%

 

servisse-policy myQoS-child

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.1.1 255.255.255.0

service-policy output myQoS-parent

!

 

when you tested, please replay to me.