11-14-2012
09:36 AM
- last edited on
03-25-2019
03:37 PM
by
ciscomoderator
We are trying to limit the DFS replications and downloads to 30% of total bandwidth. I have setup the below QoS but for some reason the default-class policy take pryority and allows the DFS replications to consume up the the shape average of the default-class policy.
When i remove the shape avaerage from the default-class the DFS is trimmed back to the alloted 30%. As soon as the shape average is placed back on the default-class it allows it to go back up to 45.
Is there something I am missing in my policy?
access-list 105 permit ip host 10.144.241.231 any
access-list 105 permit ip any host 10.144.241.231
access-list 105 remark DFS-LIMIT
class-map match-all DFS-LIMIT-IN
match access-group 105
class-map match-any VOICE-CALL-CONTROL
match ip dscp af31
match ip dscp cs3
class-map match-any DFS-LIMIT
match access-group 105
class-map match-any VOICE
match ip dscp ef
match ip dscp cs5
class-map match-any ROUTING
match ip dscp cs6
policy-map WAN-EDGE
class VOICE
priority 800
class VOICE-CALL-CONTROL
bandwidth percent 1
class ROUTING
bandwidth percent 1
class DFS-LIMIT
shape average percent 30
class class-default
fair-queue
random-detect dscp-based
policy-map PARENT
class class-default
shape average 45000000 3000000 1000
service-policy WAN-EDGE
policy-map PARENT-IN
class DFS-LIMIT-IN
police cir percent 25
interface GigabitEthernet0/1.94
description AVPN 50MB/45MBCommit
bandwidth 409600
encapsulation dot1Q 94
ip address 10.144.250.49 255.255.255.252
ip accounting output-packets
service-policy input PARENT-IN
service-policy output PARENT
end
11-14-2012 10:00 AM
It looks like one of your class maps that reference your acl is set to "match-all" which is the default. You should remove this from your policy-map PARENT-IN and remove the class-map. Recreate it with "class-map match-any DFS-LIMIT-IN" and match on your same acl.
HTH,
John
11-14-2012 10:54 AM
I will give that a try for the input. I should have mentioned that the Output on the interface is where i am seeing the 45 meg happen.
Does the output policy look correct?
11-14-2012 01:04 PM
It does look correct. Have you tried to remove the burst from the parent class-default? Try removing that and do just "shape average 45000000" and see what you get. When you do your test, can you post "show policy-map interface"?
HTH,
John
11-15-2012 08:45 AM
Implemented the suggested changes but still no luck:
show policy-map int gi 0/1.94
GigabitEthernet0/1.94
Service-policy input: PARENT-IN
Class-map: DFS-LIMIT-IN (match-any)
1852586432 packets, 1089778262041 bytes
5 minute offered rate 1104000 bps, drop rate 46000 bps
Match: access-group 105
police:
cir 25 %
cir 12800000 bps, bc 400000 bytes
conformed 1682579435 packets, 874263917595 bytes; actions:
transmit
exceeded 162517555 packets, 214979009983 bytes; actions:
drop
conformed 1428000 bps, exceed 31000 bps
Class-map: class-default (match-any)
955282109 packets, 795440521315 bytes
5 minute offered rate 11040000 bps, drop rate 0 bps
Match: any
Service-policy output: PARENT
Class-map: class-default (match-any)
2077522094 packets, 1919295120644 bytes
5 minute offered rate 11744000 bps, drop rate 129000 bps
Match: any
Traffic Shaping
Target/Average Byte Sustain Excess Interval Increment
Rate Limit bits/int bits/int (ms) (bytes)
45000000/45000000 281250 1125000 1125000 25 140625
Adapt Queue Packets Bytes Packets Bytes Shaping
Active Depth Delayed Delayed Active
- 0 126215906 97741110 83351115 3541435327 yes
Service-policy : WAN-EDGE
Class-map: VOICE (match-any)
16183 packets, 3526745 bytes
5 minute offered rate 97000 bps, drop rate 0 bps
Match: ip dscp ef (46)
16183 packets, 3526745 bytes
5 minute rate 97000 bps
Match: ip dscp cs5 (40)
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 800 (kbps) Burst 20000 (Bytes)
(pkts matched/bytes matched) 3337/727466
(total drops/bytes drops) 0/0
Class-map: VOICE-CALL-CONTROL (match-any)
3726 packets, 792058 bytes
5 minute offered rate 30000 bps, drop rate 0 bps
Match: ip dscp af31 (26)
0 packets, 0 bytes
5 minute rate 0 bps
Match: ip dscp cs3 (24)
3726 packets, 792058 bytes
5 minute rate 30000 bps
Queueing
Output Queue: Conversation 265
Bandwidth 1 (%)
Bandwidth 450 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 671/166987
(depth/total drops/no-buffer drops) 0/0/0
Class-map: ROUTING (match-any)
280 packets, 50499 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp cs6 (48)
280 packets, 50499 bytes
5 minute rate 0 bps
Queueing
Output Queue: Conversation 266
Bandwidth 1 (%)
Bandwidth 450 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 50/9607
(depth/total drops/no-buffer drops) 0/0/0
Class-map: DFS-LIMIT (match-any)
193183 packets, 282639580 bytes
5 minute offered rate 6596000 bps, drop rate 0 bps
Match: access-group 105
193183 packets, 282639580 bytes
5 minute rate 6596000 bps
Traffic Shaping
Target/Average Byte Sustain Excess Interval Increment
Rate Limit bits/int bits/int (ms) (bytes)
30 (%) 0 (ms) 0 (ms)
13500000/13500000 81000 324000 324000 24 40500
Adapt Queue Packets Bytes Packets Bytes Shaping
Active Depth Delayed Delayed Active
- 0 0 0 0 0 no
Class-map: class-default (match-any)
178602 packets, 36533798 bytes
5 minute offered rate 785000 bps, drop rate 100000 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/2604/0
Extended IP access list 105
10 permit ip host 10.144.241.231 any (2089518780 matches)
20 permit ip any host 10.144.241.231 (1852722063 matches)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide