cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
353
Views
0
Helpful
1
Replies

QoS over layer-2 WAN link: Is there a better way?

Ian Adams
Level 1
Level 1

Hi everyone, I have an interesting QoS issue, and while I've found a solution, I wonder if there's a better way.

Background:

This is for a radio station that is sending audio from the station to the transmitter on a mountain via a T1. Historically they've used a device that will divide the T1's time-slots up to deliver digital audio (not IP audio), and use the remaining time-slots to extend a LAN to the other side.

They're now switching over to use IP audio codec appliances to deliver a one-way UDP stream from the station to the mountain top. I have now been given all 24 time-slots (1.544 mbps) for IP traffic, and need to ensure as close to 0% packet loss on the UDP stream as possible. The catch being that I need to use the existing LAN extender equipment, whereas normally I'd want to put in a pair of routers with serial cards in place.

The IP audio codec tags its UDP packets with a DSCP value of "ef". I tried several policy-maps based on that, giving priority to "ef", but I was still able to create a massive packet loss rate by doing things like FTPing files up. In this case, packet loss means dead air on the radio station.

Eventually I came up with the following policy-map that polices "ef" traffic, giving a hard 700 kbps. All other traffic gets 715 kbps, with anything exceeding that getting dropped. It works. It's solid. I've flooded that link with non-DSCP "ef" traffic, and I'm getting no packet loss.

The question is, could this be done better? Right now if the station wanted to add another IP Audio Codec, I'd need to adjust the policing on my policy-map. Is there a way to make prioritization more dynamic?  

Network diagram:

Policy map and interface config on CoreSW01:

class-map match-any AUDIO
match ip dscp ef
!
policy-map MNT-UPLINK
class AUDIO
bandwidth 700
police 700000 conform-action transmit exceed-action transmit
class class-default
bandwidth 715
police 715000 conform-action transmit exceed-action drop
!
interface GigabitEthernet2/48
description LAN extender to mountaintop
switchport access vlan 200
switchport mode access
bandwidth 1415
service-policy output MNT-UPLINK

Show policy-map int output from CoreSW01, taken during a traffic flood test:

CoreSW01#show policy-map interface gigabitEthernet 3/19
GigabitEthernet3/19

Service-policy output: MNT-UPLINK

Class-map: AUDIO (match-any)
18027176 packets
Match: ip dscp ef (46)
18027176 packets
Queueing
queue limit 264 packets
(queue depth/total drops) 0/196
(bytes output) 3877438140
bandwidth 700 kbps
police:
cir 700000 bps, bc 21875 bytes
conformed 3869345110 bytes; actions:
transmit
exceeded 0 bytes; actions:
transmit
conformed 671000 bps, exceeded 0000 bps

Class-map: class-default (match-any)
4114839 packets
Match: any
Queueing
queue limit 1848 packets
(queue depth/total drops) 0/34
(bytes output) 1074097063
bandwidth 715 kbps
police:
cir 715000 bps, bc 22343 bytes
conformed 987031146 bytes; actions:
transmit
exceeded 222510411 bytes; actions:
drop
conformed 227000 bps, exceeded 2000 bps
CoreSW01#

Thanks!

-Ian

1 Reply 1

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

"Better" depends on your equipment.  What you want is some kind of traffic shaping that you can attach a QoS policy too.  I don't think the 4500 supports that.  Not sure about the 3650.

Basically, you want a device that would allow something similar to:

policy-map MNT-UPLINK

class class-default

service-policy QoS

shape average 1500000

policy-map QoS

class AUDIO

priority percent 99

class class-default

bandwidth remaining percent 100

Review Cisco Networking products for a $25 gift card