cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
447
Views
0
Helpful
1
Replies

QOs Voip sip.

stephtchoko
Level 3
Level 3

Good day.

I want to implement qos to priorise voice on other traffic.I have a router 1710 and behind (lan side) it computer and ipphone all set on private address 192.168.1.x.

The ip phone use sip signalisation.

On wan side the ip address of router is 196.202.234.162.

how can configure it please ?

1 Reply 1

pradeepde
Level 5
Level 5

The following steps should help to configure QoS for prioritising voice traffic :

Define an access group (105) which matches any VOIP traffic :

access-list 105 remark VOIP (SIP/IAX/IAX2) traffic gets top priority (5)

access-list 105 permit udp any any eq 4569

access-list 105 permit udp any any eq 5004

access-list 105 permit udp any any eq 5036

access-list 105 permit udp any any eq 5060

access-list 105 permit ip host OTHER.VOIP.HOST.HERE any

access-list 105 permit ip any host OTHER.VOIP.HOST.HERE

The access-group is matching UDP 4569 (IAX2), 5004 (RTP), 5036 (IAX1) and 5060 (SIP), also allowing

any traffic from OTHER.VOIP.HOST.HERE to be included.

Now, to prevent the upstream from plugging up the link, set up two input rate-limit rules to police

the incoming traffic. The first will allow 128k of VOIP traffic in no matter what, set its precedence

to high priority (5) and transmit it. The other part of the first rule will allow any excess VOIP

traffic (above 128k), but its precedence set to best-effort (0) and the remaining police rule will be

evaluated as well. The second rate-limit command will allow no more than 1408kbps through; any excess

will be dropped.

Again, this only works for TCP traffic, since dropped packets will cause the sender to back off and

try again slower. If your link is full of other protocols without this particular feature, this won't

do anything to help:

in s0/0

rate-limit input access-group 105 128000 65536 65536 conform-action set-prec-transmit 5

exceed-action set-prec-continue 0

rate-limit input 1408000 8000 8000 conform-action transmit exceed-action drop

At any rate, that takes care of the incoming traffic.

Now to handle outgoing traffic :

You can use service polices and LLQ (Low Latency Queueing)  this queueing discipline was _designed_

for VOIP.

Setting it up is a snap:

class-map voice

match access-group 105

!

policy-map policy1

class voice

priority 96

class class-default

fair-queue

!

The first pair of commands sets up a class called 'voice', which matches any traffic which matches

access group 105 (the VOIP ACL I have defined above). The second group actually sets up the police

map; it guarantees 96kbps of traffic for the voice class, and everything else is queued using the

fair-queue discipline. Now you have to do is attach this to an interface :

in s0/0

service-policy output policy1

in e0/0

service-policy output policy1

Review Cisco Networking for a $25 gift card