cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1286
Views
0
Helpful
1
Replies

Question about dialup WAN configuration using router analog modem ports

gwhuang5398
Level 2
Level 2

Can someone help me with the dialup WAN configuration using 1900 router analog modem ports? It's old technology, so I'm having hard time finding good materials to verify.

Here is the connectivity, pretty straightforward:

One 1941 router at central site, 3 modem ports using NM-2AM and NM-1AM.

Three remote sites: two are using 3Com modems, and one site using 1941 router modem port (NM-1AM).

So there'll be three analog dialup WAN connections between the central site and the remote sites.

Application is to transfer low volume data from central site to the remote sites when needed. Dial direction is from central to the remote.

Here are the configs. My questions are:

(1) Is "ip unnumbered Gi0/0" correct for the 3 Async interfaces? Do I have to give each an IP address?

(2) Do I need to apply chat script to the Async lines for dialing out?

(3) Before the dialup connection is established, the Async interface would be "down". In that case, how can the router route traffic to the Async interface to trigger dialup? It's sort of chicken and egg.

(4) Has anyone used Cisco router modem with 3Com modem before?

Thanks a lot for any help.

Gary

Central site router config:

username Remote password admin

Interface Gi0/0

description Router LAN Interface

ip address 192.168.1.2 255.255.255.0

dialer-list 1 protocol ip list 102

dialer-list 2 protocol ip list 104

dialer-list 3 protocol ip list 106

access-list 102 permit ip any 192.168.2.0 0.0.0.255

access-list 104 permit ip any 192.168.4.0 0.0.0.255

access-list 106 permit ip any 192.168.6.0 0.0.0.255

chat−script DialOut ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 30 CONNECT \c

interface async 5

description To remote 3Com modem

ip unnumbered Gi0/0

encapsulation ppp

dialer in-band

dialer string 19135550001

dialer-group 1

async mode dedicated

interface async 6

description To remote Cisco ISR modem

ip unnumbered Gi0/0

encapsulation ppp

dialer in-band

dialer string 19135550002

dialer-group 2

async mode dedicated

interface async 7

description To remote 3Com modem

ip unnumbered Gi0/0

encapsulation ppp

dialer in-band

dialer string 19135550003

dialer-group 3

async mode dedicated

ip route 192.168.2.0 255.255.255.0 Async 5

ip route 192.168.4.0 255.255.255.0 Async 6

ip route 192.168.6.0 255.255.255.0 Async 7

line 5

modem inout

autoselect ppp

transport input all

script dialer DialOut

line 6

modem inout

autoselect ppp

transport input all

script dialer DialOut

line 7

modem inout

autoselect ppp

transport input all

script dialer DialOut

Remote Cisco router config:

username Central password admin

Interface Gi0/0

description Router LAN Interface

ip address 192.168.4.2 255.255.255.0

dialer-list 1 protocol ip list 192

access-list 192 permit ip any any

interface async 5

description To Central 1941 ISR analog modem

ip unnumbered Gi0/0

encapsulation ppp

ppp authentication chap

dialer in-band

dialer-group 1

async mode dedicated

ip route 0.0.0.0 0.0.0.0 async 5

line 5

modem inout

autoselect ppp

transport input all

1 Reply 1

robert.laidlaw
Level 1
Level 1

I recently had to setup something similair, but it was for potentially thousands of remote sites.  I also did not want to setup an interface for each remote site so I setup one dialer interface with a large ip subnet, then I added the async interface into a rotary group so that the dialer could use any of the available lines to dial out with and finally I configured the dialer-map statements so it would dial certain numbers based on the destination ip address.

The relavent config is posted below.

(1) Is  "ip unnumbered Gi0/0" correct for the 3 Async interfaces? Do I have to  give each an IP address?

No, you can create one interface on a subnet like a /28 or /29 and have the router be .1 and assign one ip to each remote site if you like.

(2) Do I need to apply chat script to the  Async lines for dialing out?

No, especially if your using the built in modem, just add the modem autodiscovery for the modem lines (not the interface async, line async, like the console lines or vty lines)

(3) Before the dialup connection is  established, the Async interface would be "down". In that case, how can  the router route traffic to the Async interface to trigger dialup? It's  sort of chicken and egg.

This is where the dialer interface comes in.  Its spoofed up so traffic is routed to the correct dialer interface and it makes the decision of what number to dial

(4) Has anyone used Cisco router modem  with 3Com modem before?

Yes, no issue. We have old 3coms and multitek modems with the dip switches and no issue with either.

On a side note, I am using ODR to advertise a default route to the remote side router.  The only part to maintain is the dialer maps on the dialer interface that link the IP to the phone number to dial.  The router then selects the next available line from the rotary group and makes the call.

GL

-Rob

interface Async33
description potsline1
no ip address
encapsulation ppp
carrier-delay 10
timeout absolute 30 0
dialer in-band
dialer rotary-group 10
dialer-group 1
!
interface Async34
description potsline2
no ip address
encapsulation ppp
carrier-delay 10
timeout absolute 30 0
dialer in-band
dialer rotary-group 10
dialer-group 1
!
interface Async35
description potsline3
no ip address
encapsulation ppp
carrier-delay 10
timeout absolute 30 0
dialer in-band
dialer rotary-group 10
dialer-group 1
!
interface Async36
description potsline4
no ip address
encapsulation ppp
carrier-delay 10
timeout absolute 30 0
dialer in-band
dialer rotary-group 10
dialer-group 1
!
interface Async37
description potsline5
no ip address
encapsulation ppp
carrier-delay 10
timeout absolute 30 0
dialer in-band
dialer rotary-group 10
dialer-group 1
!
interface Async38
description potsline6
no ip address
encapsulation ppp
carrier-delay 10
timeout absolute 30 0
dialer in-band
dialer rotary-group 10
dialer-group 1
!
interface Async39
description potsline7
no ip address
encapsulation slip
carrier-delay 10
timeout absolute 30 0
!
interface Async40
description potsline8
no ip address
encapsulation slip
carrier-delay 10
timeout absolute 30 0
!
interface Dialer10
ip address 192.168.6.1 255.255.255.0
encapsulation ppp
dialer in-band
dialer idle-timeout 30
dialer map ip 192.168.6.9 name testcpe broadcast xxxxxxxxxx
dialer map ip 192.168.6.10 name MB099999 broadcast xxxxxxxxxxx
dialer-group 1
ppp authentication chap callin
ppp chap hostname HUB1
ppp chap password 7 {password omitted}
!
router odr
network 192.168.6.0
!

access-list 101 permit {fill in your own access list for interesting traffic}

dialer-list 1 protocol ip list 101
cdp timer 10

line 33 40
session-timeout 15
no exec-banner
exec-timeout 30 0
absolute-timeout 60
modem DTR-active
modem autoconfigure discovery
rotary 10
no exec
transport input telnet
escape-character 28
autoselect ppp
end

Review Cisco Networking for a $25 gift card