cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
360
Views
0
Helpful
6
Replies

Question about Register Stop Message from RP in Sparse Mode

I have a question about the Register Stop Message from the Multicast Rendezvous Point router to the Multicast first hop router, when both routers are on the same subnet. 

 

I am using sparse mode and autorp listener on the first hop router and autorp defined to a physical interface from the RP, not the loopback IP of the RP.

 

If both the Multicast RP and the Multicast first hop router (i.e. the Multicast Source Router) are both on the same subnet, should the RP send a stop register message back to the first hop router?  

 

I ask because, I see network traffic in Wireshark between the two  routers showing Register messages from the first hop router with the Multicast data encompassed.  I also see Multicast data from the RP to the Multicast receiver router/end-users.  The multicast data flow seems to be working correctly for my particular application.

 

I thought I should be seeing a register stop message from the RP and after that message is received by the first hop router, then all I should be seeing is multicast data from the first hop router to the RP.

 

Any insight is appreciated.

6 REPLIES 6
Georg Pauwen
VIP Master

Hello,

 

do you have the full configs of both the Multicast Rendezvous Point router and the Multicast first hop router, so we can lab this ?

Here is the multicast parts of the RP configuration....


ip multicast-routing distributed
!
interface GigabitEthernet0/0/0
description /// Site Red Router IP Address ///
ip address 10.145.168.1 255.255.255.248
ip pim sparse-dense-mode
no shutdown
negotiation auto
!
ip pim send-rp-announce GigabitEthernet0/0/0 scope 16 group-list 1
ip pim send-rp-discovery scope 16
!
!
access-list 1 permit 239.186.1.1
access-list 1 permit 239.186.1.2
access-list 1 permit 239.186.1.3
access-list 1 permit 239.186.1.4
access-list 1 permit 239.186.1.5
access-list 1 permit 239.186.1.6
!

 

Here is the multicast parts of the First Hop Router (i.e. Multicast Source) configuration.  The true multicast source(s) are either either 10.145.168.5 or 10.145.168.6 from this connection either one source or the other source will output the Multicast Groups but not at the same time.

 

First Hop Router configuration...


ip multicast-routing distributed
!
interface GigabitEthernet0/0/3
ip address 10.145.168.2 255.255.255.248
ip nat outside
ip pim sparse-mode
negotiation auto
no shutdown
!
ip pim autorp listener

 

Giuseppe Larosa
Hall of Fame Master

Hello @donaldhughes743301172 ,

 

>> am using sparse mode and autorp listener on the first hop router and autorp defined to a physical interface from the RP, not the loopback IP of the RP.

 

this is not clear to me for a working implementation the RP address must be associated to a loopback address that is enabled for PIM sparse mode and it is advertised in the unicast IGP. ( OSPF , EIGRP or IS-IS or RIPv2)

 

Your network topology is not clear.

However, if the RP is directly connected to the source it can accept traffic from the source and it can send it downstream to receivers.

 

the other PIM router in the LAN segment should not send register messages to the RP.

if the RP is not drectly connected to the source then the PIMD DR where the source is connected sends register messages to the RP address and the RP will join the Source Based Tree and at the same time send register stop messages to the source PIM DR router.

This is done for forwarding efficiency to avoid GRE encapsulation / decap.

 

what you see can be the result of a conflicting configuration

>> >> am using sparse mode and autorp listener on the first hop router and autorp defined to a physical interface from the RP, not the loopback IP of the RP.

 

Again post your configurations as already suggested because it is not clear what you have done.

 

Hope to help

Giuseppe

 

 

As I have indicated, I am not using the loopback address, I am using a physical WAN interface.

 

The RP is on the same network and to your point is directly connected to the multicast source router.

 

What is observed in Wireshark between the multicast source router and the RP are register messages (PIMv2) only, not multicast messages.

 

I have posted my configurations related to the network topology.

 

Also to reiterate, the Multicast Groups are being received by the Multicast Receiver.

Modified the RP configuration too:

 

int loopback0

ip address 2.2.2.2 255.255.255.255

ip pim sparse-dense-mode

 

ip pim send-rp-announce loopback0 scope 16 group-list 1

 

What is observed in Wireshark between the multicast source router and the RP are register messages (PIMv2) only, not multicast messages with this configuration.

 

Multicast end-users are getting data.

Hello @donaldhughes743301172 ,

in this case using a loopback for the RP address I think it is normal what you see if the other PIM router is the PIM DR.

the source PIM DR is in charge to send register messages to the RP address.

the RP will send register stop messages  as soon as it can get the multicast stream from the source in your case this is immediate and it does not need to join the source based tree at the source PIM DR.

In this case this is normal.

 

>> What is observed in Wireshark between the multicast source router and the RP are register messages (PIMv2) only, not multicast messages.

Yes this is correct the messages are sent to the RP address and may have a multicast packet with GRE encapsulation in the payload.

 

Again this is normal.

May I ask what unicast routing protocol are you using ?

 

Hope to help

Giuseppe