03-15-2005 10:40 AM - edited 03-03-2019 09:03 AM
We are implementing Metropolitan Over Ethernet as a WAN solution at one of our facilities. The Telco hands us an etherent connection that comes from a FastEthernet and goes to a FastEthernet0/0 on our 2651 running 12.3 software. We are only buying a 20Mbps connection and I need to traffic shape the FastEthernet to this speed.
Here's what I have so far for the config:
class-map match-all Green-20MB
match access-group name Green
!
!
policy-map QMOE-20MB
class Green-20MB
police rate 20000000 bps
exceed-action drop
interface FastEthernet0/0
description QMOE GREEN VLAN
ip address 192.168.244.3 255.255.255.0
service-policy output QMOE-20MB
ip access-list extended Green
permit ip any any
My questions are:
1.) There is an exceed action, do I need a conform action?
2.) I have only one ingress interface, fa0/1, not listed in the config above, should I shape the traffic on the ingress interface vs. the egress as listed above?
Thanks in Advance,
Peter
03-15-2005 11:04 AM
This could work, altough policing in this way is not the best option. Dropping everything over the maximum will cause quite a lot of retransmissions and your effective throughput will be significantly less.
If you are buying 20Meg of bandwidth, it is the providers challenge to see that you get no more and no less.
This is certainly true for the ingress traffic, no rate limiting should be required there.
Regards,
Leo
03-15-2005 11:36 AM
Performance will be better if you use traffic shaping as opposed to policing. Shaping will send at a smooth 20mb rate, and will buffer excess packets using whatever queuing mechanism you configure.
With your policing config packets will be clocked out at the 100mb physical interface rate with anything exceeding 20mb dropped.
interface FastEthernet0/0
traffic-shape rate 10000000 (10mb bursting to 20mb)
03-15-2005 04:53 PM
Thanks dgahm. This make alot of sense as a better way to do it. So now I have questions about the rest of the config. For grins under the Interface I put in
"traffic-shape rate 20000000" or 20Mbps.
hese are the defaults that were installed after that command:
traffic-shape rate 20000000 500000 500000 1000
So then I went back and did a bunch of question marks? to find out what each number referred to, that output follows:
RHL-TI-2651-1(config-if)#traffic rate ?
<8000-100000000> Target Bit Rate (bits per second)
RHL-TI-2651-1(config-if)#traffic rate 20000000 ?
<0-100000000> bits per interval, sustained
RHL-TI-2651-1(config-if)#traffic rate 20000000 500000 ?
<0-100000000> bits per interval, excess in first interval
RHL-TI-2651-1(config-if)#traffic rate 20000000 500000 500000 ?
<0-4096> Set buffer limit
So the numbers in the command w/ the defaults:
traffic-shape rate 20000000 500000 500000 1000
refer to
2000000 Target Bit Rate (bits per second)
500000 bits per interval, sustained
500000 bits per interval, excess in first interval
1000 Set buffer limit
Anyone have any documentation on Traffic Shaping or want to elaborate on the above numbers? Or Just Go With Defaults?
Thanks in advance,
Peter
03-15-2005 10:19 PM
Peter,
Your target rate is 20 mb with a burst to 40 mb. The default interval is 25 ms or 40 per second. So 500,000 bits per interval is 20mb/s. The excess per interval is also 500,000, so that is another 20mb/s. It says excess in the 1st interval, but in practice it seems to be more. Or at least that is true when using traffic shaping in class maps.
This is why my example shows a 10000000 rate, which won't exceed 20mb. You might start with that and see if you are able to get a sustained rate of 20mb.
A useful command is 'show traffic-shape fast0/0'
Please remember to rate posts that are helpful.
Regards, Dave
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide