cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
908
Views
0
Helpful
1
Replies

RBSCP - Anyone have it working?

bennett.troy
Level 1
Level 1

I am trying to implement RBSCP on two 3845s running 15.1(4)M1 Adv Enterprise over a satellite link.  The "show" commands all look correct, but whenever I policy route my machine through the RBSCP tunnel I dont even make it to the opposite side.  However, if I remove the "tunnel mode RBSCP" command so it acts like a regular GRE tunnel, I route through it just fine.  So I know its not a NAT, routing issue.  Here are my configs.

Local Side:

object-group network RBSCP_Networks

host 10.10.101.150

!

object-group service RBSCP_Ports

tcp

132

esp

ahp

ip    (I want to just try to route all traffic through it for now, I have tried it with just TCP and it still didnt work)

!

ip access-list extended RBSCP

remark TCP-TRAFFIC_ONLY

permit object-group RBSCP_Ports object-group RBSCP_Networks any

deny   ip any any

!

!

interface Tunnel200

description RBSCP to Remote

ip unnumbered GigabitEthernet0/0

keepalive 10 3

tunnel source GigabitEthernet0/0

tunnel mode rbscp

tunnel destination 10.10.10.138

tunnel ttl 5

tunnel bandwidth transmit 3500

tunnel rbscp delay

tunnel rbscp window-stuff 1

tunnel rbscp ack-split 4

!

!

route-map RBSCP-PBR permit 10

match ip address RBSCP

set interface Tunnel200

!

interface FastEthernet0/0/0

ip policy route-map RBSCP-PBR

-----------------------------------------------------------------------------------------------------------------

Remote Side:

object-group network RBSCP_Networks_****

host 10.10.101.150

object-group service RBSCP_Ports

tcp

132

esp

ahp

ip

!

ip access-list extended RBSCP

remark TCP-TRAFFIC_ONLY

permit object-group RBSCP_Ports any object-group RBSCP_Networks_****

deny   ip any any

!

interface Tunnel200

description RBSCP to Local

ip unnumbered GigabitEthernet0/0

ip nat inside

ip virtual-reassembly in

keepalive 10 3

tunnel source GigabitEthernet0/0

tunnel mode rbscp

tunnel destination 10.10.10.137

tunnel ttl 5

tunnel bandwidth transmit 3500

tunnel rbscp delay

tunnel rbscp window-stuff 1

tunnel rbscp ack-split 4

!

!

interface FastEthernet0/0/0

ip policy route-map RBSCP-PBR

!

route-map RBSCP-PBR permit 10

match ip address RBSCP

set interface Tunnel200

-----------------------------------------------------------------------------------------------------

Show commands for local and remote:

router-local#

sh rbscp all tunnel 200

Tunnel200 is up, line protocol is up

RBSCP operational state:  OPEN

RBSCP operating mode: (26Eh) delay dual_delay ack_split window_stuffing inorder SCTP_report

  window step: 1

  drop scale : 0

  ACK split size: 4

  input drop scale: 2

  initial TSN: 1h

  fuzz factor: 0

  max burst: tunnel 16, network 16

  next TSN: 1h

  next sequence: 4C3h

  current outstanding: 0

  out with no ack: 0

  max out per RTT: 230125

  packets since SACK: 0

  cumulative ack: 133h

  TSN at SACK: 133h

  last cumulative ack: 0h

  last delivered TSN: 133h

  next FWDTSN corr: 4h

  RTO: 680 ms

  RTT: 526 ms     srtt_sa: 4173   srtt_sv: 10

  sentQ: num packets: 0, num bytes: 0

  tmitQ: num packets: 0, num bytes: 0

RBSCP protocol statistics:

  Init FWD-TSNs sent 0, received 1

  TUNNEL-UPs sent 0, received 2

  CLOSEDs sent 0, received 1

  TSNs sent 0, resent 0, lost by sender: gap 0, timeout 0

  TSNs received 2416 (duplicates 0)

  FWD-TSNs sent 1276 (heartbeats 1233)

  FWD-TSNs received 1 (ignored 0)

  FWD-TSNs caused 4 packet drops, 0 whole window drops

  SACKs sent 2419, received 1230 (ignored 0)

  Recovered with RTX 2

  Received with delay 2

  Packets released into: tunnel 3696, network 2416

  Failed sends into the: tunnel 0, network 0

  Most released at once: tunnel 1, network 1

  Dropped due to: excess delay 0, tmit queue full 0

  Dropped detunneled packets 0

  Max on any queue: num packets: 0, num bytes: 0

  Max outstanding: 0

-----------------------------------------------------------------------------------------

router-remote#

sh rbscp all tunnel 200

Tunnel200 is up, line protocol is up

RBSCP operational state:  OPEN

RBSCP operating mode: (26Eh) delay dual_delay ack_split window_stuffing inorder SCTP_report

  window step: 1

  drop scale : 0

  ACK split size: 4

  input drop scale: 2

  initial TSN: 1h

  fuzz factor: 0

  max burst: tunnel 16, network 16

  next TSN: 1D1h

  next sequence: 1h

  current outstanding: 0

  out with no ack: 0

  max out per RTT: 229687

  packets since SACK: 0

  cumulative ack: 0h

  TSN at SACK: 0h

  last cumulative ack: 1D0h

  last delivered TSN: 0h

  next FWDTSN corr: 0h

  RTO: 679 ms

  RTT: 525 ms     srtt_sa: 4173   srtt_sv: 8

  sentQ: num packets: 0, num bytes: 0

  tmitQ: num packets: 0, num bytes: 0

RBSCP protocol statistics:

  Init FWD-TSNs sent 0, received 2

  TUNNEL-UPs sent 0, received 1

  CLOSEDs sent 0, received 1

  TSNs sent 2577, resent 6, lost by sender: gap 0, timeout 4

  TSNs received 0 (duplicates 0)

  FWD-TSNs sent 33 (heartbeats 2)

  FWD-TSNs received 0 (ignored 1314)

  FWD-TSNs caused 0 packet drops, 0 whole window drops

  SACKs sent 1315, received 2574 (ignored 0)

  Recovered with RTX 0

  Received with delay 0

  Packets released into: tunnel 3933, network 0

  Failed sends into the: tunnel 0, network 0

  Most released at once: tunnel 1, network 0

  Dropped due to: excess delay 0, tmit queue full 0

  Dropped detunneled packets 0

  Max on any queue: num packets: 5, num bytes: 552

  Max outstanding: 552

Any help would be great

1 Reply 1

cadet alain
VIP Alumni
VIP Alumni

Hi,

taken from Cisco doc:

If IP access lists (ACLs) are configured on an  interface that is used by an RBSCP tunnel, the RBSCP IP protocol (199)  must be allowed to enter and exit that interface or the tunnel will not  function.

Isn't this the problem ?

Could you do debug ip policy and debug tunnel rbscp.

Regards.

Alain.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card