cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
114
Views
0
Helpful
0
Replies
salvadormejianin
Beginner

Redistribute OSPF area through a static link (STUDENT QUESTION)

Please be kind, I'm just a student and I'm not in my native language... I have to redistribute from LAN1 to ISP1 and ISP2 the OSPF domain, I do not know how to do this without making IPS1 and ISP2 part of OSPF. Guess to my teacher I have to make two default routes with different metrics (with additional configuration like some sla to prove reachability to the loopbacks in INTERNET, where ISP1 and 2 make PAT to INTERNET) .. And some PBRs between LAN2 and LAN1

There's something I'm missing? How do I make "aware" LAN2 of the default route in LAN1 and ISPs to route the LAN2's packets through PAT without any routing protocol between LAN1 and the ISPs but making two defualt rotues in LAN1 like the teacher asked me to do?

 

In ISP1 if I do a show access-list 1 (while pinging from LAN2 to INTERNET addresses <not loopback>) I can see some matches..

ISP1#show access-lis 1
Standard IP access list 1
10 permit any (73 matches)

but any response from INTERNET

 

2nd question: How do I make the loopbacks on INTERNET reachable without any routing protocol between INTERNET and the ISPs rotuers?

 

I have made a several testing with default routes in LAN1. I know I have to make something like this:

<LAN1#conf> 0.0.0.0 0.0.0.0 <int of LAN1 to ISP1>

<LAN1#conf> router ospf 1

<LAN1#router-conf> default-information originate

But that doesn't work. In ISP1 I have

access-list 1 permit any <-- yes I know that's not appropiate

ip nat inside source-list 1 interface s3/0 overload

<and the proper IP nat inside and outside interfaces>

 

gns3 topologia cap 5.PNGI had thought that the problem was between the ISP1 and INTERNET. My teacher did not ask me to make routing (like Bgp) between INTERNET and the ISPs (I actually asked him about it and said me that it is not necessary) neither he asked me to make the links between LAN1 and the ISPs part of OSPF domain. The weird thing is that if I make the PAT in one of the ISPs and I make the default route in LAN1 I can ping from LAN1 to one of the serial interface of INTERNET, but not to the loopbacks. If I redistribute with default-information that default route to LAN2, LAN2 actually has a default route in the routing table like this:

O*E2 0.0.0.0/0 [110/1] via 10.0.3.138, 00:31:14, FastEthernet6/0
10.0.0.0/8 is variably subnetted, 10 subnets, 4 masks
O E2 10.0.3.0/26 [110/20] via 10.0.3.138, 01:02:11, FastEthernet6/0
O E2 10.0.3.128/29 [110/20] via 10.0.3.138, 01:02:11, FastEthernet6/0

 

This is my configuration in LAN1 to OSPF

LAN1(config)#ip route 0.0.0.0 0.0.0.0 g1/0

LAN1(config-router)#do sh run | sec router os

router ospf 1
router-id 1.1.1.1
redistribute eigrp 100 subnets <-- I have to redistribute between OSPF and EIGRP, but nothing between EIGRP and the PAT..
network 10.0.3.136 0.0.0.7 area 0
default-information originate

 

This is my configuration in LAN2 (inside the OSPF domain)

LAN2#sh run | sec router os
router ospf 1
router-id 2.2.2.2
network 10.0.0.0 0.0.0.255 area 0
network 10.0.1.0 0.0.0.255 area 0
network 10.0.2.0 0.0.0.255 area 0
network 10.0.3.136 0.0.0.7 area 0

 

Help me here. God bless you

0 REPLIES 0