cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
237
Views
5
Helpful
5
Replies

redistributing static into BGP

hmc250000
Beginner
Beginner

I have the following configured in a GNS3 on an L3 Switch (Site2) but not all the routes are seen in the neighboring BGP router (R7). The static routes are routes to loopback interfaces on R11. AM I missing something? PLEASE SEE topology attached.

 

On L3 Switch Site2:

router bgp 1000
bgp log-neighbor-changes
neighbor 192.168.16.2 remote-as 1001
address-family ipv4
network 192.168.16.0
network 192.168.20.0
redistribute connected route-map Advertise_Connected_Routes
redistribute static route-map Static_Routes_Prefix
neighbor 192.168.16.2 activate
exit-address-family
ip route 192.168.0.0 255.255.0.0 192.168.16.3
ip route 192.168.20.0 255.255.255.0 192.168.15.2
ip route 192.168.21.0 255.255.255.0 192.168.15.2 permanent name network21
ip route 192.168.22.0 255.255.255.0 192.168.15.2 permanent name network22

ip prefix-list Advertise_Connected_Routes seq 10 permit 192.168.10.0/24
ip prefix-list Advertise_Connected_Routes seq 20 permit 192.168.15.0/24
ip prefix-list Advertise_Connected_Routes seq 30 permit 192.168.16.0/24

ip prefix-list Static_Routes_Prefix seq 10 permit 192.168.20.0/24
ip prefix-list Static_Routes_Prefix seq 20 permit 192.168.21.0/24
ip prefix-list Static_Routes_Prefix seq 30 permit 192.168.22.0/24

route-map Advertise_Connected_Routes permit 10
match ip address prefix-list Advertise_Connected_Routes

route-map Static_Routes permit 10
match ip address prefix-list Static_Routes_Prefix

 

 

On R7 this is configured:

router bgp 1001
no synchronization
bgp log-neighbor-changes
network 10.0.1.4 mask 255.255.255.252
neighbor 10.0.1.5 remote-as 1002
neighbor 192.168.16.1 remote-as 1000
no auto-summary

 

 

 

I'm seeing this on router R7:

R7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B 192.168.15.0/24 [20/0] via 192.168.16.1, 00:00:26
B 192.168.10.0/24 [20/0] via 192.168.16.1, 00:00:26
B 192.168.20.0/24 [20/0] via 192.168.16.1, 00:00:26
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.1.4 is directly connected, GigabitEthernet0/0
C 192.168.16.0/24 is directly connected, GigabitEthernet1/0

 

 

 

 

Capture.JPG

5 Replies 5

MHM Cisco World
Advisor
Advisor

can you share the 
show ip bgp in R7?

Jon Marshall
VIP Community Legend VIP Community Legend
VIP Community Legend

 

Under your BGP configuration change this - 

 

redistribute static route-map Static_Routes_Prefix

 

to 

 

redistribute static route-map Static_Routes

 

Jon

Darnit!!! How did I miss this. Lol. Good to have another set of eyes verify things.  Thtank you Jon. 

 

 

All is good now.

 

R7#sh ip bgp
BGP table version is 11, local router ID is 192.168.16.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.1.4/30 0.0.0.0 0 32768 i
* 10.0.1.5 0 0 1002 i
*> 192.168.10.0 192.168.16.1 0 0 1000 ?
*> 192.168.15.0 192.168.16.1 0 0 1000 ?
r> 192.168.16.0 192.168.16.1 0 0 1000 i
*> 192.168.20.0 192.168.16.1 0 0 1000 i
*> 192.168.21.0 192.168.16.1 0 0 1000 ?
*> 192.168.22.0 192.168.16.1 0 0 1000 ?
R7#

Another question. When redistributing static routes into BGP are metrics of any significance? And if so what should the value be?

 

redistribute static metric ? route-map Static_Routes_Prefix

MHM Cisco World
Advisor
Advisor

Yes you can use it, 
R1-static-R2-eBGP-R3
R4-static-R5-eBGP-R3
assume you config two static route with two different metric toward R1 and R4 for same prefix
R2/R5 will advertise this static toward R3 
metric of static route will be add as MED attribute and send to R3
R3 can use this MED attribute to prefer one path than other.
this is one use of static route metric in BGP.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers