cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
131
Views
0
Helpful
0
Replies
Beginner

Redistribution between VRF enabled BGP and global OSPF (solved)

(Update 3/13) - I added "import ipv4 unicast map cff-internal-routemap" under one of VRFs interface with a prefix-list and route-map in order to redistribute OSPF into vrf enabled bgp.  I see a little progress, but I am still not able to redistribute global OSPF to vrf BGP. ... 

 

 

diagram

Azure MSSE (Microsoft Edge)  =======================   (vrf1: coresite1 / vrf2: coresite2)  Gateway --- internal sw(l3) 

 

Hi, I have Azure ExpressRoute connected with edge (Gateway). Please see my attached photo for name. The gateway router is able to establish two eBGP session through two VRF interface (Coresite1 and Coresite2) which has two different RD. I do not have any issue between MSSE (Microsoft Service Edge) and gateway. Now I like to redistribute routes learned from internal switch (l3) which is connected through OSPF without VRF meaning that Gateway has two vrf interface toward MSSE while there is single connection to internal switch (L3). When I tried to redistribute global OSPF routes into vrf enabled BGP, it did not work because OSPF is not VRF enabled (there is only one connection, so I don't need vrf connection to internal switch). 

 

Here are my questions. 

 

1. OSPF to vrf-BGP redistribution--- I got %VRF specified does not match this router. 

DC1-4451-ISR-01(config-router-af)#redistribute ospf 1 match internal
%VRF specified does not match this router  

 

 (Once I added import ipv4 / export imp4, it worked)

 

2. vrf-BGP to OSPF redistribution -- The below commend works, but I don't see route. I tried "redistribute bgp 6552 vrf coresite1 subnet" as well meaning that I put vrf names, but did not take it (show run does not show the vrf)

router ospf 1
auto-cost reference-bandwidth 10000
redistribute bgp 65522 subnets

 

I guess that I have to enable vrf on gateway? what am I missing? 

 

Thanks. 

 

 

 

 

ip vrf coresite1
rd 65522:1
route-target export 65522:1
route-target import 65522:1

import ipv4 unicast map cff-internal-routemap (added)
!
ip vrf coresite2
rd 65522:2
route-target export 65522:2
route-target import 65522:2
!
!
!
!
interface Loopback0
ip vrf forwarding coresite1
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0/0
ip address 10.191.192.2 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/1.445
encapsulation dot1Q 445
ip vrf forwarding coresite1
ip address 10.191.190.1 255.255.255.252
bfd interval 300 min_rx 300 multiplier 3
!
interface GigabitEthernet0/0/1.747
encapsulation dot1Q 747
ip vrf forwarding coresite2
ip address 10.191.190.5 255.255.255.252
bfd interval 300 min_rx 300 multiplier 3
!
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 10.200.201.10 255.255.255.0
negotiation auto
!
router ospf 1
auto-cost reference-bandwidth 10000
redistribute bgp 65522 subnets
network 10.191.0.0 0.0.255.255 area 0
!
router bgp 65522
bgp router-id 10.200.201.10
bgp log-neighbor-changes
!
address-family ipv4 vrf coresite1
bgp router-id 10.191.190.2
neighbor 10.191.190.2 remote-as 12076
neighbor 10.191.190.2 fall-over bfd
neighbor 10.191.190.2 activate
neighbor 10.191.190.2 soft-reconfiguration inbound
neighbor 10.191.190.2 prefix-list no-default-route in
exit-address-family
!
address-family ipv4 vrf coresite2
bgp router-id 10.191.190.6
neighbor 10.191.190.6 remote-as 12076
neighbor 10.191.190.6 fall-over bfd
neighbor 10.191.190.6 activate
neighbor 10.191.190.6 soft-reconfiguration inbound
neighbor 10.191.190.6 prefix-list no-default-route in
exit-address-family
!
!
ip prefix-list no-default-route seq 5 deny 0.0.0.0/0
ip prefix-list no-default-route seq 10 permit 0.0.0.0/0 le 32

 

ip prefix-list cff-internal seq 13 permit 2.2.2.2/32
ip prefix-list cff-internal seq 14 permit 10.221.231.0/24

 

route-map cff-internal-routemap permit 10
match ip address prefix-list cff-internal