cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
313
Views
0
Helpful
1
Replies

Redundant ADSL to MPLS

Mounirabdallah
Level 1
Level 1

Network setupPicture attached.

Objective:

1. ALL traffic from VLAN1 and VLAN2 in branch office to headquarters is routed via Dialer1. If dialer1 is not available then all traffic is routed via dialer2.

2. ALL traffic from VLAN1 and VLAN2 in branch office to the internet is routed via Dialer2. If dialer2 is not available then all internet traffic is routed via dialer1.

This configuration is yet to be going into production but I am not sure whether it will work. Please verify which Option makes more sense.

Thanks

My Configuration Option 1:

uilding configuration...

Current configuration : 3291 bytes
!
! Last configuration change at 21:59:11 UTC Thu Mar 9 2017 by plesi
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Busways_kempsey
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
enable secret 5 $1$QWCt$Fl4eD6Nu.WOFoDdFW2hz5/
enable password plesi1
!
no aaa new-model
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
vpdn enable
!
!
license udi pid C887VA-K9 sn
!

!
controller VDSL 0
!
!
interface ATM0
description ### DSL1 ###
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
description ### RESERVED_FOR_VOICE_LAN ###
no ip address
shutdown
!
interface FastEthernet1
switchport trunk allowed vlan 1,2,101,1002-1005
switchport mode trunk
no ip address
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
description ### DSL2 ###
switchport access vlan 3
no ip address
no cdp enable
!
interface Vlan1
description ### ###
ip address 10.1.11.1 255.255.255.0
ip virtual-reassembly in
ip tcp adjust-mss 1452
ip policy route-map RM-TO-HEADQUARTERS
!
interface Vlan2
description ### PORT_MACQUARIE_WIFI_LAN ###
ip address 192.168.11.1 255.255.255.0
ip virtual-reassembly in
ip tcp adjust-mss 1452
ip policy route-map RM-TO-HEADQUARTERS
!
interface Vlan3
description ### VLAN DSL2 ###
no ip address
pppoe enable
pppoe-client dial-pool-number 2
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp chap hostname xxxxxxxxxxxx
ppp chap password 0 xxxxxxxxxxxxx
!
interface Dialer2
description ### INTERNET ###
ip address negotiated
ip mtu 1492
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 2
dialer idle-timeout 0
dialer persistent
dialer-group 2
ppp chap hostname xxxxxxxxxxxxxxxx
ppp chap password xxxxxxxxxxxxxx
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip access-list extended ACL-ROUTE-TO-HEADQUARTERS
permit ip 10.1.11.0 0.0.0.255 10.1.1.0 0.0.0.255
permit ip 10.1.11.0 0.0.0.255 192.168.1.0 0.0.0.255
permit ip 192.168.11.0 0.0.0.255 10.1.1.0 0.0.0.255
permit ip 192.168.11.0 0.0.0.255 192.168.1.0 0.0.0.255

route-map RM-TO-HEADQUARTERS permit 10
match ip address ACL-ROUTE-TO-HEADQUARTERS
set ip next-hop dialer1
set ip next-hop verify-availability
!
!
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer1 10
!
control-plane
!
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

=========================

My Configuration Option 1:

!
interface ATM0
description ### DSL1 ###
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
description ### RESERVED_FOR_VOICE_LAN ###
no ip address
shutdown
!
interface FastEthernet1
switchport trunk allowed vlan 1,2,101,1002-1005
switchport mode trunk
no ip address
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
description ### DSL2 ###
switchport access vlan 3
no ip address
no cdp enable
!
interface Vlan1
description ### ###
ip address 10.1.11.1 255.255.255.0
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Vlan2
description ### ###
ip address 192.168.11.1 255.255.255.0
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Vlan3
description ### VLAN DSL2 ###
no ip address
pppoe enable
pppoe-client dial-pool-number 2
!
interface Dialer1
description ### Headquarters ###
ip address negotiated
ip mtu 1492
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp chap hostname
ppp chap password
!
interface Dialer2
description ### INTERNET ###
ip address negotiated
ip mtu 1492
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 2
dialer idle-timeout 0
dialer persistent
dialer-group 2
ppp chap hostname
ppp chap password
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
track 1 ip sla 1
track 2 ip sla 2
!
!
ip sla 1
icmp-echo 10.250.38.10 source-interface Dialer1
timeout 1000
frequency 5000
ip sla schedule 10 life forever start-time now
!
!
ip sla 2
icmp-echo 8.8.8.8 source-interface Dialer2
timeout 1000
frequency 5000
ip sla schedule 10 life forever start-time now
!
!
!
ip route 10.1.0.0 0.0.255.255 Dialer1 track 1 1
ip route 192.168.0.0 0.0.255.255 Dialer1 track 1 1
ip route 10.1.0.0 0.0.255.255 Dialer2 track 2 10
ip route 192.168.0.0 0.0.255.255 Dialer2 track 2 10
!
ip route 0.0.0.0 0.0.0.0 Dialer2 track 2 1
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1 10
!
control-plane
!
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

1 Reply 1

Francesco Molino
VIP Alumni
VIP Alumni

Hi 

Both solutions will work. 

This depends also on the image your using on your router but I bet you already checked that. 

Pbr will allow you granular routing decisions based on the source subnet if you plan having more subnets. 

On your actual design, you can decide either to use one or other. 

I'll prefer using pbr in that situation because you can precisely select which traffic goes where in case of growth. 

Thanks 

PS: Please don't forget to rate and mark as correct answer if this answered your question


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Review Cisco Networking products for a $25 gift card