cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1980
Views
5
Helpful
5
Replies
Iluvnetwork
Beginner

RIP Version 2 Routing Table & DHCP Question :)

 

R3# show ip route

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

R 1.0.0.0/8 is possibly down, routing via 1.1.1.2, Serial0/0

C 1.1.1.0/24 is directly connected, Serial0/0

3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

R 3.0.0.0/8 [120/1] via 192.168.0.253, 00:02:31,

FastEthernet0/0

R 3.3.3.0/24 [120/1] via 192.168.0.253, 00:00:21,

FastEthernet0/0

C 192.168.0.0/24 is directly connected, FastEthernet0/0

R 200.0.0.0/24 [120/1] via 1.1.1.2, 00:00:16, Serial0/0


After 1min or few sec,

1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Serial0/0

3.0.0.0/24 is subnetted, 1 subnets

R 3.3.3.0 [120/1] via 192.168.0.253, 00:00:23, FastEthernet0/0

C 192.168.0.0/24 is directly connected, FastEthernet0/0

R 200.0.0.0/24 [120/1] via 1.1.1.2, 00:00:21, Serial0/0


After rip routing (Version 2 + no auto-summary), I was expecting to see two C and two R. However, as you can see, 6 lines routing table was made somehow. After few seconds or 1 min, 6 lines routing table became as I expected. Can anyone explain to me why the routing table was 6 lines instead of 4 lines at the beginning?

I configured DHCP setting on both active and standby. Is there anyway that the active router sends the DHCP configuration to the standby router?

 

 

Router 4's Configuration

 

Router(config)#do show

show

% Incomplete command.

Router(config)#do show run

Building configuration...

 

Current configuration : 696 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

ip dhcp pool test

network 200.0.0.0 255.255.255.0

default-router 200.0.0.254

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 200.0.0.253 255.255.255.0

duplex auto

speed auto

standby 0 ip 200.0.0.254

standby priority 255

!

interface Serial0/0

bandwidth 64

ip address 1.1.1.2 255.255.255.0

!

router rip

version 2

network 1.0.0.0

network 200.0.0.0

no auto-summary

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
paul driver
VIP Expert

Hello

What you are seeing is due to the disablement of auto summerization and rip ver 2 being applied and as such the classful network 1.0.0.0/8 which was being advertised will now be re advertised with its correct subnet mask 1.1.1.0/24.

The old 1.0.0.0/8 route ( as you have posted) will eventually timeout thorough the RIP protocol invalid and holddown timers.(unless you manually clear the route table)

 

res

Paul

 

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

5 REPLIES 5
Julio E. Moisa
VIP Mentor

Hi

Based on your topology and IP plan the HSRP on the left side is not configured properly they (Router 1 and 3) have different HSRP virtual IP, is that information right? otherwise please share the config into a notepad. 

 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Opps my bad. I did configure correctly :) Both virtual IP is 192.168.0.252

Updated Configuration Info. 

Hi,

That is ok, I see the following message: possibly down:

R 1.0.0.0/8 is possibly down, routing via 1.1.1.2, Serial0/0

C 1.1.1.0/24 is directly connected, Serial0/0

3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

R 3.0.0.0/8 [120/1] via 192.168.0.253, 00:02:31,

 

 

It can indicate a poisoning route was received, when during the hold down timer is being processed and if an update with valid information about a recovered network it will be restablished. The poisoning route is used to avoid loops on distance vector routing protocols. 

 

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
paul driver
VIP Expert

Hello

What you are seeing is due to the disablement of auto summerization and rip ver 2 being applied and as such the classful network 1.0.0.0/8 which was being advertised will now be re advertised with its correct subnet mask 1.1.1.0/24.

The old 1.0.0.0/8 route ( as you have posted) will eventually timeout thorough the RIP protocol invalid and holddown timers.(unless you manually clear the route table)

 

res

Paul

 

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thank you very much! Perfect Explanation :)