cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

325
Views
0
Helpful
6
Replies
Highlighted

Route map matching criteria

Hi Folks, 

 

im just running into an existential question here, 

 

We are running iBGP to exchange some prefixes via prefix list, I havent had the time to study the design for years, now, there was a requirement to allow a couple of subnets, 

 

all good, but during my diagnosis, I discovered that there is a route map declared matching a prefix list where I had to add my subnets, but it is not being applied anywhere, its just declared and pointing to the itself (loopback of the router )

 

the thing during my window, if the subnet is not in the prefix, it will not advertise in or out, 

 

How come it works if there is no policy criteria to the peers declared under bgp? not even applied to any interface, its just the routemap declared only, 

 

is there any other magic trick like that or I guess Im missing something, 

 

anyone else have any much more explanation for that? 

 

Regards

Everyone's tags (2)
6 REPLIES 6
Highlighted
VIP Mentor

Re: Route map matching criteria

Hello

Your explanation seems a bit vague, Are you saying you have a route-map configured matching on a prefix-list however this route-map isn't appended to any interface or under any routing process and you say it looks like its still being called upon for route filtering/advertisement?.

Would you be able to post the configuration pertaining to this?.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Re: Route map matching criteria

Hi, yeah, my explantion seemed redudant,

here is the config,

interface Loopback0
ip address 192.168.1.1 255.255.255.255

router bgp 64512
bgp router-id 192.168.1.1
bgp log-neighbor-changes
neighbor 192.168.1.2 remote-as 64512

route-map MYROUTEMAP permit 5
match ip address prefix-list FROM-CLIENT
set ip next-hop 192.168.1.1

notes:

If I dont add the subnet to the prefix, it wont be advertised,
route map MYROUTEMAP is not applied anywhere in the config, neither BGP config nor interface, it is exactly as above






Highlighted
VIP Mentor

Re: Route map matching criteria

Hello

Do you any interface with ip policy-route applied as it looks like it was created for policy based routing?

sh run | in policy-route

sh run | in MYROUTEMAP

sh route-map MYROUTEMAP


However if that route-map isn't attached to any interface or routing process I cannot see how it will negate any prefix from being advertise.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Re: Route map matching criteria

yep, I did the same thought process as you say, but believe it or not, and I dont get anything by lying here, if I dont add the subnets, they wont get propagated, started to think a router issue perhaps,

this is after running the commands a few seconds ago:

router#sh run | in policy-route
router#sh run | inc MYROUTEMAP
route-map MYROUTEMAP permit 5
router#sh route-map MYROUTEMAP
route-map MYROUTEMAP, permit, sequence 5
Match clauses:
ip address prefix-lists: FROM-CLIENT
Set clauses:
ip next-hop 192.168.1.1
Policy routing matches: 0 packets, 0 bytes
router#


its an ISR4431/K9,

although, the CPU looks fine


router#show processes cpu
CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
1 4 34 117 0.00% 0.00% 0.00% 0 Chunk Ma

but thanks so much for your assistance, I thought there was a magic here, but seems like is a erratic behavior I guess,
Highlighted
Rising star

Re: Route map matching criteria

Could you share your complete config (removing sensitive information)? Also, at least, the BGP related config from the other router. It will help us to see if there is anything you missed by any chance.

 

HTH,

Meheretab

HTH,
Meheretab
Highlighted
VIP Mentor

Re: Route map matching criteria

Hello

One last thing


@Kn1ghtR1d3rOfD00m wrote:
the thing during my window, if the subnet is not in the prefix, it will not advertise in or out,

route-map MYROUTEMAP, permit, sequence 5
Match clauses:
ip address prefix-lists: FROM-CLIENT
Set clauses:
ip next-hop 192.168.1.1
Policy routing matches: 0 packets, 0 byte

Are you saying is you remove a prefix statement from thie prefix-list FROM-CLIENT, then any route related to that prefix statement is lost?

 

As suggested by @Meheretab Mengistu if applicable post the running config of your rtr, iy may assist in resolving your issue, If you have any!

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future