cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
661
Views
0
Helpful
12
Replies
Highlighted
Beginner

Route static and MP-BGP , change the weigth

Hello,

I have a network with MPLS/MP-BGP  actived.

device = ME-3800-X

It's ok.

But today, I would like change the weight of some route.

But, route are well advertised but without the weight changed.

 

My config :

 

router bgp 65000

 address-family ipv4 vrf vrf_tetra
  redistribute connected
  redistribute static route-map SET-WEIGHT-VRF-TETRA
 exit-address-family

!

ip route vrf vrf_tetra 10.28.0.0 255.255.0.0 10.28.200.118

!

access-list 99 permit 10.28.0.0 0.0.255.255

!

route-map SET-WEIGHT-VRF-TETRA permit 10
 match ip address 99
 set weight 200

 

 

Cordialy

 

 

 

12 REPLIES 12
Highlighted
Hall of Fame Guru

 

BGP weight is only local to the router you define it on so it won't be carried in routing advertisements to other routers. 

 

What exactly are you trying to achieve ? 

 

Jon

 

 

Highlighted

Hooooo

I am an idiot.

Can i use LOCAL_PREF  for this ?

 

Cdlt,

 

 

 

 

Highlighted

 

Local preference will influence traffic leaving your site not traffic coming into your site. 

 

It is not clear which one you want at the moment. 

 

Jon

Highlighted

Ok.

I want influence other routers on my network.

 

 

 

 

Highlighted

 

In terms of traffic inbound to the router you are applying the configuration to ? 

 

If so the usual way is to use AS path prepending. 

 

Jon

Highlighted

I create a route-map , SET-AS-PATH-VRF-TETRA

 

route-map SET-AS-PATH-VRF-TETRA permit 10
match ip address 99
set as-path prepend 65002 65002

 

But, i have a probleme with static route.

It's not supported.

 

 

sw_pn_nts141_ric(config-router-af)#redistribute static route-map SET-AS-PATH-VRF-TETRA
% "SET-AS-PATH-VRF-TETRA" used as redistribute static into bgp route-map, set as-path prepend not supported
sw_pn_nts141_ric(config-router-af)#

 

 

Cordialy,

 

 

 

Highlighted

 

Haven't got time to test at the moment but try creating a new route map for just the prepending and apply that route map to the neighbor(s) you want to influence. 

 

Make sure in your route map you include a second permit statement for all the other routes you are not prepending. 

 

Jon

Highlighted

Juste pour explain :

 

CPE1 ------FW1--------R_1-------------R3

|                                    |                           |

ospf                               |                           |

|                                    |                           |

CPE2-------FW2-------R_2|-------------r-4 ------->Other_net 

 

On R_1  : static route  to  CPE1 via FW1

ON R_2 : static route  to  CPE2 via FW2

There is not routage protocol between CPEx etR_x

 

 I would like  influente other router, the traffic must be forwarder first  by R1   and backup by R2 if R1 is broken. 

R1 / R2 R3 R4 , MPLS and VRF.

 

 

Highlighted

 

Are R1 and R2 internal to your network so the CE routers connect to the MPLS network which is not shown in your diagram ? 

 

Apologies but it is still not clear what you are trying to do ie. influence traffic coming from the MPLS network or influence traffic going to the MPLS network ? 

 

Jon

Highlighted

I am sure that there are things in the discussion that I do not understand well. But one thing I am clear about. The attempt to use a route map for prepending was applied to redistribution. And it was rejected because you prepend on route maps that are applied to what you advertise to a neighbor and not applied on how you learned the route. 

 

I agree with Jon that we need a better understanding of the environment and clarity about what you are trying to achieve.

 

HTH

 

Rick

HTH

Rick
Highlighted

Hello,

Sorry for my late.

It's OK now.

I try to explain to you  What I did.

Excuse me for my english.

 

  1. On R1 (edge MPLS network) , this routeur diffuse the client's static route to MPLS whithout change the metric
    1. Create IP SLA  
      ip sla 99
       icmp-echo 10.28.200.110 (@ip cpe2) source-interface Vlan3200
       vrf vrf_tetra
       threshold 50
       timeout 1000
       frequency 5
      ip sla schedule 99 life forever start-time after 00:00:10
      
    2. Create IP track 
      track 99 ip sla 99 reachability
    3. Add IP track on static route to LAN Client
       ip route vrf vrf_tetra 10.28.41.100 255.255.255.255 10.28.200.118 (# it's FW1)  track 99
    4.  BGP  on R1
      router bgp 65000 //
      address-family ipv4 vrf vrf_tetra redistribute connected redistribute static exit-address-family
  2. On CPE1 (edge cpe network) , this routeur diffuse the  static route of MPSL  to its  LAN client.There is also an IP SLA / TRACK pour static route to MPSL.
  3. On R2, like R1 but BGP redistribute static client  to MPLS Network  with metric of 200.
    1. Create IP SLA  
      ip sla 99
       icmp-echo 10.28.200.106 (#@ip of cpe2) source-interface Vlan3200
       vrf vrf_tetra
       threshold 50
       timeout 1000
       frequency 5
      ip sla schedule 99 life forever start-time after 00:00:10
      
    2. Create IP track 
      track 99 ip sla 99 reachability
    3. Add IP track on static route to LAN Client
       ip route vrf vrf_tetra 10.28.41.100 255.255.255.255 10.28.200.118 (# it's FW2)  track 99
    4.  BGP  on R1
      router bgp 65000 //
      address-family ipv4 vrf vrf_tetra
      redistribute connected
      redistribute static metric 200
      exit-address-family

2019-01-29 08_47_23-Dessin1.VSD - Microsoft Visio.png

 

 

 

 

Highlighted

Thank you for the update. Glad to know that now it is OK.

 

HTH

 

Rick

HTH

Rick