cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1275
Views
0
Helpful
1
Replies
davidhuynh5
Beginner

Routed Switch Virtual Interface vs. Routed Interface

What are the pros and cons of configuring a Switch Virtual Interface (SVI) versus a routed physical port between layer 3 switches?

For example, if I have two 4506s and have a need to run HSRP and route between them which feature is better and why?

switch_a

!

interface vlan 25

ip address 10.10.10.1 255.255.255.0

!

interface fa0/1

switchport mode trunk

switch_b

!

interface vlan 25

ip address 10.10.10.2 255.255.255.0

!

interface f0/1

switchport mode trunk

----------------------------------

switch_a

!

interface fa0/1

no switchport

ip add 10.10.10.1 255.255.255.0

switch_b

!

interface f0/1

no switchport

ip address 10.10.10.2 255.255.255.0

1 ACCEPTED SOLUTION

Accepted Solutions
Reza Sharifi
Hall of Fame Expert

When you make a port a routed port, that is point-to-point port, menacing you can only have one port/interface for that subnet.  When you create an SVI, that is vlan interface meaning you can assign more then one port/host to that vlan/subnet specially when you are using a /24.  Usually for a routed port you use a /30, because that is all you need. For an SVI you use a bigger subnet i.e. /26, /25, 24, etc.... so you can add more hosts/ports to that subnet.

HTH

View solution in original post

1 REPLY 1
Reza Sharifi
Hall of Fame Expert

When you make a port a routed port, that is point-to-point port, menacing you can only have one port/interface for that subnet.  When you create an SVI, that is vlan interface meaning you can assign more then one port/host to that vlan/subnet specially when you are using a /24.  Usually for a routed port you use a /30, because that is all you need. For an SVI you use a bigger subnet i.e. /26, /25, 24, etc.... so you can add more hosts/ports to that subnet.

HTH