cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
546
Views
0
Helpful
3
Replies

Router DHCP request trough router in bridge mode

LdT
Level 1
Level 1
Hi!
 
I try to make a bridge with ROUTER1 between the ISP side and a ROUTER2.
The goal is to get a dhcp address, for the ROUTER2 address, from the ISP side.
 
In debug mode I see the ROUTER2 make a discovery but there is no offer from the other side.
I have no physical access to the devices so I can't put a Wireshark in and see the traffic passing trough routers.
 
Can you help me to find why this does not work please? Thank you!
 
I have those 2 configurations :
 
ROUTER1
 
Current configuration : 1724 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER1
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
no aaa new-model
!
resource policy
!
ip cef
ip dhcp relay information trust-all
!
!
username xxx password xxx
!
bridge irb
!
interface FastEthernet0
no ip address
duplex auto
speed auto
bridge-group 1
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
  protocol bridge broadcast
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
dsl operating-mode auto
bridge-group 1
!
interface Vlan1
ip address 172.x.x.x 255.x.x.x
!
interface Dialer0
ip address negotiated
ip access-group traffic_entrant in
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname fti/f9aphrt
ppp chap password 
ppp pap sent-username fti/f9aphrt password
ppp multilink
!
interface BVI1
no ip address
!
ip route 0.0.0.0 0.0.0.0 172.x.x.x
!
!
no ip http server
no ip http secure-server
!
access-list 101 permit udp any any eq bootpc
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
line aux 0
line vty 0 4
login local
monitor
line vty 5 15
login local
monitor
!
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end
 
 

ROUTER 2
 
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER2
!
boot-start-marker
boot-end-marker
!
enable secret 5 
no aaa new-model
!
!
dot11 syslog
!
!
ip cef
!
multilink bundle-name authenticated
!
!
username xxx password xxx
!
!
archive
log config
  hidekeys
!
interface FastEthernet0
ip address dhcp
duplex auto
speed auto
!
interface FastEthernet1
ip address 172.x.x.x 255.x.x.x
duplex auto
speed auto
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
no ip address
!
interface Vlan2
no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.x.x.x
!
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login local
line vty 5 15
login local

1 Accepted Solution

Accepted Solutions

We had to modify ATM0 configuration on ROUTER1 to make it work :

interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5snap
!
dsl operating-mode auto
bridge-group 1

View solution in original post

3 Replies 3

chrihussey
VIP Alumni
VIP Alumni

Just taking a guess, but try adding:

!
bridge 1 protocol ieee
 bridge 1 route ip
!
Hope this helps

 

Thank you for the quick reply.
I tried but it did not work.

We had to modify ATM0 configuration on ROUTER1 to make it work :

interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5snap
!
dsl operating-mode auto
bridge-group 1
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card