cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
457
Views
0
Helpful
2
Replies

Router on a Stick with VLANS

stephen.moss88
Level 1
Level 1

Hope all of you are doing well.

My ISP (Google Fiber) has the internet coming in on VLAN2 (I am bypassing there NetworkBOX) and for some reason the routing wont work.

On my router I can ping google.com and 8.8.8.8 but on my switch I cant. The PC connected on the switch can ping the gateway. It got its ip address from the router but cant ping google.com or 8.8.8.8 as well. Please help me out.

Thanks

* Removed some of the config file to shorten it. Should have all information needed though.

------- ROUTER ----------------------------

hostname C01-CoreRouter-01


ip dhcp excluded-address 10.32.10.1 10.32.10.50
ip dhcp excluded-address 10.32.20.1 10.32.20.50
!
ip dhcp pool Managment
network 10.32.10.0 255.255.255.0
default-router 10.32.10.1
dns-server 8.8.8.8
!
ip dhcp pool Wired
network 10.32.20.0 255.255.255.0
default-router 10.32.20.1
dns-server 8.8.8.8
!
!
ip cef
ip domain name venexnetworks.com
!
multilink bundle-name authenticated

!
license udi pid CISCO1841 sn FTX1204Y1E1
username admin privilege 15 password 0 cisco
!
redundancy
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address dhcp
ip nat outside
no ip virtual-reassembly
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 10.32.10.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 10.32.20.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
interface Serial0/1/0
no ip address
shutdown
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit any
access-list 1 deny any

------- NETWORK SWITCH --------------------

hostname C01-Switch-Core-01
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Q2n6$ltPyhG5qSKDRLRZxNvXd11
!
no aaa new-model
switch 1 provision ws-c3750v2-48ps
system mtu routing 1500
ip subnet-zero
ip domain-name venexnetworks.com
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet1/0/11
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.32.10.5 255.255.255.0
!
interface Vlan20
no ip address
!
ip default-gateway 10.32.10.1
ip classless
ip http server
ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
logging synchronous
line vty 0 4
logging synchronous
login
line vty 5 15
logging synchronous
login
!
end

2 Replies 2

stephen.moss88
Level 1
Level 1

Just figured it out. Helps if I pick the right interface. I fixed the sub-interface but not the NAT settings.

This use to be a lab that plugged into my Google Fiber Network Box and now that I have removed that equipment it didn't work. 

ip nat inside source list 1 interface FastEthernet0/0 overload

vs

ip nat inside source list 1 interface FastEthernet0/0.2 overload

yes fa 0/0 did not had any ip after changes made so NAT statement for interface overload had to be changed

interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address dhcp
ip nat outside
no ip virtual-reassembly