cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
895
Views
40
Helpful
19
Replies
Lee Santos
Beginner

Same Network by 2 OSPF Protocols

Hello experts,

currently I have 2 links L2L, for one link routed a network 10.1.1.0/26, by the second link is routed other networks on my network.

I Need routed the network 10.1.1.0/26 by the two links, but always take the link 1.

I tried to add the network under the second OSPF protocol, but the network never propagated.

my ios does not support PBR, anyone know how I can resolve my problem

Annex to the topology diagram.

3 ACCEPTED SOLUTIONS

Accepted Solutions

If there was only one OSPF process per link eg. using the top link as an example from your diagram, if all the devices were in OSPF 10 then it might be easier.

But i am not suggesting you get the configuration changed without understanding why it has been done like that in the first place. Your ISP may have a good reason to have done it this way although i can't see it at the moment.

If the routers are running multiple OSPF processes there could still be a way to make it work but at the moment i need to understand exactly how it has been setup otherwise i can't test anything.

So before you talk to the ISP can you -

1) clarify which devices you have control over in terms of configuration. Is it just the L3 switches

2) are the routers running multiple OSPF processes and doing redistribution

3) if so do you know why it has been setup this way

we can test with what you have if you want but answers to the above would help.

Edit - it's late where i am so i will pick up this tomorrow unless someone else jumps in to help.

Jon

View solution in original post

syed kazim abbas
Participant

HI,

LEE

you need these commands on left hand Switch where the route 10.1.1.0/26 is existed 

router ospf 20
  redistribute connected subnets route-map TEST


route-map TEST permit 10
 match interface FastEthernet0/0
 set metric-type type-1

 

HTH

"please rate if post if helpfull"

View solution in original post

Jon,

 

It will not redistribute all connected because i am using route-map, plz see carefully 

and the second point is, it is not the opposite , because 10.1.1.0/26 is reaching the right hand switch with "O" mean same area, if u see the diagram , then it show that from left switch to right AREA 0, very interesting, I practically did it, after preparing a test bed lab.

thirdly, i cannot understand, why redistributing on all routers, even they don't have effect on routes

see the attachment

Regards,

syed

View solution in original post

19 REPLIES 19
Jon Marshall
VIP Community Legend

I Need routed the network 10.1.1.0/28 by the two links, but always take the link 1.

Not sure what you mean by this. Do you mean you want it to use the current link but use the other as backup in case the first link fails ?

If so, firstly your diagram does not show a 10.1.1.0/28 network anywhere. It does show a 10.1.1.0/26 network, is that the one you are referring to ?

If it is the 10.1.1.0/26 network then you cannot advertise this into two separate OSPF processes on the same router which is why it is not propogated when you add it to the second OSPF process.

So, assuming you do want to use the second link as a backup and it is a 10.1.1.0/26 you are referring to what you could do is redistribute routes into the second OSPF process but filter those routes so only that specific network is redistributed.

If you did this the route would be an OSPF E2 route so it would not be used unless the first link went down.

That said i have made a lot of assumptions and it would help if you could clarify exactly whay you are trying to do with and with which subnet.

Jon

Jon, thank for your coment

I just edit my post, and this is correct the network is 10.1.1.0/26 and use the second link as backup, do you have a document where I can review this configuration.

regards.

I just looked at your diagram again and noticed that you redistributing OSPF between the LAN links so routes at either end probably appear as E2s already.

This makes it a bit more difficult.

Not sure why you are redistributing everywhere but regardless of that if you do a "sh ip route 10.1.1.0 255.255.255.192" on the right hand L3 switch in your diagram do you see it as an E2 route ?

Jon

as configured now, into the switch on the right hand, not show the network 10.1.1.0/26 by the second link.

I configured a similar topology in the lab, and I have the same problem the network 10.1.1.0/28 (laboratory), on the switch on right hand only have one route to 10.1.1.0/28

I send to you the show ip route

sh ip route 
 

Gateway of last resort is 192.168.200.31 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.200.31
      10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
O E2     10.1.1.0/28 [110/2] via 10.10.12.1, 00:00:19, GigabitEthernet1/0/13
C        10.10.12.0/30 is directly connected, GigabitEthernet1/0/13
L        10.10.12.2/32 is directly connected, GigabitEthernet1/0/13
C        10.10.13.0/30 is directly connected, GigabitEthernet1/0/18
L        10.10.13.2/32 is directly connected, GigabitEthernet1/0/18
      20.0.0.0/30 is subnetted, 1 subnets
O E2     20.20.20.0 [110/1] via 10.10.12.1, 00:00:19, GigabitEthernet1/0/13

Okay that is what i expected to see.

Can you clarify something.

On your diagram the routers between the L3 switches are running an OSPF process but you also show them redistributing OSPF from the L3 switch OSPF processes.

So is each router running two OSPF processes ?

Jon

the routers run only one OSPF processes.

But your diagram is showing them redistributing OSPF into another OSPF process so both processes would have to be running on the routers.

In addition the route is showing as E2 from your IP route output so you must be doing some redistribution somewhere ie.

on the left hand switch you have 10.1.1.0/26 in OSPF 10 but when you do a "sh ip route" on the right hand switch it is an E2 so it must have been redistributed somewhere ?

To be honest it would make more sense if there was no redistribution on those routers because i can't see the need but then the route should not be an external one.

Apologies for all the questions but something is not making sense.

I am happy to lab this up to test a solution but i need to understand how it is setup  before i can do that.

Jon

 

 

I reviewed the configuration of routers, they have 2 processes running, one to the swtich L3 and one between 2 routers shows in to the driagram.

the cuestion here, my configuration in these routers should be have one processes as show in the diagram?

the cuestion here, my configuration in these routers should be have one processes as show in the diagram?

Not sure what you are asking. The diagram suggests there are two processes running on each router because you are redistributing.

What exactly is happening on the production devices ie. not in your lab.

If the routers are running multiple OSPF processes do you know why ?

Jon

this configuration is performed by the service provider, but I can request is modified.

my question is, if with only one OSPF processes is possible to works the routing

If there was only one OSPF process per link eg. using the top link as an example from your diagram, if all the devices were in OSPF 10 then it might be easier.

But i am not suggesting you get the configuration changed without understanding why it has been done like that in the first place. Your ISP may have a good reason to have done it this way although i can't see it at the moment.

If the routers are running multiple OSPF processes there could still be a way to make it work but at the moment i need to understand exactly how it has been setup otherwise i can't test anything.

So before you talk to the ISP can you -

1) clarify which devices you have control over in terms of configuration. Is it just the L3 switches

2) are the routers running multiple OSPF processes and doing redistribution

3) if so do you know why it has been setup this way

we can test with what you have if you want but answers to the above would help.

Edit - it's late where i am so i will pick up this tomorrow unless someone else jumps in to help.

Jon

View solution in original post

syed kazim abbas
Participant

HI,

LEE

you need these commands on left hand Switch where the route 10.1.1.0/26 is existed 

router ospf 20
  redistribute connected subnets route-map TEST


route-map TEST permit 10
 match interface FastEthernet0/0
 set metric-type type-1

 

HTH

"please rate if post if helpfull"

View solution in original post

Just a few points on this -

1) that would redistribute all connected routes and the requirement is just for 10.1.1.0/26

2) by making it an E1 it would be preferred over E2 which is the exact opposite of what is required ie. this redistributed route is only meant to be a backup.

However this doesn't really matter because -

3) the problem is as soon as it hits the first router it gets redistributed again and it would revert to an E2 so by the time it gets to the right hand switch it is back to an E2.

This is the main issue as far as i can see. Each router seems to be doing redistribution so whatever you do on the left hand switch is reset which would mean you would need to modify each router if you wanted to influence the routing.

Apologies if i have misunderstood what you were saying.

Jon

that's correct Jon, I require only redistribute the network 10.1.1.0/26 as backup by link 2.