cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
264
Views
0
Helpful
2
Replies

some BGP related issue.

att-sgcops
Level 1
Level 1

I have 4 routers ruuning in BGP AS1 and adopting EIGRP 100 as IGP. The connection looks like the following:

R0(interface e0)----(interface e0)R5(interface s1)-----(interface s1)R6(interface s0)----(interface S1)R4.

And the follwoing is the list of the configuration:

R0#

interface Ethernet0

ip address 172.16.1.1 255.255.255.0

no ip route-cache

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 172.15.1.4 remote-as 1

neighbor 172.15.1.6 remote-as 1

neighbor 172.16.1.2 remote-as 1

auto-summary

R5#sh run

interface Ethernet0

ip address 172.16.1.2 255.255.255.0

!

interface Serial0

ip address 10.10.10.5 255.255.255.252

no fair-queue

!

interface Serial1

ip address 32.1.1.5 255.255.255.252

!

router eigrp 100

network 32.0.0.0

network 172.16.0.0

no auto-summary

!

router bgp 1

no synchronization

bgp log-neighbor-changes

redistribute eigrp 100 metric 50 route-map localOnly

neighbor 32.1.1.6 remote-as 1

neighbor 172.15.1.6 remote-as 1

neighbor 172.16.1.1 remote-as 1

no auto-summary

!

ip classless

ip http server

!

access-list 1 permit 32.1.1.0

route-map localOnly permit 10

match ip address 1

R6#sh run

interface Serial0

ip address 172.15.1.4 255.255.255.0

no ip route-cache

no ip mroute-cache

no fair-queue

clockrate 2000000

!

interface Serial1

ip address 32.1.1.6 255.255.255.252

no ip route-cache

no ip mroute-cache

clockrate 2000000

!

router eigrp 100

network 32.0.0.0

network 172.15.0.0

no auto-summary

!

router bgp 1

no synchronization

bgp log-neighbor-changes

redistribute eigrp 100 metric 50 route-map localOnly

neighbor 32.1.1.5 remote-as 1

neighbor 172.15.1.6 remote-as 1

neighbor 172.16.1.1 remote-as 1

no auto-summary

access-list 1 permit 32.1.1.0

route-map localOnly permit 10

match ip address 1

interface Serial1

ip address 172.15.1.6 255.255.255.0

no ip route-cache

!

interface BRI0

no ip address

no ip route-cache

shutdown

!

router eigrp 100

network 172.15.0.0

no auto-summary

!

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 172.15.1.4 remote-as 1

neighbor 172.16.1.1 remote-as 1

neighbor 172.16.1.2 remote-as 1

no auto-summary

the reason I want to config the route-map on the R6 and R5 is I only want to R6 and R5 announce the network 32.1.1.0/24. But looks like R6 did not advertise 32.1.1.0 towards R4:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

R6#sh ip bgp nei 172.15.1.6 ad

~~~~~~~~~~nothing showed~~~~~~~~~~~~~~~~

R6#

When I added one more route-map:

route-map localOnly permit 100

All the network been advertised out:

R6#sh ip bgp nei 172.15.1.6 ad

BGP table version is 68, local router ID is 6.6.6.6

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

*> 32.1.1.4/30 0.0.0.0 0 32768 ?

*> 172.15.1.0/24 0.0.0.0 0 32768 ?

*> 172.16.1.0/24 32.1.1.5 50 32768 ?

*> 172.17.1.4/30 32.1.1.5 50 32768 ?

How do i do to only allow the network 32.1.1.0/24 to be advertised ?

2 Replies 2

att-sgcops
Level 1
Level 1

Sorry, for that, I mis-configured access-list. It should be "access-list 1 permit 32.1.1.4 0.0.0.3"

mounir.mohamed
Level 7
Level 7

Dear,

to advertise only the above network you could try the following configurations:

router bgp 1

no synchronization

bgp log-neighbor-changes

redistribute eigrp 100 metric 50 route-map out-routes

route-map out-routes permit 10

match ip address prefix-list out-routes

ip prefix-list out-routes seq 1 permit 32.1.1.0/24

and make sure that the subnet 32.1.1.0/24 is added in your routing tabel with the same prefix

Another woraorund you can appliy you BGP filtering in the incoming routes on R5 by the following

R5(config-router)#neighbor 32.1.1.6 remote-as 1

R5(config-router)#neighbor 32.1.1.6 prefix-list incoming in

R5(config)#ip prefix-list incoming seq 1 permit 32.1.1.0/24

Best Regards,

Mounir Mohamed

Review Cisco Networking for a $25 gift card