ā09-11-2016 04:58 AM - edited ā03-05-2019 04:40 AM
Hi,
My company had acquired a 150M internet bandwidth from a local ISP.
Due to some requirement, we will be sharing the single 150M internet bandwidth with another company.
We will need to spilt the internet bandwidth up into 100M to another company and 50M to us.
May I know what is the term called for performing such bandwidth spilt. And how do I do it on the router?
And for security reason, we do not want the companies to interfere with one another.
Please kindly advise. =)
Solved! Go to Solution.
ā09-19-2016 07:18 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
If the companies have different network prefixes, you write an ACL to match each, e.g.:
ip access-list extended CompanyX
permit ip 192.168.1.0 255.255.255.0 any
permit ip any 192.168.1.0 255.255.255.0
ip access-list extended CompanyY
permit ip 192.168.2.0 255.255.255.0 any
permit ip any 192.168.2.0 255.255.255.0
Then write class-maps to match the ACLs, e.g:
class-map match-any CompanyX
match access-group name CompanyX
class-map match-any CompanyY
match access-group name CompanyY
Then use the class-maps in the policy-map, e.g:
policy-map sample
class CompanyX
shape or police 100000000
fair-queue
class CompanyY
shape or police 50000000
fair-queue
ā09-12-2016 06:51 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
On egress you might shape or police the traffic for your two companies, at your 100 and 50 Mbps.
On ingress you might police the traffic for your two companies, also at your 100 and 50 Mbps. However, as ingress policing is downstream of the traffic, it's won't always guarantee/limit the bandwidths, upstream, as specified. To really control your ingress you need to manage the other side's (your ISP's) egress.
ā09-13-2016 08:41 AM
Hi Joseph,
Thank you for your reply.
Packet shaping and policing are QoS?
Can you guide me along how do I perform shaping and policing on the egress and ingress traffic?
I appreciate.
Best Regards,
Ricky
ā09-13-2016 09:25 AM
For what platform (and its IOS version)?
ā09-13-2016 10:04 AM
Hi Joseph,
The platform and ISO is not made known yet.
Let me check it out and update again.
Best Regards,
Ricky
ā09-14-2016 04:25 AM
Hi Joseph,
The platform we using are CISCO 5548UP (7.0(5)N1(1)
Can you advise me on the policing and shaping configuration?
Best Regards,
Ricky
ā09-14-2016 06:49 AM
That's a Nexus?
If so, unable to recommend QoS setup for it.
ā09-14-2016 08:38 AM
Hi Joseph,
Noted. I need to do it on a router?
Best Regards,
Ricky
ā09-15-2016 10:18 AM
Not necessarily, although routers tend to have "better" QoS.
ā09-15-2016 08:53 PM
HI Joseph,
Knowing that the switch we be using is Nexus 5548 UP.
Is there any way we can perform bandwidth shaping on it. Splitting the bandwidth to 100M and 50M respectively.
Is there other alternative?
With Thanks and Regards,
Ricky
ā09-16-2016 12:33 AM
Hi Joseph,
How bout Cisco router 2911?
Can you advise me on the steps and config for policing and shaping of the 150M bandwidth to 100M and 50M respectively.
Best Regards,
Ricky
ā09-16-2016 03:35 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
A 2911 is undersized for 150 Mbps, but yes I can provide a representative sample.
Its QoS would be like that for other x9xx series.
Something like:
policy-map sample
class 100m
shape or police 100000000
fair-queue
class 50m
shape or police 50000000
fair-queue
Shape and FQ can only be used for an "out" policy. Police must be used on an "in" policy, but it can also be used for an "out" policy.
Class maps would define what traffic matches those classes.
ā09-16-2016 06:58 PM
Hi Joseph,
Thank you so much for the guidance.
The router will be connected to a switch.
After I implement the policy to the inbound and oubound interface of the router, do i need to perform any command on the switch?
Since 2 companies will be sharing the same internet, how does the switch determine know which network to send to?
Do I need to implement some policy or command in the switch also? Like ACL/Vlan?
Best Regards,
Ricky
ā09-17-2016 04:13 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
The switch should just forward traffic "naturally".
However, depending on the switch platform, many support some kind of policing too, usually ingress policing.
If the switch is used for policing, its hardware should handle it. I.e. it wouldn't have the impact on the device like such policing might on the router.
If you do use policing on a switch, yes, you might match to VLAN (or a network prefix) using ACLs.
ā09-18-2016 01:28 AM
Hi Joseph,
For the config of shaping and policing I have an idea now.
Pls pardon me I still dont get the picture how does the individual company network be using the appropriate shaped bandwidth.
The 2 companies will be sharing the infrastructure and bandwidth.
Cisco router 2911 (bandwidth shaped and policed) -> Nexus 5548
After the bandwidth is shaped and policed to 100M and 50M, how does individual company network select the appropriate shaped bandwidth?
Can you explain and provide an example how does the process work?
I really appreciate with much thanks.
Best Regards,
Ricky
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide