cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
760
Views
0
Helpful
4
Replies

Splitting bandwidth between different hosts

Adeel Hasany
Level 1
Level 1

Hi All,

 

I have a situation where customer asked me to split 10 Mb WAN circuit to 6 Mb and 4 Mb for the hosts from the same subnet. There are two different departments and due to some reason we cant split them into two networks at this stage. Is there a possibility to allocate 6 Mb for 50 hosts and 4 Mb for remaining hosts from a /24 network? 

 

Thanks 

Ad

1 Accepted Solution

Accepted Solutions

Hello

Folllowing on from Joesph suggestion, See the below shaping example for 10MB egress traffic spilt between two classsfications.

access-list 100 permit ip 172.16.1.0 0.0.0.127 any
access-list 101 permit ip 172.16.1.128 0.0.0.127 any

class-map match-all Lowhost_cm
match access-group 100

class-map match-all Highhost_cm
match access-group 101

policy-map Shape_Child_pm
class Lowhost_cm
bandwidth remaining percent 60

class Highhost_cm
bandwidth remaining percent 40

class class-default
fair-queue

policy-map Shape_Parent_pm
class class-default
shape average 10240000 160000
service-policy Shape_Child_pm


interface x/x
Description WAN
service-policy output Shape_Parent_pm

res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

4 Replies 4

Hello

Can these hosts split between the subnet 

ie: 50 host low end, 50 hosts high end or are they mixed

Or can they be split via specific application src / dst ports

if yes to any of these then it can be possible 

 

res

paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul,

 

Many thanks for your reply. cant split them up via specific application however, I can re address and divide the subnets. what will be your approach in this scenario?

 

Thanks 

Ad

Hello

Folllowing on from Joesph suggestion, See the below shaping example for 10MB egress traffic spilt between two classsfications.

access-list 100 permit ip 172.16.1.0 0.0.0.127 any
access-list 101 permit ip 172.16.1.128 0.0.0.127 any

class-map match-all Lowhost_cm
match access-group 100

class-map match-all Highhost_cm
match access-group 101

policy-map Shape_Child_pm
class Lowhost_cm
bandwidth remaining percent 60

class Highhost_cm
bandwidth remaining percent 40

class class-default
fair-queue

policy-map Shape_Parent_pm
class class-default
shape average 10240000 160000
service-policy Shape_Child_pm


interface x/x
Description WAN
service-policy output Shape_Parent_pm

res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Usually, you can.  (What you can do also depends on the platform being used.)

For egress you might have the choice of policing or shaping.  For ingress, you cannot shape.  (Policing ingress might not provide the exact results you desire.)

Also, for egress, rather than setting hard bandwidth limits, you might be able to prioritize 3:2, that way, hosts can take advantage of otherwise unused bandwidth.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: