cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
801
Views
0
Helpful
5
Replies

static routes configure

Hello,

Say Router A has a network of 10.89.0.1 behind it and Router B has network of 10.72.0.1 behind it.  Would I have two create a static route on both routers for 10.89.0.1 to connect 10.72.0.1 or do I need to create only static route on router a.  Like Say I need to telnet from 10.89.0.1 to 10.72.0.1 do I need two static routes both ways or only one?

Thanks,

5 Replies 5

Hi

You have something like:

Subnet 10.89.0.0/24 --- ROUTER A .1--10.0.0.0/30 ---.2 ROUTER B ---  Subnet 10.72.0.0/24
                                                                  Point to Point

So your config should be

Router A

ip route 10.72.0.0 255.255.255.0 10.0.0.2

Router B

ip route 10.89.0.0 255.255.255.0 10.0.0.1

The main idea is provide a path to each router to know how to reach the remote network the otherwise the packet will be dropped. You can test it with a traceroute or ping.

Please rate the comment if it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

So you would have to configure both routers not just one to telnet to network 10.72.0.0?

Hi 

If you are going to make telnet using the directly connected subnet (I mean from the router) for example, always using my config.

Router A

Telnet 10.0.0.2 

or Vice versa, you dont need static routes because you are using the network that connect both routers, but if you are going to do telnet from subnet behind a router to a remote subnet behind to other router, you need the static routes. 

Example

RouterA#telnet 2.2.2.2 /source-interface l0
Trying 2.2.2.2 ...

% Connection timed out; remote host not responding




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Imagine this config

ROUTER A:

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface F0/0
ip address 10.0.0.1 255.255.255.0

ip route 2.2.2.2 255.255.255.255 10.0.0.2

ROUTER B:

interface Loopback2
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0/0
ip address 10.0.0.2 255.255.255.0

username cisco privilege 15 password 0 cisco

line vty 0 4
login local
transport input all

From Router A, it will not work because Router B does not know the loopback 0 on Router A

RouterA#telnet 2.2.2.2 /source-interface l0
Trying 2.2.2.2 ...

% Connection timed out; remote host not responding

So if you add the static route on Router B

ip route 1.1.1.1 255.255.255.255 10.0.0.1

It will work.

RouterA#telnet 2.2.2.2 /source-interface l0
Trying 2.2.2.2 ... Open


User Access Verification

Username:

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

While there are some scenarios where the routers can communicate without static routes on both routers (especially when accessing via connected interface subnets) the general situation is that if you have subnets on each router that need to communicate with subnets on the other router then you will need static routes on both routers.

Perhaps the thing to keep in mind is that for successful communication you need a route for the initial packet to be sent and you need a route for the response to be sent. So both routers need a route to the subnet of the other router.

HTH

Rick

HTH

Rick
Review Cisco Networking products for a $25 gift card