cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
397
Views
0
Helpful
6
Replies

Static routing dont know whats the problem

Lukaskasc
Level 1
Level 1

Hey i have to submit a class project today can anyone can help me solve the problem with static routing? 

The help would be very much apprieciated :)

Adding the project in zip file because i cant post in other format

6 Replies 6

Hello,

 

nots sure what the requirements are, but try the below:

 

M1

ip route 0.0.0.0 0.0.0.0 Serial2/0

 

M2

ip route 172.16.182.192 255.255..255.192 Serial2/0

ip route 0.0.0.0 0.0.0.0 Serial3/0

 

M3

ip route 0.0.0.0 0.0.0.0 Serial3/0

!

interface Serial3/0

ip address 150.0.0.10 255.255.255.252

 

You are missing the above IP address on Serial3/0 on M3 as well...

@Georg Pauwen 

You dont want to default route between all three routers, you can easily cause a loop, you need to be more specific  than just adding defaults


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello,

 

I wanted to keep the config to a minimum; default routes in this case are sufficient, since all the connected routes are more specific; I needed just one specific route (as posted). 

Hello

@Georg Pauwen

 


@Georg Pauwen wrote:

default routes in this case are sufficient, since all the connected routes are more specific; I needed just one specific route (as posted). 


I believe that isn't the case, For example if a host from M3 tried to access a subnet via its default route then it will be routed to M2 and then if M2 didn't have a specific route also for the destination it will route it back towards M3 and then M3 will do the same again, hence a loop!.

 

Another example, host behind M1 did the same, it will be routed towards M1<->M2<->M3<->M2<-M3->M2.etc


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Paul.

 

not sure how you have configured the lab, here are my final configs (my additions are marked in bold). Hosts from all four segments, PC-PT PK 1.1 (172.16.182.194/24), PC-PT PK 2.2 (194.50.10.171/26), PC-PT PK 3.1 (205.70.8.130/29), and PC-PT PK 4.2 (205.70.8.67/29), can all mutually ping each other. I don't get any loops. Can you post your lab or configs for reference ? Curious where the difference is and how the loop occurs...

 

M1

 

Router#sh run
Building configuration...

Current configuration : 773 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.16.182.193 255.255.255.192
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 150.0.0.5 255.255.255.252
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial2/0
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

----------

 

M2

 

Router#sh run
Building configuration...

Current configuration : 833 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 194.50.10.169 255.255.255.192
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 150.0.0.6 255.255.255.252
clock rate 9600
!
interface Serial3/0
ip address 150.0.0.9 255.255.255.252
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 172.16.182.192 255.255.255.192 Serial2/0
ip route 0.0.0.0 0.0.0.0 Serial3/0
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

----------

 

M3

 

Router#sh run
Building configuration...

Current configuration : 804 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 205.70.8.129 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 205.70.8.65 255.255.255.248
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
ip address 150.0.0.10 255.255.255.252
clock rate 9600
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

Hello

Try the following:

 

M1
ip route 150.0.0.9 255.255.255.252 Serial2/0 150.0.0.6
ip route 205.70.8.128 255.255.255.248 Serial2/0 150.0.0.6
ip route 205.70.8.64 255.255.255.248 Serial2/0 150.0.0.6
ip route  194.50.10.168 255.255.255.192 Serial2/0 150.0.0.6


M2
ip route 172.16.182.192 255.255.255.192 Serial2/0 150.0.0.5
ip route 205.70.8.128 255.255.255.248 Serial3/0 150.0.0.10
ip route 205.70.8.64 255.255.255.248 Serial3/0 150.0.0.10


M3
ip route 150.0.0.4 255.255.255.252 Serial3/0 150.0.0.9
ip route 172.16.182.192 255.255.255.192 Serial3/0 150.0.0.9
ip route 194.50.10.168 255.255.255.192 Serial3/0 150.0.0.9

 

interface Serial3/0
ip address 150.0.0.10 255.255.255.252


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking for a $25 gift card