cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1463
Views
25
Helpful
9
Replies

Static Routing Noob

adam.cattell1
Level 1
Level 1

Hello, I'm taking an advanced routing course at college and we've been tasked with a project to configure routing by only using static routes to make each PC pingable from all the other PCs. I've been at it all day and I'm just stuck. I don't know what to do with the router in the middle. I think I have everything connected but again, I'm really not sure what I'm doing. 

this project is due on Monday 4/4 if anyone is able to help me before than please contact me through discord @  giraffe#0001. I don't know if I'll see this in time on here, but I'm usually always on discord. ill also attach the file here.2022-04-01 22_12_49-Greenshot.png   

1 Accepted Solution

Accepted Solutions

Hello,

 

I am not sure that this version (6.2) saves all the setting correctly, especially the PC settings. Make sure everything is configured as below:

 

Router0#sh run
Building configuration...

Current configuration : 788 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router0
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.55.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.15.55.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC0

IP: 172.16.3.2/24
DG: 172.16.3.1




Router1#sh run
Building configuration...

Current configuration : 785 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 10.10.8.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC2

IP: 10.10.8.2/24
DG: 10.10.8.1




Router3#sh run
Building configuration...

Current configuration : 793 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router3
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.100.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC3

IP: 192.168.1.2/24
DG: 192.168.1.1




Router4#sh run
Building configuration...

Current configuration : 783 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router4
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 10.1.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.17.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.17.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC4

IP: 10.1.10.2/24
DG: 10.1.10.1




Router5#sh run
Building configuration...

Current configuration : 1239 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router5
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.16.55.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
!
interface FastEthernet5/0
no ip address
!
interface FastEthernet6/0
ip address 192.168.100.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet7/0
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet8/0
ip address 10.1.17.2 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 172.16.3.0 255.255.255.0 172.16.55.1
ip route 10.10.8.0 255.255.255.0 10.10.10.1
ip route 192.168.10.0 255.255.255.0 192.168.4.1
ip route 192.168.1.0 255.255.255.0 192.168.100.1
ip route 10.1.10.0 255.255.255.0 10.1.17.1
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

View solution in original post

9 Replies 9

Hello
The PT you posted isnt readable, However see below for a solution but before you apply this configuration remove all current static routing  for al rtrs.

top left rtr
ip route 0.0.0.0 0.0.0.0 172.15.55.x (primary rtr ip)

bottom left rtr
ip route 0.0.0.0 0.0.0.0 10.10.8.x (primary rtr ip)

bottom rtr
ip route 0.0.0.0 0.0.0.0 192.168.10.x (primary rtr ip)


top right rtr
ip route 0.0.0.0 0.0.0.0 10.1.17.x (primary rtr ip)



bottom left rtr
ip route 0.0.0.0 0.0.0.0 192.168.100.x (primary rtr ip)


primay rtr
ip route 172.15.55.0 255.255.255.0 172.16.55.x (top left rtr ip)
ip route 10.10.8.0 255.255.255.0 172.16.55.x (bottom left rtr ip)
ip route 192.168.10.0 255.255.255.0 192.168.10.x (bottom rtr ip)
ip route 10.1.17.0 255.255.255.0 10.1.17.x (top right rtr ip)
ip route 192.168.100.0 255.255.255.0 192.168.100.x (bottom left ip)


 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I suspect (because I've had not double checked) what @paul driver is correct.  However, it may be unclear to you what and why Paul suggested what he did.

Routing looks at an incoming packet and compares that packet's destination address with all its known networks (i.e. their prefixes) and aggregates of such, or, and lastly, a "none of the above" (the latter is not done, by default).  Matching occurs from the most specific match to the least specific match.

In your diagram you have five networks containing hosts and five networks as transits between routers.

For packets to flow between devices, each router needs to know where to direct a received packet.  (If it doesn't, the packet is dropped.)

By default, routers know all the networks directly connected to them, but need to (somehow) be informed of networks not directly connected so they can forward the packet to the correct egress interface and to, sometimes, a known IP to forward packets to.

So, Paul "informs" the central router of all five (not directly connected) host networks and what IP to forward those packets to (the latter implying the router knows how to get to those IPs, which it does, as they are all directly connected networks.)  (BTW, Paul is assuming all those host networks are /24, but they could be smaller or larger.  In fact, using the old Classful network rules, I believe two are Class As, /8, one a Class B, /16, and two Class Cs, /24).

For the routers, either they need to be "informed" of the four other host networks, going via the central router, or, what Paul has done, is "inform" them, send "unknown" destinations to the central router.  I.e. one "wildcard" route on each host edge router replaces four routes that you would otherwise need.  (BTW, this would be the usual approach for a hub/spoke network.)

If you're still confused, post additional questions, because, the real goal, for such an assigned project, is to "learn" routing.

 

you explain more about this project than my professor has. thanks for this helpful information, it means alot to me!

hi paul! thanks for helping me out with this. it may not be readable due to my packet tracer being an older version, my school uses pt version 6.2. i've gone ahead and put a link to the file for you if you want to better look at mine. i was also wondering when you put the "x" in the command line what would i put for that? i'm also not sure if i have my ip configs correct. like i said i really dont know what im doing. i appreciate your help alot

 

Cisco Packet Tracer 6.2 

 

here is also a different way of getting my file if you need it

my pt file 

 

i added the commands in but the pc's still arent able to communicate with each other. i must be doing something else wrong that i dont know. 

Hello

You had multiple configuration errors, all your host pcs had the incorrect default-gateways and on some rtrs you had duplicate addressing.

 

Please review the working PT file.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

hi paul, I tried opening your file and i keep getting the error

the file is not compatible with this version of Packet Tracer.

Not sure why i am. 

Hello,

 

since I was working on the file in the version (6.2) you are, I might as well send my revised file. PT versions are not backward compatible, unfortunately, so hopefully you can open this one.

 

Apart from the static routing, all of your PCs had either the wrong IP address/subnet mask/default gateway. The IP address assignments of the inter-router links were often wrong (wrong IP addresses/subnet), hence all static routes were wrong as well. 

 

Have a look at the attached file, and try to make sense of it...

Hi George, I took a look at you file and was able to open it. I see all the work that you did, thank you I appreciate it! However, each PC is not pingable from all the other PCs. Not sure if it's something I'm doing wrong. 

Hello,

 

I am not sure that this version (6.2) saves all the setting correctly, especially the PC settings. Make sure everything is configured as below:

 

Router0#sh run
Building configuration...

Current configuration : 788 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router0
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.55.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.15.55.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC0

IP: 172.16.3.2/24
DG: 172.16.3.1




Router1#sh run
Building configuration...

Current configuration : 785 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 10.10.8.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC2

IP: 10.10.8.2/24
DG: 10.10.8.1




Router3#sh run
Building configuration...

Current configuration : 793 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router3
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.100.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC3

IP: 192.168.1.2/24
DG: 192.168.1.1




Router4#sh run
Building configuration...

Current configuration : 783 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router4
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 10.1.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.1.17.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.17.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




PC4

IP: 10.1.10.2/24
DG: 10.1.10.1




Router5#sh run
Building configuration...

Current configuration : 1239 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router5
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.16.55.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.10.10.2 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
no ip address
clock rate 2000000
shutdown
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
!
interface FastEthernet5/0
no ip address
!
interface FastEthernet6/0
ip address 192.168.100.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet7/0
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet8/0
ip address 10.1.17.2 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 172.16.3.0 255.255.255.0 172.16.55.1
ip route 10.10.8.0 255.255.255.0 10.10.10.1
ip route 192.168.10.0 255.255.255.0 192.168.4.1
ip route 192.168.1.0 255.255.255.0 192.168.100.1
ip route 10.1.10.0 255.255.255.0 10.1.17.1
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end