cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
338
Views
0
Helpful
2
Replies

Stuck at 10M internet access cisco 1841

bfeole001
Level 1
Level 1

fastethernet0/0 is the wan interface and I have no clue why it doesn't go above 10M when I run a speed test from directly behind the router. I'm plugged into a hatteras which says internally it's connected at 20M and full duplex on its lan interface. Any ideas? 

Freedom of expression is customer-eoc-gw#sho running-config
Building configuration...

Current configuration : 6098 bytes
!
! Last configuration change at 11:28:06 EDT Tue Mar 22 2016 by xxx
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxx-eoc
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
clock timezone EST -5
clock summer-time EDT recurring
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 10.90.2.1
ip dhcp excluded-address 10.90.2.101 10.90.2.254
ip dhcp excluded-address 10.90.3.1
ip dhcp excluded-address 10.90.3.101 10.90.3.254
!
ip dhcp pool Voice-pool
   network 192.168.100.0 255.255.255.0
   next-server 666.555.48.107
   default-router 192.168.100.1
   dns-server 222.444.82.2 222.444.84.201
   option 150 ip 666.555.48.107
   option 66 ip 666.555.48.107
!
ip dhcp pool Switch-test-pool
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
!
ip dhcp pool vlan92
   network 10.90.2.0 255.255.255.0
!
ip dhcp pool vlan93
   network 10.90.3.0 255.255.255.0
!
!
ip domain name customerdomain.com
ip name-server 8.8.8.8
ip name-server 4.4.4.4
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
vtp file vtp

username xxx privilege 15 secret 5
archive
 path flash:myconfig
 time-period 3
!
!
ip ssh rsa keypair-name somethingneato
ip ssh version 2
!
!
!
!
interface FastEthernet0/0
 description Connection to Hatteras$ETH-WAN$
 ip address 10.254.16.242 255.255.255.252 secondary
 ip address 222.444.117.18 255.255.255.252
 ip flow ingress
 --More--          ip flow egress
 ip nat outside
 no ip virtual-reassembly
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description customer LAN$ETH-LAN$
 ip address 222.444.107.33 255.255.255.224
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport mode trunk
!
interface FastEthernet0/1/1
 switchport trunk native vlan 10
 switchport mode trunk
!
interface FastEthernet0/1/2
 switchport access vlan 254
!
interface FastEthernet0/1/3
 description Voice Demo (Edgemarc router)
 switchport access vlan 20
!
interface Serial0/0/0
 description Backup 1.5M XO T1 to ourcompany PH/HCFS/740920//TQW
 bandwidth 1568
 ip address 222.444.117.182 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 no cdp enable
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 shutdown
!
interface Vlan10
 ip address 10.100.0.250 255.255.0.0
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 ip nat inside
 ip virtual-reassembly
!
interface Vlan91
 ip address 10.90.1.1 255.255.255.0
 ip helper-address 10.100.0.29
 ip nat inside
 ip virtual-reassembly
!
interface Vlan92
 ip address 10.90.2.1 255.255.255.0
 ip virtual-reassembly
!
interface Vlan93
 ip address 10.90.3.1 255.255.255.0
 ip virtual-reassembly
!
interface Vlan100
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Vlan170
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 10.100.0.29
 ip nat inside
 ip virtual-reassembly
!
interface Vlan180
 ip address 172.18.1.1 255.255.255.0
 ip helper-address 10.100.0.29
 ip nat inside
 --More--          ip virtual-reassembly
!
interface Vlan254
 description WAN connection for Voice router
 ip address 666.555.59.173 255.255.255.252
!
router bgp 65004
 no synchronization
 bgp log-neighbor-changes
 network 222.444.107.32 mask 255.255.255.224
 network 666.555.59.168 mask 255.255.255.252
 neighbor 222.444.117.17 remote-as 6372
 neighbor 222.444.117.17 description ourcompany XO EoC Primary Circuit
 neighbor 222.444.117.17 password asdfasdfasdf
 neighbor 222.444.117.17 update-source FastEthernet0/0
 neighbor 222.444.117.17 soft-reconfiguration inbound
 neighbor 222.444.117.17 weight 100
 neighbor 222.444.117.17 prefix-list ourcompany-Inbound in
 neighbor 222.444.117.17 prefix-list Outbound out
 neighbor 222.444.117.181 remote-as 6372
 neighbor 222.444.117.181 description ourcompany XO T1 Backup Circuit
 neighbor 222.444.117.181 password asdfasdfasdf
 neighbor 222.444.117.181 update-source Serial0/0/0
 neighbor 222.444.117.181 soft-reconfiguration inbound
 neighbor 222.444.117.181 prefix-list ourcompany-Inbound in
 neighbor 222.444.117.181 prefix-list Outbound out
 no auto-summary
!
ip forward-protocol nd
!
ip as-path access-list 50 permit ^6372_
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list 198 interface FastEthernet0/0 overload
ip nat inside source list 199 interface Serial0/0/0 overload
ip nat inside source static tcp 10.100.0.251 80 interface FastEthernet0/0 8080
ip nat inside source static tcp 10.100.0.252 80 interface FastEthernet0/0 8081
!
!
ip prefix-list ourcompany-Inbound seq 5 permit 0.0.0.0/0
!
ip prefix-list Outbound seq 5 permit 222.444.107.32/27
access-list 23 permit 222.444.65.2
access-list 99 permit 666.555.17.2
access-list 99 permit 666.555.17.1
access-list 99 permit 222.444.65.2
access-list 99 permit 10.100.0.249
access-list 99 permit 222.444.84.197
access-list 198 permit ip 172.16.1.0 0.0.0.255 any
access-list 198 permit ip 172.18.1.0 0.0.0.255 any
access-list 199 remark Voice vlan NAT
access-list 199 permit ip 192.168.100.0 0.0.0.255 any
access-list 199 permit ip host 10.0.100.251 any
access-list 199 permit ip host 10.0.100.249 any
snmp-server community derp RO
snmp-server community derpy RW 99
snmp-server contact poop
snmp-server chassis-id company-eoc
!
route-map FilterFromourcompany permit 10
 match as-path 50
 set metric 200
!
!
!
control-plane
!
!
banner exec ^C

** This system restricted to uses approved by Kung Fu Enterprises **
^C
banner login ^C

** This system restricted to uses approved by Kung Fu Enterprises **
 --More--         ^C
!
line con 0
 login local
line aux 0
line vty 0 4
 session-timeout 30
 access-class 99 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 99 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17178418
ntp server 666.555.7.2
end

2 Replies 2

Philip D'Ath
VIP Alumni
VIP Alumni

What results do you get if you plug a notebook directly into the "hatteras" ?

Are you sure the hatteras is hard coded to 100/full, as opposed to auto/auto?  You will have big issues if only one end is hard coded.

I just found this thread because i was having the same issue. My outside interface was hard coded for speed and duplex. I took that off and fixed it instantly. Thanks

Review Cisco Networking for a $25 gift card