cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Suggestions to correct VPLS configuration or use something else.

kossuth78
Beginner
Beginner

So currently we have 2x 3945 routers that are extending two VLANs through a DMVPN from one hub site to the other.  Our WAN connections only have a 1500 MTU.  We are extending the VLANs currently with pseudowire interfaces and Xconnect because that's what the 3945s supported when the requirement popped up.  This has worked for us, but obviously the pseudowire and Xconnect method has some limitations and quirks, chief among them is that Xconnect is point to point only.  We are getting ready to life cycle the 3945s with 4331s.  I intended to convert to VPLS mostly to gain the ability to multipoint the layer II connections if I had to.  There is no requirement from management to do that today but if I can bake it in now I might as well.  I have the 4331s in the lab and the configuration is MOSTLY working but I've hit an unforeseen snag.  The extended VLANs on our older Xconnect method were the standard 1500 MTU.  With Xconnect, the router would automatically fragment and reassemble a packet even though the packet would technically overshoot the WAN MTU with the DMVPN and Xconnect overhead by 150 bytes or so.  For the most part our requirements for the layer II extensions were merely for application redundancy, and the bandwidth requirements are very modest for the applications in question.  So if router does some fragmenting and packet reassembly that's not really a concern.  The current 3945s with Xconnect use only 15% CPU and memory.   

The problem:  In the lab testing I have noticed with VPLS is that anything above a 1250 MTU wouldn't pass through the tunnel.  After researching the problem I figured out that the WAN link should have a higher MTU due to the overhead of the VPLS and DMVPN connections on the 1500 MTU WAN connection.  Obviously I didn't foresee this.  While I haven't looked into it yet; I imagine changing the WAN MTU to say 1700 or higher on our WAN connections is probably a non starter.  Management isn't happy about the bill now. 

Is there something I've missed in the configuration that would allow the router to fragment these packets, or am I going to need to rethink the protocol I use?  I've attached the VPLS components from my configuration.  Thanks for looking.    

2 REPLIES 2

paul driver
VIP Expert VIP Expert
VIP Expert

Hello
Alternative possibly  l2 vxlan?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

kossuth78
Beginner
Beginner

Figured I'd give an update to this.  In short both VPLS and VxLAN are built with the intention of having a MTU larger than 1500 as your forwarding link.  So neither would work for me.  I know this solution has been covered before but I figured I'd attach a snippet of what was needed to make everything via xconnect. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: