09-23-2023 05:24 PM
Hi all,
I've been working on a lab project and have gotten most of my configuration done but have run into two separate issues on my multi-layer switch that I've been stuck on.
The first issue involves OSPF, it works just fine once configured, however, once you close and re-open the packet tracer file the multi-layer switch forgets the routing commands for VLANs 10,20,and 30 (ip ospf 1 area 1) and they need to be re-configured each time the packet tracer file is opened and closed. I've saved the running configuration to the start-up configuration on the multi-layer switch but that doesn't seem to save. Is this a packet tracer bug? Or am I possibly missing a command?
The second issue is enabling TACACS on the multi-layer switch. From my reading and what I've seen online it seems like it's set-up on the multi-layer switch exactly like it is on the router however once configured it tells me even the local username and password that is setup through commands is invalid. This configuration works fine on the router however and I'll include it below:
****************
Router TACACS
****************
en
conf t
aaa new-model
username cisco password cisco
aaa authentication login default group tacacs+ local
aaa authorization exec default group tacacs+
tacacs-server host 10.210.83.67
tacacs-server key 1234
line vty 0 4
login authentication default
end
Here's the running config for my multi-layer switch as well in case the issue is being caused by my prior setup work:
Current configuration : 2339 bytes
!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname MultilayerSwitch
!
!
!
!
!
!
!
no ip cef
ip routing
!
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet1/0/1
description To_Switch-Users
switchport mode trunk
!
interface GigabitEthernet1/0/2
description To_Switch-Admin
switchport mode trunk
!
interface GigabitEthernet1/0/3
no switchport
ip address 10.210.83.2 255.255.255.192
ip ospf 1 area 1
duplex auto
speed auto
!
interface GigabitEthernet1/0/4
description To_Server
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description Server
mac-address 00d0.bc3b.7a01
ip address 10.210.83.66 255.255.255.192
ip helper-address 10.210.83.67
!
interface Vlan20
description Users
mac-address 00d0.bc3b.7a02
ip address 10.210.83.130 255.255.255.192
ip helper-address 10.210.83.67
!
interface Vlan30
description Admin
mac-address 00d0.bc3b.7a03
ip address 10.210.83.194 255.255.255.192
ip helper-address 10.210.83.67
!
router ospf 1
router-id 10.210.83.2
log-adjacency-changes
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
logging 10.210.83.67
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
ntp authentication-key 1234 md5 082F585E19181604 7
ntp authenticate
ntp trusted-key 1
ntp trusted-key 1234
ntp server 10.210.83.1
ntp update-calendar
!
end
09-23-2023 08:21 PM
for problem 1 : I don't know if this is a bug but try configuring ospf in config mode instead of under interface, it should save on closing PT and work.
for problem 2 : Open the sample tacacs Lab and make sure your TACACS service config is correct, you won't be able to login with local credential since line is not set for login local anymore.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide