cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
384
Views
0
Helpful
2
Replies

Topology and FailOver problem

farguisito
Level 1
Level 1

Hi,

 

I need to config the new router but I need some details of your router.

 

The topology is the next.

 

                               ISP 1 >  Cisco 800 -> Cisco 881-4G (with SIM, ISP2) -> LAN

 

I know that this topology is a little rare but I must config with these devices.

 

Cisco 800 have the network 192.168.1.1 255.255.0.0 and I can´t change it. I must config the Cisco 881-4G with FailOver.

 

I have the next code however I don’t know if I will have any problem with this.

 

Maybe I have to do the Cisco 881-4G a mix of Switch/router ( I don´t know if I can do it) because I don´t want to change the gateway of every device of the LAN (192.168.1.1)

 

Could anybody help me please??

 

Thanks in advance.

 

Regards.

cellular 0 lte profile create 1 internet.vodafone.pt chap vodafone vodafone ipv4
config t
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
line 3
script dialer lte
exit


flow record nbar-appmon
match ipv4 source address
match ipv4 destination address
match application name
collect interface output
collect counter bytes
collect counter packets
collect timestamp absolute first
collect timestamp absolute last
exit
!
!
flow monitor application-mon
cache timeout active 60
record nbar-appmon
exit

interface Vlan 1
!
description vlan1
!
ip address 192.168.1.254 255.255.0.0
!
no shutdown
!
ip nat inside
!
ip nat enable
!
end
!
config t
!
interface cell0
!
ip address negotiate
!
encap slip
!
dialer in-band
!
dialer-group 1
!
ip nat outside
!
no shutdown
!
exit
!
dialer-list 1 protocol ip permit
!
interface fastethernet 4
!
description
!

no ip address
!
ip dhcp client route track 22
!
ip address dhcp
!
ip flow ingress
!
no shutdown
!
ip nat outside
!
ip nat enable
!
exit
!
interface FastEthernet 0
!
switchport mode access
!
switchport access Vlan 1
!
no shutdown
!
exit
!
interface FastEthernet 1
!
switchport mode access
!
switchport access Vlan 1
!

no shutdown
!
exit
!
interface FastEthernet 2
!
switchport mode access
!
switchport access Vlan 1
!
no shutdown
!
exit
!
interface FastEthernet 3
!
switchport mode access
!
switchport access Vlan 1
!
no shutdown
!
exit
!
ip access-list extended NAT
!
permit ip 192.168.0.0 0.0.255.255 any
!
exit
!


!


access-list 101 permit ip 192.168.0.0 0.0.255.255 any
no access-list 1 permit 10.10.10.0 0.0.0.7
no access-list 23 permit 10.10.10.0 0.0.0.7
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 23 permit 192.168.0.0 0.0.255.255


!
ip nat inside source list 101 interface fa04 overload
!
ip nat inside source list NAT interface cell0 overload
!
ip nat inside source static tcp 192.168.1.200 80 192.168.1.1 80 extendable
ip nat inside source static tcp 192.168.0.171 554 192.168.1.1 80 554 extendable
ip nat inside source static tcp 192.168.0.172 1024 192.168.1.1 80 1024 extendable
ip nat inside source static tcp 192.168.0.173 1025 192.168.1.1 80 1025 extendable
ip nat inside source static tcp 192.168.0.171 2080 192.168.1.1 80 2080 extendable


end
!
config t
!

ip routing
ip route 4.2.2.2 255.255.255.255 DHCP
ip sla 33
icmp-echo 4.2.2.2 source-interface FastEthernet4
threshold 500
timeout 1000
frequency 3
exit
ip sla schedule 33 life forever start-time now
track 22 ip sla 33 reachability
delay down 3 up 1
exit

ip dhcp-client default-router distance 200
ip route 0.0.0.0 0.0.0.0 cell0 201
!

ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool cvo-pool
import all
network 192.168.1.1 255.255.0.0
default-router 192.168.1.1
dns-server 8.8.4.4
lease 0 2
!
end
!

2 Replies 2

farguisito
Level 1
Level 1

Could anybody help me, please???

Thanks.

Regards.

Hi farguisito,

you can use NHRP as fail over service between your Cisco 800 and "Cisco 881-4G",
according to the configuration from your Cisco 881-4G, the configuration can look something
like that:

Cisco 881-4G
interface vlan 1
ip address 192.168.1.253 255.255.0.0
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt delay reload 300

Cisco 800
track 100 interface <InterfaceToISP1> line-protocol

interface vlan 1
ip address 192.168.1.254 255.255.0.0
standby 1 ip 192.168.1.1
standby 1 track 100 20
standby 1 preempt delay reload 300

So the Cisco 800 is normaly the Master now when your Interface to ISP1 goes down the
priority is decreased by 20 and for the Cisco 800 on 80, the Cisco 881-4G has 90 as default
and with the preempt, the device will take over the ip 192.168.1.1.
You can also define other tracker (like sla monitor or something like that).

To better understand NHRP read this:
http://www.cisco.com/c/en/us/td/docs/ios/12_4/ip_addr/configuration/guide/hadnhrp.html

Best regards