11-05-2021 04:33 PM
I created Vlans 10,20,30,40 on switch1. I am trying to trunk them to switch2.
I used the following commands to add vlans to trunk interface on switch1:
Switch(config)#int g1/0/2
Siwtch(config-if)#switchport trunk allowed vlan 10-40
Command #show int trunk
Says vlans allowed on trunk interface: 10,20,30,40
Says vlans allowed and active in management domain: 10,20,30,40
Says vlans in spanning tree forwarding state and not pruned: 10,20,30,40
I used the following commands to add the vlans to trunk interface on switch2
Switch(config)#int g0/1
Siwtch(config-if)#switchport trunk allowed vlan 10-40
Command #show int trunk
Says vlans allowed on trunk are 10-40
Says vlans allowed and active in management domain: 10
Says vlans in spanning tree forwarding state and not pruned: 10
Can anyone tell me why vlan 10 is the only vlan showing up as allowed, active in management domain and spanning tree forwarding state? How do I get the other vlans to show up as active and in the spanning tree forwarding state? thanks!!
Solved! Go to Solution.
11-05-2021 07:33 PM - edited 11-05-2021 07:33 PM
Hello my friend..
trunking vlan doenst means that you i've created the vlan layer 2 itself.
i think you need create vlan first.
try create it..
conf t:
vlan 10
vlan 20
vlan 30
etc.
thank you
11-05-2021 08:42 PM
Hello @tacit.cheddar ,
as noted by @Jaderson Pessoa likely vlans 20,30,40 are missing from vlan database on switch 2.
even if we can create a Vlan "on the fly" by using
interface gi1/0/5
switchport
switchport mode access
switchport access vlan X
this is not true for trunk ports as you need to manually create the missing VLANs on switch2
conf t
vlan 20
name VLAN20
exit
vlan 30
name VLAN30
exit
vlan 40
name VLAN40
exit
compare the two VLAN databases using
show vlan
show spanning-tree summaty on both switches
Hope to help
Giuseppe
11-05-2021 07:33 PM - edited 11-05-2021 07:33 PM
Hello my friend..
trunking vlan doenst means that you i've created the vlan layer 2 itself.
i think you need create vlan first.
try create it..
conf t:
vlan 10
vlan 20
vlan 30
etc.
thank you
11-05-2021 08:42 PM
Hello @tacit.cheddar ,
as noted by @Jaderson Pessoa likely vlans 20,30,40 are missing from vlan database on switch 2.
even if we can create a Vlan "on the fly" by using
interface gi1/0/5
switchport
switchport mode access
switchport access vlan X
this is not true for trunk ports as you need to manually create the missing VLANs on switch2
conf t
vlan 20
name VLAN20
exit
vlan 30
name VLAN30
exit
vlan 40
name VLAN40
exit
compare the two VLAN databases using
show vlan
show spanning-tree summaty on both switches
Hope to help
Giuseppe
11-07-2021 01:42 PM - edited 11-07-2021 02:22 PM
Thank you all for the replies... I must have done something wrong when I originally created the same vlans on both switches.... but I re-did it and it worked! so thank you all again!
11-06-2021 12:39 AM
Hello,
on a side note, in order to make sure that the Vlan databases on switches are synchronized, typically VTP is being used. The configs for both switches would be:
Switch 1
Switch_1#conf t
Switch_1(config)#vtp domain yourdomain
Switch_1(config)#vtp mode server
Switch_1(config)#vtp password yourpassword
Switch_1(config)#vtp version 2
Switch 2
Switch_2#conf t
Switch_2(config)#vtp domain yourdomain
Switch_2(config)#vtp mode client
Switch_2(config)#vtp password yourpassword
Switch_2(config)#vtp version 2
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide