cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
857
Views
0
Helpful
7
Replies

Trunks not going thru to SVI on router .. Pleaase help

nwekechampion
Beginner
Beginner

Hi all,

 

I am using vtp to create and manage my vlans.

I have one distribution layer switch as vtp server and 2 access layer switches.

VTP works fine on all switches. However, I am unable to get the router on the other end to receive the trunks.

Please see diagram attached. I do not have the ALS2 in my setup.

 

ALSW_02(config-vlan)#do sh run
Building configuration...

Current configuration : 4455 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ALSW_02
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$7kVu$rP.sYZwy9RuiLMV0FZaB2.
!
username Lab password 0 Test
!
!
no aaa new-model
switch 1 provision ws-c3750-24p
system mtu routing 1500
vtp domain CISCO
vtp mode transparent
authentication mac-move permit
ip subnet-zero
ip domain-name champ.com
!
!
!
!
crypto pki trustpoint TP-self-signed-3149302016
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3149302016
revocation-check none
rsakeypair TP-self-signed-3149302016
!
!
crypto pki certificate chain TP-self-signed-3149302016
certificate self-signed 01
30820249 308201B2 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33313439 33303230 3136301E 170D3933 30333031 30303031
30375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31343933
30323031 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100B890 CC31E966 6A1862FD EC830A6E E091317E E139370E EA1E8899 D6889073
DAC0F7E5 9AEC1D62 7778E82E 4C9B867B 8B7829D9 D0107B45 BE8E44AA A19F1EF3
76064F86 03E70F25 74105A7F 543C106F 230DC2C7 B06EBE02 747A608A E4DEF98F
6AF26273 213EB9FF 2232E9E3 0AA48CD8 4E864491 E9BA9C39 A77C7F96 A3D66E68
F1770203 010001A3 71306F30 0F060355 1D130101 FF040530 030101FF 301C0603
551D1104 15301382 11414C53 575F3032 2E636861 6D702E63 6F6D301F 0603551D
23041830 1680143A B646A508 B3C7E57F 7DB84610 160A82A6 40A22F30 1D060355
1D0E0416 04143AB6 46A508B3 C7E57F7D B8461016 0A82A640 A22F300D 06092A86
4886F70D 01010405 00038181 0035B859 EA8025C7 786699E1 9B552CF4 E4C81416
BC8B289C 6B64E988 26E54CF7 6DC0D59C F28D098C 976D9780 7E0E5F8C 0DC9D6D3
2F522B1A 58E0A53D E5673DDB 43C661EE 5BA8E84F 3A6ABD04 CE8348C1 7C8596B1
82727427 38594F35 75E211D4 05FEB8E8 740F319C 701EC9DD D4EF3EC6 5047A3D2
FE1DBBA6 FD5E9C0A FB4CD9EE 3C
quit
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree vlan 10,40 priority 4096
!
vlan internal allocation policy ascending
!
vlan 10
name red
!
vlan 20
name blue
!
vlan 30
name orange
!
vlan 40
name green
!
vlan 300
name test
!
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface FastEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
shutdown
!
interface FastEthernet1/0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet1/0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode desirable
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/16
switchport access vlan 40
switchport mode access
!
interface FastEthernet1/0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet1/0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet1/0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet1/0/20
!
interface FastEthernet1/0/21
!
interface FastEthernet1/0/22
!
interface FastEthernet1/0/23
!
interface FastEthernet1/0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
ip address 192.168.2.7 255.255.255.0
no ip route-cache
no ip mroute-cache
!
interface Vlan10
ip address 192.168.10.7 255.255.255.0
no ip route-cache
no ip mroute-cache
shutdown
!
interface Vlan40
ip address 192.168.40.7 255.255.255.0
no ip route-cache
no ip mroute-cache
!
ip classless
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!
!
line con 0
line vty 0 4
exec-timeout 60 0
login local
transport input ssh
line vty 5 15
login
!
end
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

R1(config-if)# do sh run
Building configuration...

Current configuration : 1119 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$V11/$uDC5Q6xw72CDxX/3GoPAR1
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
!
!
ip domain name champ.com
!
multilink bundle-name authenticated
!
!
vtp domain CISCO
vtp mode transparent
username Lab password 0 Test
!
!
archive
log config
hidekeys
!
!
vlan 10
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
switchport mode trunk
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 192.168.2.1 255.255.255.0
!
interface Vlan40
ip address 192.168.40.1 255.255.255.0
no autostate
!
router eigrp 12
network 192.168.0.0
no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
exec-timeout 60 0
login local
transport input ssh
!
scheduler max-task-time 5000
end

 

7 Replies 7

Hi @nwekechampion,

Are you trying to receive the vlan database on R1# (the Router)?

From the configuration, R1# is set to VTP Transparent mode which forwards but does not add the vlan database locally.

Hi Hector,

Yes I am, however, I was unable to put the vtp mode on "client" on the router (Cisco 800 series).
It just would not change. Keeps reverting to "Transparent". Also, I am curious to know why it only allowed VLAn 10 through.

Thanks for ur reply

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

switch

ip route 0.0.0.0 0.0.0.0 vlan 1 192.168.2.1

 Also allow vlan 1 on the trunks

 

rtr

no int vlan 40

ip route 192.168.10.0 255.255.255.0 vlan1 192.168.2.7

 

ip route 192.168.40.0 255.255.255.0 vlan1 192.168.2.7

 

Router rip

ver 2

no auto summary 

network 192.168.2.0

redistribute static 

 

int x/x

description link to switch 

Switchport mode access

switchport  access vlan 1

spanning-tree portfast

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi There,

 
Thanks for your reply Paul.
 
I fixed this issue by creating a vlan manually on the router.
It sems to  be a limitation with the cisco 800 series svi's when used for trunking.
Also seems to only alow a maximum of 4 vlans
 
 
However, I will givve this a go and see if it does change anything..
Thanks again
 
Thanks so much

Anony
Beginner
Beginner

Hi Dear,

As per shared:

1- Shutdown the interfaces that are not required. Do no shut to trunk connected toward the router:

interface FastEthernet1/0/1

no shutdown

2- Unnecessary trunks are configured, you need to change them to access, default or shutdown.

3- There is no IP Address assign to the router interface.

4- Separate the range of IP Address that you need to assign to router interface and the Mgmt port to every switch. (Your every switch and router should be in same network ).

5- Point a gateway to the edge device when all vlan (10,20,30,40) data is coming with respective settings.

6- Check the interface trunk ports for vlan if that are learning in them.

7- Verify the channel status if its up and working fine. Match the configurations from the physical interface and the interface port-channel X. From the configurations showing I don't think so that traffic will work as per current scenario. Figure you network diagram for smooth flow best practice is to connect the router with distribution switch. Hope I reach the right point to understand what you are asking.

Please rate the helpful post.

Regards,

Please rate helpful, thanks.

Hi There,

Thanks for your reply.

I fixed this issue by creating a vlan manually on the router.
It sems to be a limitation with the cisco 800 series svi's when used for
trunking.
Also seems to only alow a maximum of 4 vlans


Thanks so much

Brother please mark as a solution on helpful comment so someone can go through this troubleshooting to resolve the issue as well.

 

Thanks for reply.

Please rate helpful, thanks.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers