cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
37939
Views
29
Helpful
15
Replies

two isp, two networks & one router

seclucscon
Level 1
Level 1

Hi, I have 1 router (Cisco 2921), 2 ISP Link & 2 networks(one is 172.16.0.0 & another is 192.168.0.0).  I want to pass 2 networks by 2 different ISPs, like 172.16.0.0 will be passed by ISP 1 & 192.168.0.0 will be passed by ISP 2. I have 1 firewall attached with this router.

How can i do this in 1 router that  two network will be divided by two ISPs? How the natting will be done for 2 link??

Can anyone please help me in this issue urgently??

15 Replies 15

Hello,

This should do the trick:

!

ip sla 1

icmp-echo 100.0.0.1

ip sla schedule 1 life forever start-time now

ip sla 2

icmp-echo 200.0.0.1

ip sla schedule 2 life forever start-time now

!

track 1 ip sla 1 state

!

track 2 ip sla 2 state

!

int g0/0

ip nat outside

!

int g0/1

ip nat outside

!

int LAN

description connection to ASA

ip nat inside

ip policy route-map PBR

!

ip route 0.0.0.0 0.0.0.0 next_hop_isp1 gi0/0 track 1

ip route 0.0.0.0 0.0.0.0 next_hop_isp1 gi0/0 track 2

!        

ip nat inside source route-map isp1 interface FastEthernet0/0 overload

ip nat inside source route-map isp2 interface FastEthernet0/1 overload

!

ip access-list extended LAN1

permit ip 172.16.0.0 0.0.255.255 any

ip access-list extended LAN2

permit ip 192.168.0.0 0.0.31.255 any

!

access-list 10 permit 172.16.0.0 0.0.255.255

access-list 10 permit 192.168.0.0 0.0.31.255

!

route-map PBR permit 10

match ip address LAN1

set ip next-hop verify-availability 100.0.0.1 1 track 1

!

route-map PBR permit 20

match ip address LAN2

set ip next-hop verify-availability 200.0.0.1 1 track 2

!

route-map isp1 permit 10

match ip address 10

match interface Gi0/0

!

route-map isp2 permit 10

match ip address 10

match interface Gi0/1

!

What exactly do you mean by "merge 2 links"? With configuration above you are using both links in same time so traffic load is some sort of divided between both links.

If you want to implement more complex loadbalancing, take a look at Cisco Performance Routing PfR ->

http://blog.ine.com/2011/11/01/cisco-performance-routing-pfr-optimized-edge-routing-oer/

If you meant by "merge" to create some sort of "etherchannel" it is no possible.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
Review Cisco Networking for a $25 gift card