10-15-2012 05:10 AM - edited 03-04-2019 05:51 PM
in test sample below everithing works correctly as expected ,
but problem is that if i change route-map dst "set ip next-hop 200.0.0.2 " to "set interface fastethernet 1/0"
than i am loosing conection to 222.222.222.222.
reason that i want to change route-map statement is that in reality one of my link is pppoe,
so i dont exactely know what will be the gateway next time router will take new ip.
i have two options
more prefered 1) leave defaulgt gateway assigned on pppoe and write PBR for second link for which i have gateway ip
less prefered 2) call provider and ask what can be the potential gateways , so that i can put all of them in "set ip next-hop verify-availibility x.x.x.x track xxx" command.
will be thankful, if someone can offer me better option.
interface FastEthernet0/0
description LAN
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip policy route-map dst
!
interface FastEthernet0/1
description isp1
ip address 100.0.0.1 255.255.255.0
ip nat outside
!
interface FastEthernet1/0
description isp2
ip address 200.0.0.1 255.255.255.0
ip nat outside
ip route 0.0.0.0 0.0.0.0 100.0.0.2
!
ip nat inside source route-map isp1 interface FastEthernet0/1 overload
ip nat inside source route-map isp2 interface FastEthernet1/0 overload
!
ip access-list extended dst
permit ip 10.0.0.0 0.0.0.255 host 222.222.222.222
ip access-list extended nat
permit ip 10.0.0.0 0.0.0.255 any
!
route-map isp2 permit 10
match ip address nat
match interface FastEthernet1/0
!
route-map isp1 permit 10
match ip address nat
match interface FastEthernet0/1
!
route-map dst permit 10
match ip address dst
set ip next-hop 200.0.0.2
10-15-2012 05:41 AM
Hello Archil,
in IOS command reference there are options for DHCP learned gateway but I don't see for PPP or PPPoE sessions
see
I would try to ask to the provider a list of gateways that can be used with the PPPoE service
Hope to help
Giuseppe
10-16-2012 02:32 AM
"
but problem is that if i change route-map
dst
"set ip next-hop 200.0.0.2 " to "set interface fastethernet 1/0""
This looks like your provider is not using proxy arp. Nothing that you can change.
regards,
luis
10-16-2012 03:20 AM
during the tests in lab environment all of the devices were "proxy arp" enabled, still "set interface fastethernet 1/0" did not helped.
i have tested also command
"set ip next-hop dynamic dhcp" and actually it has solved problem (at least in lab environment with ethernet intrfaces), but its interesting if i will have two interfaces , that are both taking settings from dhcp , which gateway will be choosen by this command.
10-16-2012 03:31 AM
The isp doesn't have proxy arp, is not your interface, you can take the route through pppoe with "ppp ipcp rotue default" command.
regards,
luis
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide